nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Install problem :: FC6 64 bits & 7900Gs. (http://www.nvnews.net/vbulletin/showthread.php?t=79526)

SebKaine 11-04-06 07:23 PM

Install problem :: FC6 64 bits & 7900Gs.
Hi !

i've try to install the nvidia drivers on my fedora 6 64 bits , but without any sucess !

i first try with the livna package. The 2 livna files are install correctly, but nothing seems to work after reboot (no nvidia logo, nothing in xconf.org) . I uninstall the 2 livna package in order to give a try to the official driver.

my config is :
- 7900 GS
- Core 2 Duo

I try to install the AMD64/EM64T > NVIDIA-Linux-x86_64-1.0-8776-pkg2.run drivers :
- i check that all the package were Ok
- i've done the
# yum install kernel-devel xorg-x11-server-sdk pkgconfig
# yum update
# reboot
- SELinux is not activated
- i run the driver without X running !

At the beginning all looks find , i see the driver downloading from NVIDIA FTP , but when the progression is at 100% i've got this Error : Unable to build the NVIDIA kernel module.

i Guess something is missing but i don't know what ... Maybe the 7900GS GPU is not yet supported ?

Here is my : nvidia-installer.log

Thanks for your supports

Best regards


gmp 11-05-06 12:21 PM

Re: Install problem :: FC6 64 bits & 7900Gs.
We've had the EXACT same problem except we're on AMD 275/85 Opterons and 3450, 4500 and 5500 graphics (on over 100 machines).

I would prefer to use the 8774 driver as it's what our vendors are supporting, although both the current driver and the 8774 driver installing is always the best situation.

Lastly, Lonni suggested:


I'd suggest reading this, and if you need further assistance, start a new thread, as this one is unrelated to the problem you're reporting.

If you read this carefully and also read through this and SebKaine's post you will note that BOTH of us are using smp kernels. The 2.6.18 kernels have NATIVE smp support, which means that if you have an FC5 or FC6 machine and run yum update as suggested in that posting you will not find the kernel-smp-devel rpm because it no longer exists.

The question I have is 'has anyone at Nvidia actually installed FC6, run an update and actually got a driver to install?'

With all this in mind I think it's probably time to edit http://www.nvnews.net/vbulletin/showthread.php?t=72490 and update it to reflect changes to the way kernels handle smp support and actually test this so those of us with $100K + invested in Nvidia graphics cards can get our damn systems working with FC6.


netllama 11-05-06 12:53 PM

Re: Install problem :: FC6 64 bits & 7900Gs.
I'm typing this on a system running FC6 with the NVIDIA X driver, so the answer to your question is, yes. There have also been quite a few other threads on this forum from FC6 users who are using the nvidia driver without difficulty.

I've updated the sticky post to better reflect changes in FC6.

Thanks for your feedback.


gmp 11-05-06 01:44 PM

Re: Install problem :: FC6 64 bits & 7900Gs.
So just to be sure we're getting things correct here I'm going to post our install procedure. I am beginning to suspect this has a lot to o with the xen kernel. If anyone knows how to install the non-xen kernel please feel free to enlighten us.

all from init level 3:

[root@ignatowski tmp]# uname -a
Linux ignatowski.gmp-vfx.com 2.6.18-1.2798.fc6xen #1 SMP Mon Oct 16 14:59:01 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux

[root@ignatowski tmp]# rpm -qa kernel-devel xorg-x11-server-sdk pkgconfig

[root@ignatowski 2.6.18-1.2798.fc6-x86_64]# pwd

[root@ignatowski 2.6.18-1.2798.fc6-x86_64]# ls
arch    include        lib            scripts
block    init            Makefile        security
crypto  ipc            mm              sound
drivers  kabi_whitelist  Module.symvers  symsets-2.6.18-1.2798.fc6.tar.gz
fs      kernel          net            usr

So we see that we do indeed have the kernel source...

So we go ahead and install using the usual method...


after going through the usual options we get the following error:

  ERROR: Unable to find the kernel source tree for the currently running
        kernel.  Please make sure you have installed the kernel source files
        for your kernel and that they are properly configured; on Red Hat
        Linux systems, for example, be sure you have the 'kernel-source' RPM
        installed.  If you know the correct kernel source files are
        installed, you may specify the kernel source path with the
        '--kernel-source-path' command line option.

So we go back and add the --kernel-source-path arguement:

./NVIDIA-Linux-x86_64-1.0-8776-pkg2.run --kernel-source-path /usr/src/kernels/2.6.18-1.2798.fc6-x86_64/
it gets all the way through and appears to be building the kernel module until:

  ERROR: Unable to build the NVIDIA kernel module.
Thoughts? Advice?

netllama 11-05-06 01:48 PM

Re: Install problem :: FC6 64 bits & 7900Gs.
Xen kernels are unsupported at this time. Please retest with a non-Xen kernel. I'm not sure that I understand your question about how to install a non-xen kernel, as the process is the same as installing the xen kernel (rpm -ivh kernel*).


gmp 11-05-06 01:53 PM

Re: Install problem :: FC6 64 bits & 7900Gs.
1 Attachment(s)

Thanks for the quick feedback.

I just tried with the non-xen kernel (which is installed with the default install of FC6 as it turns out).

Same result.

I am enclosing the log file.


netllama 11-05-06 02:00 PM

Re: Install problem :: FC6 64 bits & 7900Gs.
See here:
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it

This is a known issue (alraedy discussed with a workaround in several other threads on this forum) which will be resovled in the next driver release.


SebKaine 11-05-06 03:02 PM

Re: Install problem :: FC6 64 bits & 7900Gs.
Thanks for your answers guys ! in fact i've got this message :

echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it
."; \

Lonni , if i understand, there is no solution at this time ! the problem come from the driver itself , and i've to wait for a driver update ?

gmp 11-05-06 03:04 PM

Re: Install problem :: FC6 64 bits & 7900Gs.

Thanks, that did it.

I'm posting the original fix suggested by Zander here to wrap up the thread.



Originally Posted by zander
You can fix this problem by extracting the .run installer with the --extract-only option and updating the file usr/src/nv/nv-linux.h to #include linux/autoconf.h instead of linux/config.h.

SebKaine 11-05-06 03:08 PM

Re: Install problem :: FC6 64 bits & 7900Gs.
gmp you make it works ? i'm not sure i fully understand zander process ! i'm just a beginner in the linux world ...

SebKaine 11-06-06 09:12 AM

Re: Install problem :: FC6 64 bits & 7900Gs.
well i finally go back under Windows ! Linux is cool ! but 3 days to try to install a graphics driver , it's a little bit longer than the 10 seconds on XP ! :D As 3D artist I try few times to make the switch on linux , but each time i had to go back on XP ! Cause on XP , things works quickly , and spending so much hours for just installing driver / find package etc ... its a huge waste of time ! Last time i give a try to fedora it takes me 13hours to install the drivers and make them work with Maya , today it is 3 days ! Sad to see that time evolve , but linux complexity stay the same !

gmp 11-06-06 01:22 PM

Re: Install problem :: FC6 64 bits & 7900Gs.
Good luck with that. I have to say that as a major studio we don't even have any windows machines in the building. If you really want to excel in the business I would suggest that you had better come to grip with working in linux because Windows is simply unsuitable in a large production context.

This is a technical business and you'd better embrace the technical aspects or you'll be one of those perpetual junior artists that never get advanced because they can't shell script, use mel, write shaders, etc.

If you want to et the driver working you can try this:

1. log in as root
2. edit the file /etc/inittab so that the following line:

is changed to:

3. copy the installer to /tmp
4. reboot

Now you'll notice that X did not start. This is good.

5. log in as root.
6. cd /tmp
7. make sure the driver is executable

chmod +x ./NVIDIA-Linux-x86_64-1.0-8762-pkg2

8. run the installer in extract only mode

./NVIDIA-Linux-x86_64-1.0-8762-pkg2 --extract-only

this extracts the installer file into a directory.

9. cd into this directory and you'll see that there's a whole bunch of directories inside.

10. cd usr/src/nv/
11. ls and look for the file nv-linux.h
12. edit the line
#include linux/config.h
to read:
#include linux/autoconf.h

13. save the file
14. cd /tmp
15. cd into the driver directory again and you'll see the driver installer script.
16. run the script
> ./nvidia-installer

This should install the driver. If you are on a 64 bit machine YOU SHOULD INSTALL the 32-bit compatability libraries.

17. reboot
18. Log back in as root
19. type >init 5

This will bring your run level up to 5 and start X, etc.

I would work to configure your xorg.conf file with the inittab file still set to 3. This way if you screw up you can still get the machine to boot easily. Once you have an xorg.conf file working you can change the inittab file back to run level 5.

Let me know what monitors your running and perhaps I can suggest an xorg.conf configuration. If you don't know, the xorg.conf file resides in /etc/X11/

Welcome to the world of real operating systems.


All times are GMT -5. The time now is 01:41 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.