nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Legacy Graphics Cards (http://www.nvnews.net/vbulletin/forumdisplay.php?f=37)
-   -   Force composite (http://www.nvnews.net/vbulletin/showthread.php?t=79550)

Regis_G 11-05-06 07:30 AM

Force composite
 
Hello,

I've just upgrade my computeur from an old Mandrake 9.2 OS to a gentoo system. The nvidia tv out worked fine; it was the 4496 driver version. I had to force the composite output throught the svideo connector to get color on my tv.

It doesn't work anymore. I can only get a black and white screen because I can only use SVIDEO format. If I force the composite output, I haven't got any image on my tv.

Here is my xorg.conf

Code:

Section "ServerLayout"
        Identifier    "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/misc"
        FontPath    "/usr/share/fonts/75dpi"
        FontPath    "/usr/share/fonts/100dpi"
        FontPath    "/usr/share/fonts/TTF"
        FontPath    "/usr/share/fonts/Type1"
EndSection

Section "Module"
        Load  "dbe"
#        Load  "dri"
        Load  "extmod"
        Load  "record"
        Load  "xtrap"
        Load  "glx"
        Load  "freetype"
        Load  "type1"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "Extensions"
        Option "Composite" "disable"       
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mouse0"
        Option            "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        #DisplaySize          350  260        # mm
        Identifier  "Monitor0"
        VendorName  "IQT"
        ModelName    "Q995"
 ### Comment all HorizSync and VertSync values to use DDC:
        HorizSync    10.0 - 60.0
        VertRefresh  10.0 - 60.0
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "SWcursor"                  # [<bool>]
        #Option    "HWcursor"                  # [<bool>]
        #Option    "NoAccel"                    # [<bool>]
        #Option    "ShadowFB"                  # [<bool>]
        #Option    "UseFBDev"                  # [<bool>]
        #Option    "Rotate"                    # [<str>]
        #Option    "VideoKey"                  # <i>
        #Option    "FlatPanel"                  # [<bool>]
        #Option    "FPDither"                  # [<bool>]
        #Option    "CrtcNumber"                # <i>
        #Option    "FPScale"                    # [<bool>]
        #Option    "FPTweak"                    # <i>
        Option "TVStandard" "PAL-B"
#        Option "TVOutFormat" "COMPOSITE"
        Option "UseInt10Module" "false"
        Option "ConnectedMonitor" "TV"
        Option "HorizSync" "10.0-50.0"
        Option "VertRefesh" "60"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName  "NV18 [GeForce4 MX 440 AGP 8x]"
        BusID      "PCI:3:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultColorDepth 16
        SubSection "Display"
                Viewport  0 0
                Depth    1
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    4
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    8
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    15
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    16
                Modes "800x600"
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes "800x600"
        EndSubSection
EndSection

Any suggestion ?

Thanks by advance

Jesper 01-03-07 02:48 PM

Re: Force composite
 
Hi guys, it has been a while since I was here last, so greetings to everyone :)

I have a problem similiar to Regis_G.

Here is my issue etc.
My Tv is connected via composite to my FX5200 card, when I add
Code:

Option "TVOutFormat" "Composite"
to my xorg.conf file nothing happens, I tried both a simple init 3/5 and a full reboot but my TV stays in black and white, if I switch the s-video cable to the front panel of my TV (yes I know its a stupid place to have the S-video but its not my design :D) then my TV is in colors, this happens both with and without the "TVOutFormat" set, so I am sure that the option isnt even being read by the driver, and looking at the Xorg.0.log I see
Code:

(WW) NVIDIA(0): Option "TVoutputFormat" is not used
Someone please give me a hint :)

Here is the content my xorg.conf
Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Fri Dec 15 10:13:06 PST 2006

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath        "/usr/X11R6/lib/X11/rgb"
    FontPath        "unix/:7100"
EndSection

Section "Module"
    Load          "dbe"
    Load          "extmod"
    Load          "type1"
    Load          "freetype"
    Load          "glx"
EndSection

Section "ServerFlags"
    Option        "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbLayout" "dk"
    Option        "XkbModel" "pc105"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "___ VL770FS"
    HorizSync      30.0 - 70.0
    VertRefresh    50.0 - 135.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Videocard0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce FX 5200"
    Option        "TVoutputFormat" "Composite"
    Option        "TVStandard" "PAL-B"
    Option        "NoLogo" "True"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "1"
    Option        "metamodes" "CRT: nvidia-auto-select +0+0, TV: nvidia-auto-select +0+0"
    SubSection    "Display"
        Depth      24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

System:
Fedore Core 6 @ Kernel 2.6.18-1.2869.fc6
nVIDIA card: FX5200
Driver Version nvidia-x11-drv-1.0.9746-1 (FreshRPMs Release)


All times are GMT -5. The time now is 09:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.