nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Loads of resolutions with incorrect refresh rates with 9626 [Fixed] (http://www.nvnews.net/vbulletin/showthread.php?t=79569)

l_bratch 11-05-06 02:39 PM

Loads of resolutions with incorrect refresh rates with 9626 [Fixed]
 
I've just got the 1.0-9626 drivers down, but when I run xrandr, I now get the following:

Code:

SZ:    Pixels          Physical      Refresh
*0  1600 x 1200  ( 383mm x 282mm )  *50  56  57  58 
 1  1280 x 1024  ( 306mm x 240mm )  51  62  63 
 2  1280 x 960    ( 306mm x 225mm )  52  64 
 3  1024 x 768    ( 245mm x 180mm )  53  67  68  69  70  71  72 
 4    800 x 600    ( 191mm x 141mm )  54  77  78  79  80  81  82  83  84 
 5    640 x 480    ( 153mm x 112mm )  55  90  91  92  93  94  95 
 6  1600 x 1024  ( 383mm x 240mm )  59 
 7  1400 x 1050  ( 335mm x 246mm )  60  61 
 8  1152 x 864    ( 276mm x 203mm )  65 
 9  1152 x 768    ( 276mm x 180mm )  66 
 10  960 x 720    ( 230mm x 169mm )  73 
 11  928 x 696    ( 222mm x 163mm )  74 
 12  896 x 672    ( 214mm x 158mm )  75 
 13  832 x 624    ( 199mm x 146mm )  76 
 14  800 x 512    ( 191mm x 120mm )  85 
 15  720 x 400    ( 172mm x  94mm )  86 
 16  640 x 512    ( 153mm x 120mm )  87  88  89 
 17  640 x 400    ( 153mm x  94mm )  96 
 18  640 x 350    ( 153mm x  82mm )  97 
 19  576 x 432    ( 138mm x 101mm )  98 
 20  576 x 384    ( 138mm x  90mm )  99 
 21  512 x 384    ( 122mm x  90mm )  100  101  102  103  104
 22  416 x 312    (  99mm x  73mm )  105
 23  400 x 300    (  95mm x  70mm )  106  107  108  109  110
 24  360 x 200    (  86mm x  47mm )  111
 25  320 x 240    (  76mm x  56mm )  112  113  114  115
 26  320 x 200    (  76mm x  47mm )  116
 27  320 x 175    (  76mm x  41mm )  117

With the old 8xxx drivers, I only got the resolutions I specified, and the refresh rates were right.

For instance, xrandr shows that I am running at 1600x1200@50Hz, but I'm actually running at 1600x1200@75Hz.

This is only a problem because certain games are picking up the refresh rates available from xrandr, and believe they don't support for instance 50Hz.

Any idea how to solve this?

Relevant parts of xorg.conf:

Code:

Section "Monitor"

    Identifier  "My Monitor"

    HorizSync  30-95

    VertRefresh 50-152

EndSection

Section "Device"
    Identifier  "** NVIDIA (generic)                  [nv]"
    Driver      "nvidia"
    Option      "NoLogo" "1"
    Option      "CoolBits" "1"
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "** NVIDIA (generic)                  [nv]"
    Monitor    "My Monitor"
    DefaultDepth 24

    Subsection "Display"
        Depth      8
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth      16
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth      24
        Modes      "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection

This is with a 7900 GTX.

zander 11-05-06 02:43 PM

Re: Loads of resolutions with incorrect refresh rates with 9626
 
This is the expected default behavior as of 1.0-96xx; please see the documentation for the DynamicTwinView X configuration file option in the README for details.

l_bratch 11-05-06 02:53 PM

Re: Loads of resolutions with incorrect refresh rates with 9626
 
Thanks, that fixed it.


All times are GMT -5. The time now is 04:11 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.