nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1.0.9626 - No 1440x900 (http://www.nvnews.net/vbulletin/showthread.php?t=79578)

Phenax 11-05-06 04:35 PM

1.0.9626 - No 1440x900
 
1 Attachment(s)
On 1.0.8776 it could establish 1440x900 perfectly. Now, I can't. Also, it seems that GLX is working, as it previously did.
I've generated a bug report, on Xorg verbose level 6.

netllama 11-05-06 04:54 PM

Re: 1.0.9626 - No 1440x900
 
There are two problems here. First, the driver isn't correctly installed as you're not using the glx module that ships with the nvidia driver. You should reinstall the driver to fix this:
(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3

The problem with the mode is here:
(II) NVIDIA(0): Validating Mode "1440x900":
(II) NVIDIA(0): 1440 x 900 @ 61 Hz
(II) NVIDIA(0): Mode Source: EDID
(II) NVIDIA(0): Pixel Clock : 108.00 MHz
(II) NVIDIA(0): HRes, HSyncStart : 1440, 1520
(II) NVIDIA(0): HSyncEnd, HTotal : 1672, 1904
(II) NVIDIA(0): VRes, VSyncStart : 900, 903
(II) NVIDIA(0): VSyncEnd, VTotal : 909, 934
(II) NVIDIA(0): H/V Polarity : +/+
(WW) NVIDIA(0): Mode is rejected: Mode (1440 x 900) is too large for DFP
(WW) NVIDIA(0): EDID (Max: 1280 x 1024).

You can work around this by adding the following option to xorg.conf:
Option "ModeValidation" "NoEdidDFPMaxSizeCheck"

Thanks,
Lonni

Phenax 11-05-06 11:40 PM

Re: 1.0.9626 - No 1440x900
 
Thanks Lonni, I got it going.

It was actually a distro-specific error with GLX. On Gentoo I had forgot to do a "eselect opengl set nvidia" whereas default it's set to xorg-x11.

You hit the mode right on the money. Thanks.


All times are GMT -5. The time now is 12:35 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.