nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   FC6 - getting NVIDIA driver to work -my experience (http://www.nvnews.net/vbulletin/showthread.php?t=79585)

dclunie 11-05-06 07:21 PM

FC6 - getting NVIDIA driver to work -my experience
 
Decided to replace my FC5 install with FC6 (what an idiot) and expected trouble with the nvidia driver as usual, but this was a bit beyond the norm.

Here is a summary of what it took for me to get it to work in case it helps someone else; this is derived from lots of hints from other messages around the place, but I could not find a consolidated set of instructions.

Bottom line is xen kernels will not work, linux/config.h is no longer present in kernel development sources and nvidia installer expects it, and explicit specification of path to kernel sources is required since nvidia installer cannot find them.

Installed fresh FC6 from DVD image with ALL packages selected

# yum -y remove kdegraphics-devel kdepim-devel # else yum update fails dependencies
# yum -y update
# yum -y install kernel-devel
# yum -y install kernel.x86_64 # since only xen kernel was installed
# vi /etc/grub.conf
... edit to use the non-xen kernel just installed as the new default
# wget http://download.nvidia.com/XFree86/L...-8776-pkg2.run
# sh NVIDIA-Linux-x86_64-1.0-8776-pkg2.run -x
# cd NVIDIA-Linux-x86_64-1.0-8776-pkg2.run
# vi ./usr/src/nv/nv-linux.h
... edit to remove #include linux/config.h
# init 3
# ./nvidia-installer --kernel-source-path /usr/src/kernels/2.6.18-1.2798.fc6-x86_64
... successful compiles, loads modules, but crashes trying to make xorg.conf

Just used the old FC5/nvidia xorg.conf that had been working before and it still works just fine.

Tried the beta 9625 driver and it works too ... this time the xorg.conf phase did not crash (whether having in place the xorg.conf from the initial FC6 install, or my old one, before running the installer).

David

netllama 11-05-06 07:27 PM

Re: FC6 - getting NVIDIA driver to work -my experience
 
This sticky post has documented the steps required for quite a while:
http://www.nvnews.net/vbulletin/showthread.php?t=72490

dclunie 11-05-06 07:43 PM

Re: FC6 - getting NVIDIA driver to work -my experience
 
Except that the sticky post you refer to does not mention:

- not using the xen kernel
- editing out the include for linux/config.h
- specifying the source path

and hence would seem to be incomplete or insufficient (it was, obviously, the first place I looked).

David

netllama 11-05-06 07:56 PM

Re: FC6 - getting NVIDIA driver to work -my experience
 
You shouldn't need to specify the source path. If you do, then you didn't follow all the steps in the sticky post.

I've updated the sticky post to reflect the current status of Xen kernels.

Thanks for your feedback,
Lonni

plasmoidia 11-05-06 10:02 PM

Re: FC6 - getting NVIDIA driver to work -my experience
 
You know, it really is a whole lot easier to install the driver RPM from Livna:
http://rpm.livna.org/
Install their RPM to setup the repository (http://rpm.livna.org/rlowiki/UsingLivna) and a quick:
yum install kmod-nvidia
will get you setup. After it installs, just restart X. It even updates when the kernel is updated (as long as the package has been built at the time, of course). And if you want the beta driver:
yum --enablerepo=livna-testing install kmod-nvidia

snapfisher 11-06-06 10:36 PM

Re: FC6 - getting NVIDIA driver to work -my experience
 
I was not able to get the livna rpm installed on an x86_64 FC6 install. I also did get it working throught the nvidia installer (which rebuilt the driver as part of the install), with just a single nagging annoyance left.....

Rick Bilonick 11-06-06 11:35 PM

Re: FC6 - getting NVIDIA driver to work -my experience
 
It took a lot of work to install 8776 on my FC6 system. (The nvidia driver worked fine on FC5 and earlier.) Now it's installed but whenever I try to run mplayer, xine, or kaffeine to display HDTV .ts streams, the system ALWAYS freezes within a few seconds. The X11 freeze is so bad, I can't even do a ctrl alt F! to get to a text consol. So the system with FC6 is unusable for viewing HDTV.

Rick Bilonick 11-06-06 11:36 PM

Re: FC6 - getting NVIDIA driver to work -my experience
 
Forgot to mention that this is an Athlon 64 system. Previously, I was running FC5 without problems. (I have another almost identical system running FC5.) Also, I'm using a 5700 LE video display card.

dachelb 11-07-06 09:25 AM

Re: FC6 - getting NVIDIA driver to work -my experience
 
> whenever I try to run mplayer, xine, or kaffeine to display HDTV .ts streams,
> the system ALWAYS freezes within a few seconds.

This is my experience with MythTV (XvMC Enabled) , 8776, and FC6. Within a few minutes (5-15) or when changing channels the entire computer locks up.

I turned off XvMC in myth and the problem disappears...and the Xvmc playback - while it *slightly* reduces processor load - stutters and slows down really bad.


All times are GMT -5. The time now is 08:33 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.