nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia drivers 9629 slowness issue (http://www.nvnews.net/vbulletin/showthread.php?t=79740)

fafreeman 11-07-06 07:54 PM

Nvidia drivers 9629 slowness issue
 
2 Attachment(s)
Okies. About a month ago I tried the Nvidia drivers 9626 when they were spotted on ftp://download.nvidia.com/XFree86/. My distro is Gentoo, and they added them to portage last month and I upgraded to them. When I did I noticed big performance drops, glxgears was only showing 6,000fps instead of my normal 13,000fps I get on my 6800GT. All my OpenGL apps started to lag bad, and games like UT2004 dropped 20+ fps. So I downgraded back to 9625 and everything worked great again. Well today when the Nvidia 9629 drivers final was released I installed them, and again, the same issues I had with 9626 back in October I am still having with this version, but even now my cpu usage is up more. I went and installed Xorg again thinking that was it, did nvidia-xconfig to make a new Xorg.conf, but nothing seemed to work. Am I missing something in my Xorg or is it just the new drives don't like my card?

EDIT: For the time being, I went back to the 9625 drivers since they work perfectly. No slow downs or anything in that nature.. I just wonder what would be causing the 9629 drivers to cause such a slow down in everything? I tried the ones from Gentoo and Nvidia site.. Same thing..

acedog 11-07-06 09:29 PM

Re: Nvidia drivers 9629 slowness issue
 
I don't know if you are running compiz, but I get an FPS which is about half when I do. I just disable compiz when I want the extra performance. However, I have had this issue with both the 9625 and the new 9629 drivers. (BTW I have an old 6800 which gives me 10000 under glxgears without compiz and 5000 when I have compiz running.)

fafreeman 11-07-06 10:16 PM

Re: Nvidia drivers 9629 slowness issue
 
Quote:

Originally Posted by acedog
I don't know if you are running compiz, but I get an FPS which is about half when I do. I just disable compiz when I want the extra performance. However, I have had this issue with both the 9625 and the new 9629 drivers. (BTW I have an old 6800 which gives me 10000 under glxgears without compiz and 5000 when I have compiz running.)

I'm not running it with compiz. Man, I don't even want to see how low it would go in Compiz with the 9629 drivers... Nice to know i'm not the only one though.

I did try them again and this time I wasn't even able to run UT2004.. It kept freezing and had to kill it.. I shall be keeping 9625 for awhile now..

quantumanomaly 11-07-06 10:28 PM

Re: Nvidia drivers 9629 slowness issue
 
I can confirm my FPS drop from 16k to 7k using Nvidia 9629 and a GeForce 6800 Ultra PCIe
Amd64 X2 4800+

El_Presidente 11-08-06 04:32 AM

Re: Nvidia drivers 9629 slowness issue
 
1 Attachment(s)
i already opened a thread with the same problem
i have a 6800gt made by XFX
i get 7fps!!! in ut 2004 with the 9626 and 9629 drivers
9625 drivers give me 70-100fps ...

here is my bugreport log again

energyman76b 11-08-06 07:03 AM

Re: Nvidia drivers 9629 slowness issue
 
well, I don't have any slowdowns.

Differences:
you:
/proc/driver/nvidia/cards/0
Model: GeForce 6800 GT
IRQ: 21
Video BIOS: 05.40.02.36.09
Card Type: PCI-E
DMA Size: 32 bits
DMA Mask: 0xffffffff

me:
Model: GeForce 6600
IRQ: 90
Video BIOS: 05.43.02.61.00
Card Type: PCI-E
DMA Size: 39 bits
DMA Mask: 0x7fffffffff

you: dual core
me: single core

you:
/proc/iomem
00000000-0009f3ff : System RAM
00000000-00000000 : Crash kernel
0009f400-0009ffff : reserved
000a0000-000bffff : Video RAM area
000c0000-000c7fff : Video ROM
000f0000-000fffff : System ROM
00100000-7fedffff : System RAM

me:
00000000-0009fbff : System RAM
0009fc00-0009ffff : reserved
000a0000-000bffff : Video RAM area
000c0000-000c7fff : Video ROM
000f0000-000fffff : System ROM
00100000-3ffaffff : System RAM

you:
/proc/mtrr
reg00: base=0x00000000 ( 0MB), size=2048MB: write-back, count=1
reg01: base=0x7ff00000 (2047MB), size= 1MB: uncachable, count=1

me:
cat /proc/mtrr
reg00: base=0x00000000 ( 0MB), size=1024MB: write-back, count=1

do you have kexec or something like that in your kernel?

El_Presidente 11-08-06 07:10 AM

Re: Nvidia drivers 9629 slowness issue
 
well you dont have a 6800 series ...

quantumanomaly 11-08-06 10:11 AM

Re: Nvidia drivers 9629 slowness issue
 
The fact that you're free from that sort of problem is something you should be happy about!
Still, many of us are having this problem, i am sure. And the slowdowns are quite unnerving.

There is one thing you failed to mention, are you using IA32 or X86_64?
My machine is dual core and running under 64 bits...

energyman76b 11-08-06 03:59 PM

Re: Nvidia drivers 9629 slowness issue
 
amd64

fafreeman 11-08-06 06:01 PM

Re: Nvidia drivers 9629 slowness issue
 
Seems this bug only affects the 6800* series. Any Nvidia devs want to identify this as a bug? I was thinking though that maybe our 3D accel is not being activated.. Iv noticed when GLXGears is started on the drivers that do work, and any other 3D accel app, my video card makes a humming noise, but doesn't with the 9626 and 9629 drivers.. Also, when I was looking in my log I didn't see 3D accel activated in it, only 2D.. I may be wrong.. Wheres the Nvidia devs!

Also, theres new Nvidia beta drivers out. I'm gonna give them a shot to see if they fix this issue.

http://www.nzone.com/object/nzone_do...etadriver.html

EDIT:! New Nvidia beta drivers fix this issue.. No slowdowns or loss of FPS... Amazing.. Try those drivers to see if they work for you!

El_Presidente 11-09-06 04:47 AM

Re: Nvidia drivers 9629 slowness issue
 
yup it fixes it but i get an X error when i want to start world of warcraft.

e X t 7 3 11-09-06 05:13 AM

Re: Nvidia drivers 9629 slowness issue
 
Quote:

Originally Posted by fafreeman
Okies. About a month ago I tried the Nvidia drivers 9626 when they were spotted on ftp://download.nvidia.com/XFree86/. My distro is Gentoo, and they added them to portage last month and I upgraded to them. When I did I noticed big performance drops, glxgears was only showing 6,000fps instead of my normal 13,000fps I get on my 6800GT. All my OpenGL apps started to lag bad, and games like UT2004 dropped 20+ fps. So I downgraded back to 9625 and everything worked great again. Well today when the Nvidia 9629 drivers final was released I installed them, and again, the same issues I had with 9626 back in October I am still having with this version, but even now my cpu usage is up more. I went and installed Xorg again thinking that was it, did nvidia-xconfig to make a new Xorg.conf, but nothing seemed to work. Am I missing something in my Xorg or is it just the new drives don't like my card?

EDIT: For the time being, I went back to the 9625 drivers since they work perfectly. No slow downs or anything in that nature.. I just wonder what would be causing the 9629 drivers to cause such a slow down in everything? I tried the ones from Gentoo and Nvidia site.. Same thing..

You have RIGHT ... when I have had 6800 GS @16/6 @425@1200 MHz on AGP my glxgears drop something about 1000-1200 glgears ... with old drivers I had 15900-16000 and with new 14800-15200 ... now I have 7900 Gs @600/1600 MHz and all is oki glg ALWAYS (old and new drivers) =19600-20150


All times are GMT -5. The time now is 06:42 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.