nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   TFT display jitters/trembles (GeForce Go 7600 256MB) (http://www.nvnews.net/vbulletin/showthread.php?t=80083)

chni 11-10-06 10:26 PM

TFT display jitters/trembles (GeForce Go 7600 256MB)
 
2 Attachment(s)
Hi,

On my Ubuntu 6.10 notebook (1400x1050, 60 Hz) the display flickers every now and then when I use the "nvidia" driver (in contrast the preinstalled "nv" default driver works fine). The entire screen contents seem to move a pixel row down and right and back in a split second once a half minute.

Maybe it's just a simple sync problem?
Unfortunately I could't find exactly the same issue in this forum, not to mention a solution.

Attachment 21868
Attachment 21869

GeForce Go 7600 256MB

thanks in advance!

chni 11-13-06 05:30 AM

TFT display jitters/trembles (GeForce Go 7600 256MB)
 
1 Attachment(s)
Bug report:
Attachment 21929

netllama 11-13-06 01:42 PM

Re: TFT display jitters/trembles (GeForce Go 7600 256MB)
 
Does this problem persist with the 1.0-9629 or 1.0-9742 drivers?
Have you verified that you're using the latest BIOS?

Thanks,
Lonni

chni 11-13-06 06:29 PM

Re: TFT display jitters/trembles (GeForce Go 7600 256MB)
 
Hi Lonni,

Thank you for your suggestions, usually I install the drivers that are available in the Ubuntu repositories.

Now I tried to install the latest stable driver as you suggested (1.0-9629). But I get the error: "API mismatch: the NVIDIA kernel module has the version 1.0-7184, but this X module has the version 1.0-9629. ..." and Xorg refuses to start.

My BIOS is the latest version:
PhoenixBIOS
BIOS Version 11XE
MICOM Version 11XE

-- according to the Samsung download page for R65 this is the recent version.

PS: Where may I verify the MD5 sum of the driver installer?

netllama 11-13-06 07:12 PM

Re: TFT display jitters/trembles (GeForce Go 7600 256MB)
 
See:
http://www.nvnews.net/vbulletin/showthread.php?t=72490

chni 11-13-06 08:47 PM

Re: TFT display jitters/trembles (GeForce Go 7600 256MB)
 
Now I tried both the
NVIDIA-Linux-x86-1.0-9629-pkg1.run
and
NVIDIA-Linux-x86-1.0-9742-pkg1.run
drivers but I was not able to install the drivers properly:

NVIDIA-Linux-x86-1.0-9629-pkg1.run:
When I did
Code:

rmmod nvidia
it worked, but unfortunately my Compiz didn't work any more (it was only white - the entire screen/cube), and refresh rate was 50 Hz despite 60 Hz :(

NVIDIA-Linux-x86-1.0-9742-pkg1.run:
The installer says
Code:

ERROR: Unable to determine the NVIDIA kernel module filename.
ERROR: Installation has failed.  Please see the file
      '/var/log/nvidia-installer.log' for details.  You may find suggestions
      on fixing installation problems in the README available on the Linux
      driver download page at www.nvidia.com.

Why wouldn't those drivers install smoothly?
Would'nt it be more easily to provide DEB-files instead of those installers which bypass the package manager?

I despair of it...
Maybe it would be just a small entry in /etc/X11/xorg.conf which solved the issue. Is there a way to verify whether the graphics card is defective?

PS: How may I verify the MD5 checksum of those files?

netllama 11-13-06 10:18 PM

Re: TFT display jitters/trembles (GeForce Go 7600 256MB)
 
I'd need to see the installer log to determine why the driver didn't install.

Thanks,
Lonni

chni 11-14-06 08:42 AM

Re: TFT display jitters/trembles (GeForce Go 7600 256MB)
 
1 Attachment(s)
Installer log:
Attachment 21960

chni 11-14-06 01:22 PM

Re: TFT display jitters/trembles (GeForce Go 7600 256MB)
 
Hi,

Now NVIDIA-Linux-x86-1.0-9629-pkg1.run runs pretty fine. Glxgears was very slow when I installed this driver for the first time. But now, after installing xserver-xorg-dev (1:1.1.1-0ubuntu12) glxgears runs smoothly :D .
EDIT3: I uninstalled nvidia-glx as claimed in http://www.nvnews.net/vbulletin/showthread.php?t=72490: Now Glxgears is very very slow.

Unfortunately Compiz doesn't work with 1.0-9629, don't know why (Compiz doesn't tell me anything). The Compiz window borders just aren't loaded.
Sadly when I'm not able to start Compiz I won't see those nasty jitters any more. Maybe you could support me get Compiz up and running?

I tried the following versions:
  • 0.0.13.38-0ubuntu3
  • 0.3.2 from the freedesktop.org website
They behaved the same.

EDIT: How may I prevent the "nvidia" module from being loaded, I need to do rmmod nvidia every time I boot. I tried adding it to /etc/modprobe.d/blacklist but the system didn't boot any more with this entry. [SOLVED]

EDIT2: no textures any more in Neverball with 1.0-9629

thx

chni 11-14-06 01:41 PM

Re: TFT display jitters/trembles (GeForce Go 7600 256MB)
 
1 Attachment(s)
Attachment 21975


All times are GMT -5. The time now is 02:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.