nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   7900 gs no 3d accelaration (http://www.nvnews.net/vbulletin/showthread.php?t=80147)

cboehme1 11-11-06 04:59 PM

7900 gs no 3d accelaration
 
1 Attachment(s)
Update: My bad: I relied on the wrong tools, gnome-xgl-settings and glxgears. Turned out, manually setting Xgl as X-server worked without hitch...

OK, I tried the whole day to get my new 7900gs based card working with Linux (vanilla SuSE 10.1 for x64). It works flawlessly in Winxp; the 6600gt based card I had before also worked well within SuSE.

The problem is that I can't activate 3D accel: glxgears is slow and gnome-xgl-settings says I need to activate 3D. glxinfo says direct rendering is activated, the nvidia module is loaded, and I don't see any errors in in Xorg.0.log (no EE marked lines). I have tried NVIDIA-Linux-x86_64-1.0-8776-pkg2.run and NVIDIA-Linux-x86_64-1.0-9629-pkg2.run without luck.

Interesting sections from xorg.conf:
Section "Module"
Load "type1"
Load "dbe"
Load "freetype"
Load "glx"
Load "v4l"
Load "extmod"
EndSection

Section "Device"
BoardName "GeForce 7900 GS"
BusID "5:0:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVidia"
EndSection

It was created by sax. I have attached the nvidia bug report. Any ideas?

netllama 11-11-06 05:06 PM

Re: 7900 gs no 3d accelaration
 
glxgears is not a benchmark. Which real world OpenGL applications are also slow?

cboehme1 11-11-06 05:21 PM

Re: 7900 gs no 3d accelaration
 
You are right... I thought that it at least should look fast, and also was confused by gnome-xgl-settings refusing to activate 3D effects, because presumably no 3D-acceleration was available. However, simply setting Xgl as default X-Server did the trick. Sorry for wasting your time! :o


All times are GMT -5. The time now is 08:10 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.