nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Problem with Nforce2 Sound on Suse 8.1 (http://www.nvnews.net/vbulletin/showthread.php?t=8035)

kybernetikos 02-26-03 07:41 PM

Problem with Nforce2 Sound on Suse 8.1
 
I wonder if anyone can help me with this problem - I've been all over these forums and can't see anything that quite matches. I'm running the Nforce2 that's in the recent shuttles, and I've downloaded the unified nvidia driver and the graphics one. The accelerated graphics works fine, as does the network card, now I'm just trying to get sound to work.

When I try to configure in Yast2, it just tells me that an error occurred. I'm a bit of a linux newbie, but I read what others were doing so I tried
insmod i810_audio:

Using /lib/modules/2.4.19-4GB/kernel/drivers/sound/i810_audio.o
/lib/modules/2.4.19-4GB/kernel/drivers/sound/i810_audio.o: unresolved symbol ac9 7_probe_codec
/lib/modules/2.4.19-4GB/kernel/drivers/sound/i810_audio.o: unresolved symbol ac9 7_set_dac_rate
/lib/modules/2.4.19-4GB/kernel/drivers/sound/i810_audio.o: unresolved symbol ac9 7_set_adc_rate


I tried insmod nvaudio and I get something similar:

Using /lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_probe_codec
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_dac_rate
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_adc_rate

I don't know where all these unresolved symbols are coming from - I just installed the binary suse rpm from the nvidia web site.

On a side note, I spotted that that rpm was supposed to give instructions on how to configure IDE and USB, but I can't find anything on that. I don't know if this is relevant, but I get errors regarding agpgart as well.

Thanks for any help.

wv6u 03-05-03 06:56 PM

Try this. On this box I am running SuSE 8.1
Open a window and su to root.
Then type: modprobe nvaudio

Then try your sound. I run RH8.0 on my old box so now I am trying to find where to put this command on SuSE 8.1 so that it will run everytime at the right time.
73 49 111 01001001
Stephen Hawkins

wv6u 03-06-03 09:39 AM

nvidia drivers and suse 8.1
 
The command I posted works, but I still have an intermittant problem. I am running SuSE Pro 8.1 The only problems seem to be after I used the sound.

My hardware looks like this:
A ASUS A7N8X deluxe mother board with two 512 MB sticks of PC2700 DDR memory
and a AMD Athlon XP2400+ CPU
An ASUS V8170DDR video card with 64 MB of DDR memory on board.
A Sony 52X/24X/52X RW IDE CDROM drive
A Western Digital WD800JB 80GB IDE drive

If I use the sound, for instance by using my web browser to go to the BBC web site and listen to the BBC. After I am done something has been stepped on. I cannot use it again as the OS thinks that some app still has it. Occasionally session will crash. In /var/log/messages there is nothing incriminating.

I suspect that the drivers still need a little work.

Faramir 03-26-03 04:06 AM

Exactly the same problem here with an Epox Nforce2 board, and installed Nvidia Nforce driver RPM.
A friendly poster in the thread "SuSE 8.0 compile problems" did manage to get the sound to work by inserting the "modprobe nvaudio" into the /etc/init.d/boot.local file.
I'll have a try on this. I'll also try the "modprobe i810_audio" if the "nvaudio" doesn't work.

hachre 03-31-03 05:55 PM

Guys, install the Kernel source to /usr/src/linux or check if its already there...

Then download the src tar.gzs not the damn rpms and install from source...

Read the README and INSTALL files - i think it was make && make install to compile and install them

after that "depmod -a" and modprobe nvaudio ...

your sound should be working now...


All times are GMT -5. The time now is 12:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.