nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia 5200 and wide screen (http://www.nvnews.net/vbulletin/showthread.php?t=80356)

cloneu2 11-14-06 11:06 AM

Nvidia 5200 and wide screen
 
I recently upgraded my LINUX machine to the latest xorg file and my monitor to a sceptree 20.1 " wide screen. It has resolutions that use to work 1280x11024 and one that i can't find 1600x1050. The later is what I would like to use. I can't get the card to display these resolutions


HELP

thanks
John

pe1chl 11-14-06 12:26 PM

Re: Nvidia 5200 and wide screen
 
You are probably trying to use a DVI cable.
Officially this is not possible because the 5200 cards normally have a pixel clock limit of 135 MHz and those screens require something near 155 MHz pixel clock to display at 60 Hz refresh rate.

You can use a lower refresh rate, or a special option (see section L of the README) to disable the check for the maximal pixel clock. This is out-of-spec but it usually just works.

You can also use a VGA cable, this will have no problem at all to reach that resolution.

cloneu2 11-14-06 12:47 PM

Re: Nvidia 5200 and wide screen
 
Quote:

Originally Posted by pe1chl
You are probably trying to use a DVI cable.
Officially this is not possible because the 5200 cards normally have a pixel clock limit of 135 MHz and those screens require something near 155 MHz pixel clock to display at 60 Hz refresh rate.

You can use a lower refresh rate, or a special option (see section L of the README) to disable the check for the maximal pixel clock. This is out-of-spec but it usually just works.

You can also use a VGA cable, this will have no problem at all to reach that resolution.


THANKS for the quick reply. yes I use the DVI... I can not find section L of the read me to figure this out. I would like to use the DVI and not analog if possible

TIA
John

Rede 11-14-06 02:24 PM

Re: Nvidia 5200 and wide screen
 
I am also using an Nvidia GeForce 5200FX and am having some similar problems with my display.

I have my xorg.conf set up for multi-monitor mode with an 1024x768 monitor as my primary display and my 16x9 LCD TV running at 1366x768 as the second monitor. The second display is a second X session, not twinview, and is connected via the DVI-out with a DVI=>VGA converter and a VGA cable.

The problem is that the display is discolored (orange tint), has a weird black bar down the left side of the screen, and the top of the screen kind of fades into blue. It works perfectly if I set the resolution to 1024x768, but then the aspect ratio is incorrect. I am using the 9629 driver on ubuntu edgy. Previously, with Dapper and the 8XXX series driver it worked as expected.

My xorg.conf (applicable sections):

Code:

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" LeftOf "Screen0"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Monitor Vendor"
    ModelName      "NEC LCD1515"
    Option        "dpms"
    # 1024x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 64.11 MHz
    Modeline        "1024x768@60"  64.11  1024 1080 1184 1344  768 769 772 795 -HSync +Vsync
EndSection

Section "Monitor"
    Identifier    "Monitor1"
    VendorName    "Monitor Vendor"
    ModelName      "RCA L26W11"
    Option        "dpms"
    # 1368x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 85.86 MHz
    Modeline "1368x768@60"  85.86  1368 1440 1584 1800 768 769 772 795  +HSync +Vsync
EndSection

Section "Device"
    Identifier    "nvidia0"
    Driver        "nvidia"
    VendorName    "NVIDIA"
    BoardName      "NVIDIA GeForce FX (generic)"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier    "nvidia1"
    Driver        "nvidia"
    VendorName    "NVIDIA"
    BoardName      "NVIDIA GeForce FX (generic)"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "nvidia0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection    "Display"
        Depth      24
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Screen"
    Identifier    "Screen1"
    Device        "nvidia1"
    Monitor        "Monitor1"
    DefaultDepth    24
    SubSection    "Display"
        Depth      24
        Modes      "1366x768"
    EndSubSection
EndSection


netllama 11-14-06 02:32 PM

Re: Nvidia 5200 and wide screen
 
Please generate and attach an nvidia-bug-report.log.

Thanks,
Lonni

Rede 11-14-06 02:37 PM

Re: Nvidia 5200 and wide screen
 
Quote:

Originally Posted by netllama
Please generate and attach an nvidia-bug-report.log.

Thanks,
Lonni

Er, sorry, how do I do that? :D

netllama 11-14-06 02:38 PM

Re: Nvidia 5200 and wide screen
 
http://www.nvnews.net/vbulletin/showthread.php?t=46678

Rede 11-14-06 02:42 PM

Re: Nvidia 5200 and wide screen
 
Cool, thanks. I am at school right now, but I'll generate the log when I get home (6 hours or so).

Thank you very much for the quick replies.

cloneu2 11-14-06 03:01 PM

Re: Nvidia 5200 and wide screen
 
OK it works just fine with the analog plug BUT I want the DVI... Can't find the area to change in the xorg file or the read me that was indicated above.. Heeeeeelp Mr.Wizzard:captnkill:

TIA
John

cloneu2 11-14-06 03:40 PM

Re: Nvidia 5200 and wide screen
 
I got IT... Did a search for pixel clock and found an xorg that someone else had made. Now at 1600x1050... With DVI....Thanks for the forum and excuse my ramblings... I had to get the monitor working so I could have a nice day

Enjoy
John:)

pe1chl 11-14-06 03:52 PM

Re: Nvidia 5200 and wide screen
 
You can find the README here:
/usr/share/doc/NVIDIA_GLX-1.0/README.txt

It is also on the NVIDIA website.
It never hurts to read this because it explains the issues that you have encountered, and many others.

Rede 11-14-06 08:58 PM

Re: Nvidia 5200 and wide screen
 
I've had something come up tonight, but I'll be posting that error log either late tonight or tomorrow sometime.


All times are GMT -5. The time now is 09:40 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.