nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   pm-suspend broken on fedora core 6 on gf4 ti4200 (http://www.nvnews.net/vbulletin/showthread.php?t=80425)

apatrat2 11-15-06 03:44 AM

pm-suspend broken on fedora core 6 on gf4 ti4200
 
1 Attachment(s)
Hello,
i've search the forum and I did not find any similar post so here I am :)
I am using the 9626 drivers (because of the nv2x bug in 9629...), everything works accel, compiz, beryl.

I've configured /etc/pm/functions-nvidia as indicated in this forum (commenting vbetool post etc...).
When I am trying to suspend the first time it works fine, after resuming I don't find any problems no slowdowns, compiz works fine..all good.
But if I am trying to suspend the second time the screen freezes (with a beautiful snow effect :) ) and I have to hard reboot (no ctrl+alt+bsp or del ) the remote ssh sessions are also unresponsive. I get the same result whether I use compiz or just the plain metacity.

I have the same problem if I'm trying to hibernate and I suspect that after the first resume the video is in a "funny" state that cannot be saved at the next reboot.

I attach the nvidia-bug-report.
Thanks,
Andrei

apatrat2 11-17-06 07:36 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
Anybody? Any hint of how to debug-it? (as far as I see everything seems ok, except the total freeze on second suspend cycle ;) )
10x,
Andrei

apatrat2 11-24-06 05:48 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
Hi,
I've found an workaround :) . I have just to change the resolution of the screen (via nvidia-settings) to another resolution and then back to the default resolution if I want to issue another suspend cycle. This makes the video card to re-initialize itself and then I can suspend without problems. I've tested with 9626 but I think that this shoud work with newer version of the driver as well.
I'm soooo happpyyy :) While writting this post I have just resumed for the 17th time :)).
Thanks nvidia people for the good work, now I have 3D acceleration,beryl and suspend all working on my old ti4200 card.
Andrei.

P.S. Is there a way to issue the resolution change from command line to put it in the hibernate script? Thanks, again. Now I let you concentrate to the black window bug with Beryl / Compiz :p

apatrat2 11-24-06 08:54 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
Actually I had made a mistake (before the last tests I was playing with nvidia-settings and activated Xinerama and nvidia-settings modified the Xorg.conf and I didn't had direct rendering so the suspend works only without direct rendering :((
So, I have to choose:
1)do not use direct rendering: no accell, no compiz, but hibernate
2)use direct rendering: compiz, but not hibernate (or I need to restart X after the first hibernate cycle in order to be able to suspend the second time).
Nobody can help ?
Andrei :(

apatrat2 04-23-07 03:31 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
1 Attachment(s)
Hello,
i have just upgraded to the latest stable legacy drivers (1.0.7185) and thing could not go worse. I have totally lost the ability to suspend :((.

Let me try to summarize the problem :

*Driver version < 9626 (actually pre texture-from-pixmap version) => suspend was ok (i was able to suspend and resume many times in a sequence without problems)

*Driver version 9626-9631 - suspends and resumes ok for the first time but then locks when suspending the second time.

*Current Driver (1.0.7185) locks during resume (always :( ). I attach the nvidia-bug-report log file where i can see some "BUG: sleeping function called from invalid context at kernel/rwsem.c:20" entries.

Suspend is working ok with the nv driver, and I have applied the vbetool changes in pm-functions-nvidia as directed on this forum.

Can I do anything to help to solve this problem?

Thanks,
Andrei

apatrat2 04-23-07 03:37 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
Is this a cause or a symptom?

BUG: sleeping function called from invalid context at kernel/rwsem.c:20
in_atomic():0, irqs_disabled():1
[<c043a142>] down_read+0x12/0x28
[<c04f60ad>] pci_get_subsys+0x71/0xf3
[<c05b55d6>] pci_conf1_write+0x99/0xa7
[<c04f6145>] pci_get_device+0x16/0x19
[<f90da625>] os_pci_init_handle+0x4b/0x81 [nvidia]
[<f8ec6fcd>] _nv001671rm+0x25/0x2c [nvidia]
[<f8ebb2ed>] _nv002094rm+0x4d/0x58 [nvidia]
[<f8ec1ccb>] _nv002133rm+0xc7/0x110 [nvidia]
[<f8ec2ca8>] _nv002081rm+0x98/0x1a8 [nvidia]
[<f8eb9eaa>] _nv001893rm+0x36/0xe0 [nvidia]
[<f8ece55f>] rm_teardown_agp+0x57/0x60 [nvidia]
[<f8fe7aad>] _nv004363rm+0x17d/0x51c [nvidia]
[<f8ecc936>] _nv001191rm+0x1e2/0x1f8 [nvidia]
[<f90d6315>] nv_agp_teardown+0x4a/0x5d [nvidia]
[<f8ec976f>] _nv001633rm+0x73/0xa8 [nvidia]
[<f8eba936>] _nv001787rm+0x26/0x2c [nvidia]
[<f8eca254>] _nv000812rm+0x58/0xc4 [nvidia]
[<f8eca2aa>] _nv000812rm+0xae/0xc4 [nvidia]
[<f8ecaa72>] _nv001261rm+0x92/0xd4 [nvidia]
[<f8ecaa7f>] _nv001261rm+0x9f/0xd4 [nvidia]
[<f8ec7466>] _nv001744rm+0x12/0x18 [nvidia]
[<f8ecdb4f>] rm_disable_adapter+0x2f/0x80 [nvidia]
[<f8ecdb7a>] rm_disable_adapter+0x5a/0x80 [nvidia]
[<f90d8c1f>] nv_kern_close+0x204/0x31b [nvidia]
[<c0473256>] __fput+0xba/0x170
[<c0470cad>] filp_close+0x51/0x58
[<c0471be8>] sys_close+0x70/0xa7
[<c0403f64>] syscall_call+0x7/0xb

Best,
Andrei

sgoodall 04-23-07 03:53 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
I've had similiar problems on my machine. The stacktraces are annoying, but do not appear to be causing any problems. I also have the freeze on second resume for the 9631.

I tried the 7185 drivers, but they never seemed to resume properly. I'm stlll using the 7184 drivers for now.

I just stuck "return" as the second line in /etc/pm/functions-nvidia. I also added a new script called /etc/pm/hooks/99chvt (see below) to switch to console mode and back as this seems to turn my display back on.

#!/bin/sh
## Temporarily switch to text mode on resume
case "$1" in
resume)
VT=7
/usr/bin/chvt 12
/usr/bin/chvt $VT
esac
exit $?

apatrat2 04-23-07 07:08 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
2 Attachment(s)
Hi sgoodall and thanks for your quick reply.
Actually 7184 is quite old and cannot compile on newer 2.6.20 kernels (sure, this can be fixed but I don't know if it pays back for the time spent on fixing the compilling errors)

Anyway, I was hoping that since suspend worked well for some older nvidia driver it shouldn't be difficult to trace were the things went bad and create a bugfix. Now, since nvidia driver development is quite dynamic and probably there are a lot of changes between releases it might be not so trivial...
It's just a pity that there are problems that probably will never be fixed on such cards (which are quite capable in my opinion - beryl/compiz work with nice FPS ) because of their legacy status...

I will stay with 9631 for the time being and I will try to remember not to suspend 2 times in a row :(

Anyway, i attach two new bug-report-logs for 9631 (one before the first suspend - old.gz and the other after the first resume - and just before the freeze on the second suspend cycle.

Cheers all nvidia developers out there and good luck with the debugging ;),
Andrei

sgoodall 04-23-07 07:44 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
I'm actually using the pre-built rpm's from livna.org. They have 7184 working with 2.6.20.

apatrat2 04-23-07 07:55 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
Hi,
nice to know for the binary packages(me=kinda newbie...). I will give-it a try.
Thanks,
Andrei

P.S. I guess that 7184 doesn't support GLX_TEXTURE_FROM_PIXMAP but you can't have it all....

apatrat2 04-23-07 08:43 AM

Re: pm-suspend broken on fedora core 6 on gf4 ti4200
 
Ok,
7184 resumes ok (for me as well thanks again sgoodall)
7185 doesn't suspend at all (freeze on suspend)

9626-9631 resume ok the first time, freeze on second suspend
96xx <9626 (At least some version suspended ok)

Hope that the next version 96?? would have both suspend and composite working :)

Andrei


All times are GMT -5. The time now is 02:12 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.