nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Improper let go of display resources on 8800GTS with beta drivers (http://www.nvnews.net/vbulletin/showthread.php?t=80551)

AireTamStrm 11-16-06 05:14 PM

Improper let go of display resources on 8800GTS with beta drivers
I know beta drivers are hard to support, and I don't expect a solution here, but just thought I shouldreport my troubles and revelations with the 8800 series here.

System Information:
I am running SuSE 10.1 x86_64 under a newly bought AMD X2 4200+,
GeForce 8800GTS (and GeForce FX5500 PCI for testing purposes)

Driver installer file:

X initializes. It gets me to a desktop and I get to see the awesome power of this card in glxgears at 22,000 FPS. However, Ctl-Alt-Backspace or attempting to restart X in other ways results in failiure. Shutdown also takes particularly long, but that may be because I am unable to see the progress of it (when X exits, BaSH does not display). This problem is NONEXISTANT on the 5500 card, and X can stop/start/restart without problems. I assume that this is due to the splitting of the driver for the G80's new architechture, and that obviously being a beta driver, support is incomplete.

TV out does not work on the G80s yet it seems. I tried SVideo, and not HDTV outputs, so that may very well work. If someone can post that result it'd be nice. Under this driver, the 5500 TV outputs work.

I had a laptop that ran Xgl/Compiz very well. It was 32-bit SuSE 10.1 on Intel graphics, very stable, abeit slow and problematic with video. However, compiz never crashed like it does on the nvidia driver. I assume this is also due to the G80 portion of the driver being incomplete, and a fix will be out later. The symptoms are as described in another thread here, animation, windows all appearing normal with status updates, but the mouse is unable to interact with the beryl-Xgl process suddenly. Killing that process restores input, I assume that somewhere an OpenGL instruction is called that isn't fully supported yet, leaving the Xgl process stuck waiting for a result that will never come from the nvidia kernel module. If so, this will also be resolved with a new driver.

Again, most of my worries are most likely from the driver being incomplete, but I must say. nVIDIA, good damned job, even with your beta drivers. Your excellent support has not only made your products a good choice for Linux users, but the only practical choice. Back in the days of RH 7.3, we got our driver. We didn't have GUIs on anything for X config from you guys, and you didn't really have to write any, but now you've been going out of your way to bring us that support. Really, its appreciated.

Keep it up nVIDIA!

Ikshaar 11-17-06 03:25 PM

Re: Improper let go of display resources on 8800GTS with beta drivers
Thanks for the info.. I am getting ready to get one of those baby.

If you don't mind few questions:

- What happen with earlier driver ? X don't start or what ?
- If you are not using XGL/compiz (and don't try to restart X), is it stable ?
- Are game performance as good as expected ? tried any ? WoW with wine/cedega ? native Quake4 ?

xanas3712 11-18-06 05:50 AM

Re: Improper let go of display resources on 8800GTS with beta drivers
Game performance is fine. I am impressed with it by comparison to my former 7800 GT. I can do ultra mode 1920x1200 now and keep the consistent top framerate w/ no issues.

But, other than that, I am having the exact same issues he has noted, didn't notice this thread down here before I posted my own.

AireTamStrm 11-18-06 07:03 PM

Re: Improper let go of display resources on 8800GTS with beta drivers
I've seem to have fixed the stability problems in Xgl.

I turned off screensaver and standby on the TwinView Screen, via KDE. I think the different standby and off modes (which wouldn't display in Xgl anyway) killed input. All input SEEMS to be working at this point, consistently.

Also, I have a Dual-Core processor, so I also added the following argument to my kernel parameters in GRUB:


I'm running beryl on Xgl.

All times are GMT -5. The time now is 04:39 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.