nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   G80 Emulator on Linux (http://www.nvnews.net/vbulletin/showthread.php?t=80626)

bkoz 11-17-06 03:45 PM

G80 Emulator on Linux
 
Has anyone got the G80 emulator to work on Linux? The release notes say to add ' Option "RegistryDwords" "8F773984=7" ' to the Screen or Device section of the xorg.conf file. Running glxinfo does report the 97.42 driver and GL 2.1.0support but no G80 extenstions (GL_EXT_gpu_shader4, etc) are advertised.

I'm running suse 10.1 on an ia32 platform with a Quadro FX1500M. I also tried it on an FX1400 system.

Thanks,
Bob

yoda-105>cat nvidia-bug-report.log | grep -i Registry
/proc/driver/nvidia/registry
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv-i2c.o nv.o nv
-vm.o os-agp.o os-interface.o os-registry.o nv-i2c.o nvidia.mod.o
#s" -D"KBUILD_BASENAME=KBUILD_STR(os_registry)" -D"KBUILD_MODNAME=KBUILD_ST
tmp_os-registry.o /tmp/selfgz3867/NVIDIA-Linux-x86-1.0-9742-pkg1/usr/src/nv/
os-registry.c
/nv/os-registry.c:14:
/nv/os-registry.c:14:
7/NVIDIA-Linux-x86-1.0-9742-pkg1/usr/src/nv/os-registry.o /tmp/selfgz3867/NV
(**) NVIDIA(0): Option "RegistryDwords" "8F773984=7"
Option "RegistryDwords" "8F773984=7"
(**) NVIDIA(0): Option "RegistryDwords" "8F773984=7"
Option "RegistryDwords" "8F773984=7"
yoda-106>

dominik95 01-25-07 03:09 PM

Re: G80 Emulator on Linux
 
I got the same problem any help would be really appreciated.

OS: Gentoo http://www.gentoo.org
Linux gpu 2.6.18-gentoo-r6 #1 SMP Wed Jan 17 14:42:53 CET 2007 i686 Intel(R) Pentium(R) 4 CPU 3.60GHz GenuineIntel GNU/Linux

here's part of Xorg.0.log :
(**) NVIDIA(0): Option "RegistryDwords" "8F773984=7"
(**) NVIDIA(0): Option "SLI" "Auto"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): NVIDIA SLI auto-select rendering option.
(WW) NVIDIA(0): DamageEvents are not currently compatible with SLI. Disabling
(WW) NVIDIA(0): DamageEvents.
(II) NVIDIA(0): NVIDIA SLI enabled.
(II) NVIDIA(0): NVIDIA GPU Quadro FX 1400 at PCI:1:0:0 (GPU-0)

drivers version tried :
the one specified here : http://developer.download.nvidia.com...ease_notes.pdf
and version 97.46

cards are :
01:00.0 VGA compatible controller: nVidia Corporation NV41GL [Quadro FX 1400] (rev a2)
02:00.0 VGA compatible controller: nVidia Corporation NV41GL [Quadro FX 1400] (rev a2)

symptom :
call to glCreateShader ( GL_GEOMETRY_SHADER_EXT ); or the ARB version gives an error
glxinfo does display version 2.1.0 but does not display the GL_EXT_geometry_shader4 extension.
the right headers are included and the right .so are used for linking.

thank you
dom

michael.bauer 01-25-07 03:16 PM

Re: G80 Emulator on Linux
 
Maybe Option "NvEmulate" or something similar in xorg.conf helps. <<Option "RegistryDwords" "8F773984=7">> enables GL_EXT_gpu_shader4 and GL_EXT_geometry_shader4 etc. for G80 hardware.

dominik95 01-25-07 03:43 PM

Re: G80 Emulator on Linux
 
Thank you for your reply, i will try that as soon as I can and post the results here.

by the way, the mentionned pdf does not specify that, should be added.

thank you.

dom

dominik95 01-26-07 08:01 AM

Re: G80 Emulator on Linux
 
Trying to set NvEmulate gives :

(WW) NVIDIA(0): Option "NvEmulate" is not used

and the same invalid operation from OpenGL ....

I was just wondering if someone with an access to the dev forums can ask
the question about this ?

thank you
dom

dominik95 01-26-07 12:06 PM

Re: G80 Emulator on Linux
 
Quote:

Originally Posted by michael.bauer
"RegistryDwords" "8F773984=7">> enables GL_EXT_gpu_shader4 and GL_EXT_geometry_shader4 etc. for G80 hardware.

As far as i understood, the extensions are available in software when using this feature on <g80 :

Quote:

Originally Posted by http://developer.download.nvidia.com/opengl/glsl/glsl_release_notes.pdf
On pre-GeForce 8 series hardware, this also requires enabling feature set emulation, and the newer feature will result in software emulation. These GeForce 8 series enhancements are considered to be in beta form, and once sufficient testing has completed, they will be advertised by default like the rest of GLSL.

thank you
dom

dominik95 01-29-07 01:08 PM

Re: G80 Emulator on Linux
 
I won't be abble to test that before few days.

I ask the technical support and they reply that I should try :

Option "RegistryDwords" "8F773984=7; NvEmulate=50"

regards,
dom


All times are GMT -5. The time now is 03:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.