nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Using Composite 24/7 Results in Slowdown after ~48 hours (http://www.nvnews.net/vbulletin/showthread.php?t=80690)

mooninite 11-18-06 01:48 PM

Using Composite 24/7 Results in Slowdown after ~48 hours
 
Fedora Core 6
Using either a 7900gt or FX5200 with driver 9629
The 7900gt system is 64-bit, the 5200 is in a 32-bit system.
Using XFCE 4.4 rc2 as the Desktop Environment with its built-in compositor.

2D performance is quick and normal upon first logging in. After leaving the computer on for a consecutive 48 hours (more or less in that range), 2D performance will start to suffer and it's like I'm running a 286 with a VESA LB video card. If I disable the compositor (a check box in XFCE) then 2D performance is OK with transparancy gone. If I reenable it then 2D performance suffers immediately. I'm forced to logout and kill X to get 2D performance back to normal.

Is this a memory leak? XFCE problem?

P.S. When I say 2D performance I'm talking about window drawing and any sort of 2D draw operation. Dragging windows around is very choppy and it leaves trails of windows behind. Going through dialogs or web browsing is very slow and sluggish.

Thunderbird 11-18-06 02:22 PM

Re: Using Composite 24/7 Results in Slowdown after ~48 hours
 
This could be a memory leak error. Provide at least the results of running the nvidia-bug-report.sh script.

mooninite 11-20-06 12:19 AM

Re: Using Composite 24/7 Results in Slowdown after ~48 hours
 
1 Attachment(s)
Quote:

Originally Posted by Thunderbird
This could be a memory leak error. Provide at least the results of running the nvidia-bug-report.sh script.

Don't know what you'll find from this besides my system specs. A report from my 64-bit system is attached.

It was acting slow at the time of making the report. Also, running Xv (watching TV with tvtime) causes CPU to be 100% on one of the cores when it is "acting slow."

It seems that something either causes the nvidia driver to revert to a legacy slow mode, or maybe the XFCE compositor has a problem.

Bluekkis 11-20-06 05:10 AM

Re: Using Composite 24/7 Results in Slowdown after ~48 hours
 
This sounds like what i had not long ago. Increasing stuttering over longer uptime on heavy 3d loads (games), interestingly though I never had problems on beryl driven desktop. Problem went away almost entirely when I updated from xfce4.4_rc2 to svn builds, so probably xfce problem.

mooninite 11-20-06 03:17 PM

Re: Using Composite 24/7 Results in Slowdown after ~48 hours
 
So the latest XFCE SVN did the trick? I might be moving over to Beryl today since I just saw the new burn effect. I'll run Beryl for a solid week and add anything to this if it fouls up.


All times are GMT -5. The time now is 04:28 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.