nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1.0-9629 uses 75Hz instead of 60Hz (http://www.nvnews.net/vbulletin/showthread.php?t=80798)

shift-zz 11-20-06 09:45 AM

1.0-9629 uses 75Hz instead of 60Hz
 
I got a new LCD monitor (Dell 1907FP) and tried to use it with my system here. The graphic card (GeForce2 MX/MX 400) insists on using 75Hz instead of the desired 60Hz. This phenomen disappeared by using an older version of the nvidia driver (1.0-8774) and/or by using the open source nv-driver.
Is there a way to force the card to use the 60Hz?
I allready modified the edid file with a hex editor to cut off "1280×1024@75 Hz" and disable the modes from Vesa and from X-server. But this was not enough. The image on the screen is the same as with 75Hz but the monitor "says" the frequency is 60Hz.

Here are a few parts of the Xorg.0.log

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP"
(**) NVIDIA(0): Option "CursorShadow" "on"
(**) NVIDIA(0): Option "CustomEDID" "DFP-0:/etc/X11/edid_dell_1907FP.bin"
(**) NVIDIA(0): Option "AllowGLXWithComposite" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Option "ModeValidation" "DFP-0: NoVesaModes,NoXServerModes"
(==) NVIDIA(0): Using HW cursor
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Enabling cursor shadow
(==) NVIDIA(0): Video key set to default value of 0x101fe
(**) NVIDIA(0): ConnectedMonitor string: "DFP"
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(GPU-0): Display device DFP-0: using Custom EDID from file
(II) NVIDIA(GPU-0): '/etc/X11/edid_dell_1907FP.bin'
(II) NVIDIA(0): NVIDIA GPU GeForce2 MX/MX 400 at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 32768 kBytes
(II) NVIDIA(0): GPU Architecture: 0x10
(II) NVIDIA(0): GPU Implementation: 0x11
(II) NVIDIA(0): GPU Revision: 0xb2
(--) NVIDIA(0): VideoBIOS: 03.11.00.18.68
(--) NVIDIA(0): Found 2 CRTCs on board
(II) NVIDIA(0): Supported display device(s): CRT-0, CRT-1, DFP-0, TV-0
(II) NVIDIA(0): Bus detected as AGP
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are not supported on this GPU
(II) NVIDIA(0):
(II) NVIDIA(0): Mode timing constraints for : GeForce2 MX/MX 400
(II) NVIDIA(0): Maximum mode timing values :
(II) NVIDIA(0): Horizontal Visible Width : 4096
(II) NVIDIA(0): Horizontal Blank Start : 4096
(II) NVIDIA(0): Horizontal Blank Width : 1024
(II) NVIDIA(0): Horizontal Sync Start : 4088
(II) NVIDIA(0): Horizontal Sync Width : 248
(II) NVIDIA(0): Horizontal Total Width : 4128
(II) NVIDIA(0): Vertical Visible Height : 2048
(II) NVIDIA(0): Vertical Blank Start : 2048
(II) NVIDIA(0): Vertical Blank Width : 128
(II) NVIDIA(0): Veritcal Sync Start : 2047
(II) NVIDIA(0): Vertical Sync Width : 15
(II) NVIDIA(0): Vertical Total Height : 2049
(II) NVIDIA(0):
(II) NVIDIA(0): Minimum mode timing values :
(II) NVIDIA(0): Horizontal Total Width : 40
(II) NVIDIA(0): Vertical Total Height : 2
(II) NVIDIA(0):
(II) NVIDIA(0): Mode timing alignment :
(II) NVIDIA(0): Horizontal Visible Width : multiples of 8
(II) NVIDIA(0): Horizontal Blank Start : multiples of 8
(II) NVIDIA(0): Horizontal Blank Width : multiples of 8
(II) NVIDIA(0): Horizontal Sync Start : multiples of 8
(II) NVIDIA(0): Horizontal Sync Width : multiples of 8
(II) NVIDIA(0): Horizontal Total Width : multiples of 8
(II) NVIDIA(0):
(--) NVIDIA(0): Connected display device(s) on GeForce2 MX/MX 400 at
(--) NVIDIA(0): PCI:1:0:0:
(--) NVIDIA(0): DELL 1907FP (DFP-0)
(--) NVIDIA(0): DELL 1907FP (DFP-0): 165.0 MHz maximum pixel clock
(--) NVIDIA(0): DELL 1907FP (DFP-0): External Single Link TMDS
(--) NVIDIA(0): DELL 1907FP (DFP-0): Native FlatPanel Scaling is supported
(--) NVIDIA(0): DELL 1907FP (DFP-0): DFP modes are not limited to 60 Hz
(--) NVIDIA(0): refresh rate
(--) NVIDIA(0):
(--) NVIDIA(0): --- EDID for DELL 1907FP (DFP-0) ---
(--) NVIDIA(0): EDID Version : 1.3
(--) NVIDIA(0): Manufacturer : DEL
(--) NVIDIA(0): Monitor Name : DELL 1907FP
(--) NVIDIA(0): Product ID : xxxxx
(--) NVIDIA(0): 32-bit Serial Number : xxxxxxxxxxxx
(--) NVIDIA(0): Serial Number String : xxxxxxxxxxx
(--) NVIDIA(0): Manufacture Date : 2006, week 38
(--) NVIDIA(0): DPMS Capabilities : Standby Suspend Active Off
(--) NVIDIA(0): Prefer first detailed timing : Yes
(--) NVIDIA(0): Supports GTF : No
(--) NVIDIA(0): Maximum Image Size : 380mm x 300mm
(--) NVIDIA(0): Valid HSync Range : 30 kHz - 81 kHz
(--) NVIDIA(0): Valid VRefresh Range : 56 Hz - 76 Hz
(--) NVIDIA(0): EDID maximum pixel clock : 140.0 MHz
(--) NVIDIA(0):
(--) NVIDIA(0): Established Timings:
(--) NVIDIA(0): 640 x 480 @ 60 Hz
(--) NVIDIA(0): 640 x 480 @ 75 Hz
(--) NVIDIA(0): 800 x 600 @ 60 Hz
(--) NVIDIA(0): 800 x 600 @ 75 Hz
(--) NVIDIA(0): 1024 x 768 @ 60 Hz
(--) NVIDIA(0): 1024 x 768 @ 75 Hz
(--) NVIDIA(0):
(--) NVIDIA(0): Standard Timings:
(--) NVIDIA(0): 1152 x 864 @ 75 Hz
(--) NVIDIA(0):
(--) NVIDIA(0): Detailed Timings:
(--) NVIDIA(0): 1280 x 1024 @ 60 Hz
(--) NVIDIA(0): Pixel Clock : 108.00 MHz
(--) NVIDIA(0): HRes, HSyncStart : 1280, 1328
(--) NVIDIA(0): HSyncEnd, HTotal : 1440, 1688
(--) NVIDIA(0): VRes, VSyncStart : 1024, 1025
(--) NVIDIA(0): VSyncEnd, VTotal : 1028, 1066
(--) NVIDIA(0): H/V Polarity : +/+
(--) NVIDIA(0):
(--) NVIDIA(0): --- End of EDID for DELL 1907FP (DFP-0) ---
(--) NVIDIA(0):
(II) NVIDIA(0): Mode Validation Overrides for DELL 1907FP (DFP-0):
(II) NVIDIA(0): NoVesaModes
(II) NVIDIA(0): NoXServerModes
(II) NVIDIA(0): Frequency information for DELL 1907FP (DFP-0):
(II) NVIDIA(0): HorizSync : 30.000-81.000 kHz
(II) NVIDIA(0): VertRefresh : 56.000-76.000 Hz
(II) NVIDIA(0): (HorizSync from EDID)
(II) NVIDIA(0): (VertRefresh from EDID)
(II) NVIDIA(0):
(II) NVIDIA(0): Native backend timings for DELL 1907FP (DFP-0):
(II) NVIDIA(0): 1280 x 1024 @ 60 Hz
(II) NVIDIA(0): Pixel Clock : 108.00 MHz
(II) NVIDIA(0): HRes, HSyncStart : 1280, 1328
(II) NVIDIA(0): HSyncEnd, HTotal : 1440, 1688
(II) NVIDIA(0): VRes, VSyncStart : 1024, 1025
(II) NVIDIA(0): VSyncEnd, VTotal : 1028, 1066
(II) NVIDIA(0): H/V Polarity : +/+
(II) NVIDIA(0):
(II) NVIDIA(0):
(II) NVIDIA(0): --- Modes in ModePool for DELL 1907FP (DFP-0) ---
(II) NVIDIA(0): "nvidia-auto-select" : 1280 x 1024 @ 60.0 Hz (from: EDID)
(II) NVIDIA(0): "1280x1024" : 1280 x 1024 @ 60.0 Hz (from: EDID)
(II) NVIDIA(0): "1280x1024_60" : 1280 x 1024 @ 60.0 Hz (from: EDID)
(II) NVIDIA(0): "1152x864" : 1152 x 864 @ 75.0 Hz (from: EDID)
(II) NVIDIA(0): "1152x864_75" : 1152 x 864 @ 75.0 Hz (from: EDID)
(II) NVIDIA(0): "1024x768" : 1024 x 768 @ 75.0 Hz (from: EDID)
(II) NVIDIA(0): "1024x768_75" : 1024 x 768 @ 75.0 Hz (from: EDID)
(II) NVIDIA(0): "1024x768_60" : 1024 x 768 @ 60.0 Hz (from: EDID)
(II) NVIDIA(0): "800x600" : 800 x 600 @ 75.0 Hz (from: EDID)
(II) NVIDIA(0): "800x600_75" : 800 x 600 @ 75.0 Hz (from: EDID)
(II) NVIDIA(0): "800x600_60" : 800 x 600 @ 60.3 Hz (from: EDID)
(II) NVIDIA(0): "640x480" : 640 x 480 @ 75.0 Hz (from: EDID)
(II) NVIDIA(0): "640x480_75" : 640 x 480 @ 75.0 Hz (from: EDID)
(II) NVIDIA(0): "640x480_60" : 640 x 480 @ 60.0 Hz (from: EDID)
(II) NVIDIA(0): --- End of ModePool for DELL 1907FP (DFP-0): ---
(II) NVIDIA(0):
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Requested modes:
(II) NVIDIA(0): "1280x1024"
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): MetaMode "1280x1024":
(II) NVIDIA(0): Bounding Box: [0, 0, 1280, 1024]
(II) NVIDIA(0): DELL 1907FP (DFP-0): "1280x1024"
(II) NVIDIA(0): Size : 1280 x 1024
(II) NVIDIA(0): Offset : +0 +0
(II) NVIDIA(0): Panning Domain: @ 1280 x 1024
(II) NVIDIA(0): Position : [0, 0, 1280, 1024]
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(II) NVIDIA(0):
(II) NVIDIA(0): Implicitly adding the following modes to X Screen 0 (these
(II) NVIDIA(0): will be available via XRandR and XF86VidMode):
(II) NVIDIA(0):
(II) NVIDIA(0): "1152x864" : 1152 x 864 @ 75.0 Hz
(II) NVIDIA(0): "1024x768" : 1024 x 768 @ 75.0 Hz
(II) NVIDIA(0): "1024x768_60" : 1024 x 768 @ 60.0 Hz
(II) NVIDIA(0): "800x600" : 800 x 600 @ 75.0 Hz
(II) NVIDIA(0): "800x600_60" : 800 x 600 @ 60.3 Hz
(II) NVIDIA(0): "640x480" : 640 x 480 @ 75.0 Hz
(II) NVIDIA(0): "640x480_60" : 640 x 480 @ 60.0 Hz
(II) NVIDIA(0):
(II) NVIDIA(0): Computing DPI using physical size from DELL 1907FP (DFP-0)'s
(II) NVIDIA(0): EDID and first mode to be programmed on DELL 1907FP
(II) NVIDIA(0): (DFP-0):
(II) NVIDIA(0): width : 1280 pixels 380 mm (DPI: 85)
(II) NVIDIA(0): height : 1024 pixels 300 mm (DPI: 86)
(--) NVIDIA(0): DPI set to (85, 86); computed from "UseEdidDpi" X config
(--) NVIDIA(0): option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[b]
[1] 0 0 0xde000000 - 0xdeffffff (0x1000000) MX[b]
[2] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[3] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[4] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[5] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[6] -1 0 0xdfeff000 - 0xdfefffff (0x1000) MX[b]
[7] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[b]O
[8] -1 0 0xdfdf0000 - 0xdfdfffff (0x10000) MX[b](B)
[9] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[b](B)
[10] -1 0 0xde000000 - 0xdeffffff (0x1000000) MX[b](B)
[11] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
[12] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
[13] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
[14] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[15] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[16] -1 0 0x0000ac00 - 0x0000ac3f (0x40) IX[b]
[17] -1 0 0x0000d800 - 0x0000d83f (0x40) IX[b]
[18] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[b]
[19] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[b]
[20] -1 0 0x00000c00 - 0x00000c0f (0x10) IX[b]
[21] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[b]
[22] -1 0 0x0000fc00 - 0x0000fc0f (0x10) IX[b]
[23] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[24] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): kernel module enabled successfully
(II) NVIDIA(0): Memory mapped
(II) NVIDIA(0): Interrupts enabled
(II) NVIDIA(0): Using built-in logo image.
(II) NVIDIA(0): Logo is 744x537 with depth 24.
(II) NVIDIA(0): Setting mode "1280x1024"
(II) NVIDIA(0): DFP-0 assigned CRTC 0
(II) NVIDIA(0): First mode initialized
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Visuals set up
(II) NVIDIA(0): Pixmap depths set up
(II) NVIDIA(0): GLX visuals set up
(II) NVIDIA(0): Framebuffer set up
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) NVIDIA(0): Default colormap initialized.
(II) NVIDIA(0): Palette loaded
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(WW) NVIDIA(0): Option "XAANoOffscreenPixmaps" is not used
(II) NVIDIA(0): Screen initialization complete
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX


Any Ideas what else can be done to use this driver?

Jörg

Mattia 11-20-06 10:19 AM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
Try to add this line to your xorg.conf section screen:
Option "DynamicTwinView" "false"

Mattia 11-20-06 10:22 AM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
,

shift-zz 11-20-06 11:06 AM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
Quote:

Originally Posted by Mattia
Try to add this line to your xorg.conf section screen:
Option "DynamicTwinView" "false"

The result is the same. :(

Mattia 11-20-06 11:15 AM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
Quote:

Originally Posted by shift-zz
The result is the same. :(

Sorry section monitor

If doesn't works add:
Option "DynamicTwinView" "false"
Option "UseEDID" "false"

netllama 11-20-06 01:21 PM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
Please generate and attach an nvidia-bug-report.log.

Lethe 11-20-06 03:51 PM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
I had same issue with Viewsonic DPF... I use this in xorg.conf to sort it

Nick


SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x1024_60" "1024x768_60" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024_60" "1024x768_60" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024_60" "1024x768_60" "800x600" "640x480"
EndSubSection
EndSection

shift-zz 11-21-06 03:37 AM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
1 Attachment(s)
I attached two bug reports. The one with version 9629 which doesn't work and the one w/ version 8774 which works verry well.

Jörg

netllama 11-21-06 11:50 AM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
I'm a bit confused over the problem you're reporting. You stated "The image on the screen is the same as with 75Hz but the monitor "says" the frequency is 60Hz."

That suggests to me that you're getting the 60Hz refresh rate that you want. Additionally, the X log shows that you're running a 60Hz refresh rate. Where are you determining that you are not?

shift-zz 11-25-06 10:27 AM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
2 Attachment(s)
Quote:

Originally Posted by netllama
I'm a bit confused over the problem you're reporting. You stated "The image on the screen is the same as with 75Hz but the monitor "says" the frequency is 60Hz."

By pressing the menu button on the screen it tells the desired resolution/frequency and the actual one.

Quote:

Originally Posted by netllama
That suggests to me that you're getting the 60Hz refresh rate that you want. Additionally, the X log shows that you're running a 60Hz refresh rate. Where are you determining that you are not?

Please have a look at the attached photos. The screen shoold look like in "screen_60HZ.jpg". But if I use 75Hz refreshrate or the nvidia driver 9629 I get a screen as seen in "screen_75Hz.jpg"

Jörg

shift-zz 11-25-06 10:30 AM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
Quote:

Originally Posted by Lethe
I had same issue with Viewsonic DPF... I use this in xorg.conf to sort it

Nick

...
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024_60" "1024x768_60" "800x600" "640x480"
EndSubSection
EndSection

I allready tried 1280x1024_60, but the result on the screen is the same as using 1280x1024_75

Jörg

hayaka 11-25-06 10:51 AM

Re: 1.0-9629 uses 75Hz instead of 60Hz
 
Can you post the log file after setting 1280x1024_60 as the first mode in the first screen?

In your posted log file, you have "1280x1024" as the selected mode. I'm curious which mode the driver uses when you have "1280x1024_60" chosen.


All times are GMT -5. The time now is 03:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.