nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   can't install 1.0-4191 w/ kernel 2.4.18-24.8.0 (http://www.nvnews.net/vbulletin/showthread.php?t=8094)

cascao_dv8 02-28-03 12:49 PM

can't install 1.0-4191 w/ kernel 2.4.18-24.8.0
can't install 1.0-4191 w/ kernel 2.4.18-24.8.0 dowloaded from RH site.

in using RH 8.0 w/ the above kernel UP when i try to do rpmbuild --rebuild to 1.0-4191 src.rpm kernel pkg it returns the folowing :

+ export LANG
+ rm -f /tmp/files.lst
+ '[' -z '' ']'
++ uname -r
+ export TARGET_KERNEL=2.4.18-24.8.0
+ TARGET_KERNEL=2.4.18-24.8.0
+ '[' -d /lib/modules/2.4.18-24.8.0/kernel ']'
+ INSTALLPATH=/lib/modules/2.4.18-24.8.0/kernel/drivers/video
+ mkdir -p /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.18-24.8.0/kernel/drivers/video
+ install -m 0444 nvidia.o /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.18-24.8.0/kernel/drivers/video
install: cannot stat `nvidia.o': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.10428 (%install)

RPM build errors:
user buildmeister does not exist - using root
group buildmeister does not exist - using root
user buildmeister does not exist - using root
group buildmeister does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.10428 (%install)

ps. im doing it as root and i have all kernel develop. pkg's installed

could anyone tel me whats wrong ... plase.

ps.(2) im not a native english speaker so please forguive any erros in text :-P

THE_ODD_ONE 02-28-03 03:43 PM

read the post from steel it says that trying it in the gui and then doing the glx in text worked.

After 2 weeks of fighting with this thing on and off, I have now got my G3 TI200 working great under linux.
I am playing UT2003 and Its working great.

I am on the same kernel as you. I just tried and tried and it finally worked.

mikef 03-01-03 10:03 PM

I had exactly the same problem. I first tried to install the kernel rpm NVIDIA_kernel-1.0-4191.rh80up_2.4.18_18.8.0.i686.rpm and had all kinds of problems, it said it was installed but startx just produced an error saying it couldn't find the nvidia.o. I tried installing with the source and got the same problem as you. Then I started checking the kernel version numbers using uname -r I found that I was running 2.4.18-14. When I looked under the libs/modules directory I found that I had two directories 2.4.18-18.80 and 2.4.18-14. The first had the nvidia.o installed but n other files, I guest that I must have been trying to install the wrong nvidia driver, so I downloaded NVIDIA_kernel-1.0-4191.rh80up.i686.rpm instead, I tried to install it but it said I all ready had the other installed so I removed the GLX and then the original driver using rpm -e NVIDIA_kernel-1.0-4191.rh80up_2.4.18_18.8.0 etc. and then installed the new drivers using rpm -ivh NVIDIA_kernel-1.0-4191.rh80up.i686.rpm and then the same for the GLX. I then modified my XFree86 file and modules.conf file as per the instructions at http://www.whacked.net/ldl/faq/. when I typed xstart the NVIDIA flash screen came up!!! an end to considerable frustration. I am a bit of a newbie so I am sorry if this doesn't help, and I still dont understand why we should get that problem with the src file but if it worked for me it might work for you. Good luck.


All times are GMT -5. The time now is 10:14 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.