nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   resolution 1440x900 problem (http://www.nvnews.net/vbulletin/showthread.php?t=80958)

nixxon 11-22-06 08:42 AM

resolution 1440x900 problem
 
hi, I have a problem. My configuration is:

slackware 11, kernel huge26.s (2.6.17.13), monitor hp w19 inch, geforce 7300 le, driver NVIDIA-Linux-x86-1.0-9629-pkg1.run.
Under windows Xp my resolution is 1440x900 60 Hz 32 bit, under slackware is max 1280x1024 50 hz why? can you help me? :(

this is my xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Nov 1 19:47:17 PST 2006

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/misc/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
Option "AutoRepeat" "500 30"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Cambo 11-22-06 08:51 AM

Re: resolution 1440x900 problem
 
It's quite possibly something to do with the EDID info from your monitor.

Probably best to generate a nvidia-bug-report.txt - see http://www.nvnews.net/vbulletin/showthread.php?t=46678 for info on that.



Cambo

nixxon 11-22-06 09:36 AM

Re: resolution 1440x900 problem
 
1 Attachment(s)
Quote:

Originally Posted by Cambo
It's quite possibly something to do with the EDID info from your monitor.

Probably best to generate a nvidia-bug-report.txt - see http://www.nvnews.net/vbulletin/showthread.php?t=46678 for info on that.



Cambo

my nvidia-bug-report.txt :)

greviant 11-22-06 09:40 AM

Re: resolution 1440x900 problem
 
2 Attachment(s)
I have a similar problem with GeForce 6800 Ultra AGP card and ViewSonicE70 CRT monitor. Ubuntu Edgy 2.6.17.10, monitor usually caps out at 1400x1050@60Hz, but new drivers won't let me run at anything more than 800x600@51Hz

Attached are my xorg.conf, and my bug-report.

nixxon 11-22-06 09:47 AM

Re: resolution 1440x900 problem
 
Quote:

Originally Posted by greviant
I have a similar problem with GeForce 6800 Ultra AGP card and ViewSonicE70 CRT monitor. Ubuntu Edgy 2.6.17.10, monitor usually caps out at 1400x1050@60Hz, but new drivers won't let me run at anything more than 800x600@51Hz

Attached are my xorg.conf, and my bug-report.

Which drivers did you use before?

Cambo 11-22-06 10:03 AM

Re: resolution 1440x900 problem
 
@greviant: It looks like the driver cannot read the EDID info from your monitor;

Quote:

(--) NVIDIA(0): Connected display device(s) on GeForce 6800 Ultra at
(--) NVIDIA(0): PCI:1:0:0:
(--) NVIDIA(0): @@@ (CRT-1)
(--) NVIDIA(0): @@@ (CRT-1): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-1
(WW) NVIDIA(0): No valid modes for "1400x1050"; removing.
(WW) NVIDIA(0): No valid modes for "1280x1024"; removing.
(WW) NVIDIA(0): No valid modes for "1152x864"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0): No valid modes for "800x600"; removing.
(WW) NVIDIA(0): No valid modes for "640x480"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
http://www.viewsonic.com/products/de...ies/e70/#specs has the specs for your monitor. Editting your Monitor Section of your /etc/X11/xorg.conf may help. Try;

Quote:

Section "Monitor"
Identifier "ViewSonic E70"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection
According to the specs page, the maximum resolution for your monitor is only 1280x1024.

When it comes to the refresh rate that you can see, bear in mind that the Nvidia driver actually changes the numeric value, so that XRandR does not get confused - there are several posts referencing this, and it's in the driver's README file.



Cambo

nixxon 11-22-06 10:09 AM

Re: resolution 1440x900 problem
 
solved with Option "ModeValidation" "NoEdidDFPMaxSizeCheck" (nana2)

greviant 11-26-06 10:41 AM

Re: resolution 1440x900 problem
 
What section did you put this option in?

Cambo 11-26-06 10:47 AM

Re: resolution 1440x900 problem
 
@greviant: From http://us.download.nvidia.com/XFree8...ppendix-d.html

Quote:

Appendix D. X Config Options

The following driver options are supported by the NVIDIA X driver. They may be specified either in the Screen or Device sections of the X config file.
....


Cambo


All times are GMT -5. The time now is 06:09 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.