nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia driver vs livna driver (http://www.nvnews.net/vbulletin/showthread.php?t=81003)

sammy11 11-22-06 09:30 PM

nvidia driver vs livna driver
 
Has anybody read the sticky post on linuxquestions.org, https://www.redhat.com/archives/fedo.../msg01178.html? It mentioned a damage by nvidia driver to the fedora system. Is it true?
I thus tried the livna.org driver:
Quote:

yum kmod-nvidia
The installation went well. But when I issue "startx", I got erro messages saying "Module nvidia not found" and the x-window won't start. How do I solve this problem? (I did nvidia official drive installation and it runs well, now I am just want to try livna.org driver and do a comparison). How do I fix the problem without run the ".run" drive installation?
Thanks,

russofris 11-23-06 03:50 AM

Re: nvidia driver vs livna driver
 
Though "damage" is too strong a word for my taste, the post is accurate. Nvidia created a generic installer that 'should' work with the majority of distros out there. It does appear that they put more effort into installing than uninstalling, but that's their perogative. Consider the Nvidia installer a "reference implementation" of the installer. You should always use your distro specific installer to add and remove third party driver files.

Your options are as follows:

1: Troubleshoot the kmod-nvidia installation
Have you tried finding the nvidia.ko? Have you tried to modprobe nvidia? Have you -v verbosed the yum install to see where the files are being placed?

2: If you have no intention of ever un-installing the NVidia card, you could use the Nvidia supplied driver, and simply "deal" with the uninstallation in the manner described in the referenced post.

3: Make your own rpm, file a nvidia bug report on the nvidia installer, write a patch to the nvidia installer, etc.

Thank you for your time,
Frank Russo

sammy11 11-23-06 03:42 PM

Re: nvidia driver vs livna driver
 
Thanks for the reply. Now I kind of know the reason of error of "Module nvidia not found". My PC is 64-bit, dual-processor, it has "smp" kernel. The "kmod-nvidia" installation did not find the fitting module for it. The correct installation should be "kmod-nvidia-smp", but it also did not find the matching module. It seems "livna.org" does not have the nvidia-smp module.
Now, I may have two option:
(1) install non-smp kernel, and install kmod-nvidia. Will this hurt the performance of video card (I have quadro FX 4500, it is a ultra high end, and I would like to optimize its performance) since I have dual processors?
(2) find the nvidia-smp module in nvidia.com. I think it is in the ".run" driver file. Can I "sh driverfile.run --extractonly" and locate the module? What will be the name of the module? How do I put it in my FC5 system?
Thanks,


All times are GMT -5. The time now is 06:53 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.