nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   9626 builds but no glx (http://www.nvnews.net/vbulletin/showthread.php?t=81087)

wbing 11-24-06 07:55 AM

9626 builds but no glx
 
3 Attachment(s)
Hi,

I am new to linux and trying to install nvidia has been a steep learning curve. I am using FC6 and a GForce 3 Ti500.

Managed to get 9626 to build by changing <linux/config.h> to <linux/autoconf.h> in nv-linux.h, after much searching.

Can't find solution though from the forum or it's there but I can't understand it. I have checked the installed components against README and they seemed to be present. But my xorg.conf file still shows "nv" driver.

Running glxgears gives me:
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

And ldd glxinfo gives me:
linux-gate.so.1 => (0x003b3000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x00253000)
libGLU.so.1 => /usr/lib/libGLU.so.1 (0x4f045000)
libc.so.6 => /lib/libc.so.6 (0x4e426000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x41000000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x003b4000)
libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0x00110000)
libm.so.6 => /lib/libm.so.6 (0x4e565000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x41104000)
libdl.so.2 => /lib/libdl.so.2 (0x4e58e000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x4e865000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x4e857000)
/lib/ld-linux.so.2 (0x4da57000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x4e5c2000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x4e6cb000)

My xorg log shows this error message:
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

Below are my logs.
Attachment 22349
Attachment 22350
Attachment 22351

In my untrained assessment, it could be a linking problem?? Would appreciate some pointers or help.

Thanks!
wbing

Cambo 11-24-06 08:06 AM

Re: 9626 builds but no glx
 
In your /etc/X11/xorg.conf, you have;

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Change the "nv" to "nvidia".

You might get a better config if you run 'nvidia-xconfig' as root.



Cambo

wbing 11-25-06 12:38 AM

Re: 9626 builds but no glx
 
Thanks Cambo. It worked.

I can run glxgears now but the resolution is stuck at 800x600 (as reported by others). The EDID readings in my xorg log states that my max pixel clock at 0.00 Mhz so all modes removed. Tried "false" options for "UseEdid" or "UseEdidDpi" but X doesn't change.

I don't know if it's something simple I missed like "nv" to "nvidia". :o

Appreciate your help.

wbing

Cambo 11-25-06 12:42 AM

Re: 9626 builds but no glx
 
If you do another nvidia-bug-report, with the nvidia driver running now, I'll take a look at it.

BTW, what monitor are you using?



Cambo

wbing 11-25-06 01:00 AM

Re: 9626 builds but no glx
 
1 Attachment(s)
Here's my bug report:

Attachment 22359

I am using a CRT, NEC Multisync V921. Default resolution 1280x1024 at 85Mhz (refresh rate recommended by NEC).

Appreciate it.

Cambo 11-25-06 01:25 AM

Re: 9626 builds but no glx
 
OK, well your /etc/X11/xorg.conf seems to be missing some stuff. I would suggest adding;

Quote:

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection
While you're at it, get rid of all those " ### Comment all HorizSync and VertSync values to use DDC:" lines ;-)

In your 'Section "Screen"', 'SubSection "Display"', you need to add the 1600x1200 mode.

I haven't been able to track down the frequency specs for your monitor, so I'm assuming for now that the figures you have are correct.

Try adding 'Option "UseEDID" "False" in your Screen section. You can look up the various different option at http://us.download.nvidia.com/XFree8...ppendix-d.html

Hope that helps a bit.


Cambo

wbing 11-25-06 02:07 AM

Re: 9626 builds but no glx
 
Your suggestion to add "Load glx, dbe ...etc" to xorg.conf is because the nvidia driver is...I don't know how exactly to put this...a different or added component to xorg? I saw those items loaded in the log and hence i didn't put them into xorg.conf. Is my understanding correct?

I have actually remove some modes in the Display subsection (except for 1280x1024) thinking it would help. And I did put in the "UseEdid - False" option

I'll go through it again. Thanks again Cambo.

wbing

Cambo 11-25-06 02:19 AM

Re: 9626 builds but no glx
 
I just cut'n'pasted that Module section from my own xorg.conf ;-)



Cambo

Cambo 11-25-06 02:56 AM

Re: 9626 builds but no glx
 
Found a different Monitor section for you to try;

Quote:

Section "Monitor"
Identifier "NEC V921"
HorizSync 31-96
VertRefresh 55-160
Option "DPMS"
EndSection


Cambo


All times are GMT -5. The time now is 04:07 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.