nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   9742 Beta won't doesn't support GeForce4 420? (http://www.nvnews.net/vbulletin/showthread.php?t=81157)

mfuzzey 11-25-06 07:23 PM

9742 Beta won't doesn't support GeForce4 420?
 
Hi,
I just upgeaded to 9629 to use xgl / compiz. That works fine however games that switch graphics mode crash X.

I've read here that this is fixed in the 9742 beta.

But this fails to install with :
WARNING: The NVIDIA GeForce4 440 Go 64M GPU installed in this system is
supported through the NVIDIA legacy Linux graphics drivers. Please
visit http://www.nvidia.com/object/unix.html for more information.
The 1.0-9742 NVIDIA Linux graphics driver will ignore this GPU.
WARNING: You do not appear to have an NVIDIA GPU supported by the 1.0-9742
NVIDIA Linux graphics driver installed in this system. For further
details, please see the appendix SUPPORTED NVIDIA GRAPHICS CHIPS in
the README available on the Linux driver download page at
www.nvidia.com.

However the README lists the 420 / 440 as supported.

What is going on here - is it a bug in the beta or are these chips really being dropped (as its a laptop I can't change the chipset if I wanted to...)

line from lspci -nn:
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV17 [GeForce4 420 Go 32M] [10de:0179] (rev a3)

Regards,

Martin

zander 11-25-06 07:54 PM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
GeForce4 GPUs will continue to be supported through legacy graphics drivers from the 1.0-96xx series; they are not supported by the 1.0-9742 BETA and upcoming non-legacy driver releases. The VidMode crash will also be fixed in the next 1.0-96xx driver release.

El_Presidente 11-25-06 10:34 PM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
@zander why dont you write a compatibility list for each driver and post it as sticky in the forum so these post will not occur anymore ;)

zander 11-25-06 10:38 PM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
@El_Presidente: the supported GPU lists should already do this, but get out of sync every now and then...

fozner 11-26-06 01:27 AM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
So the MX440 has been moved to legacy too? I get (EE) Cannot load GLX using legacy 1.0.77xx

Will try 1.0.96xx I guess.

Cambo 11-26-06 02:52 AM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
There are 2 different 'legacy' categories. I guess Nvidia are going to have to find some way of naming them differently, or something ;-)

The 96xx series will continue to support your GPU (NV17).

The 97xx and higher will be for NV20 and later GPUs.



Cambo

fozner 11-26-06 03:15 AM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
Nope. 1.0-96.29 says my MX440 is "not supported"

and 1.0.77xx is not compat. with kernel > 2.6.18

... which means MX440 and Fedora Core 6 don't mix.

Anybody wanna buy a cheap video card?

Cambo 11-26-06 03:20 AM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
Ah yes, sorry. That's 'cos Nvidia were a little bit naughty with the naming of some of the Geforce 4 series. The 4 MX cards are pretty much just supped up Geforce 2 cards :/

I shall now go and stand in the dunce corner for half an hour ;-)



Cambo

fozner 11-26-06 04:08 AM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
The MX440 does work with compiz, if I install the pre-compiled binary nVidia driver 1.0-96.29 for Fedora Core 6, but it DOES generate occasional obscure thread locking errors with most games on wine, and there are missing textures. People are going to report a few unnecessary bugs with this unsupported card, due to the way Fedora's yum package manager lets you install unsupported drivers without warning. (lee63)

bobbel42 11-26-06 11:50 AM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
I just tried 9742 Beta and it refuses to complete the installation process. It says my GeForce4 Ti 4200 isn't supported. BTW: this is a NV25 GPU, so I guess Cambo's statement isn't correct. It does agree with zander's statement however that GeForce4 cards will not be supported by the 97xx drivers.

The reason I was trying the 9742 Beta drivers is that I just upgraded from RedHat 9 to Fedora Core 6 and I'm having trouble with the precompiled 9629 packages from livna. 2D acceleration works fine (TwinView works perfectly!) but glxinfo exits with a Segmentation fault. The same thing happens when I select the "OpenGL/GLX Information" node in the nvidia-settings app. :(

netllama 11-26-06 01:18 PM

Re: 9742 Beta won't doesn't support GeForce4 420?
 
1.0-96xx supports all the same GPUs that 1.0-87xx supported (per the README).
1.0-9742 supports all GPUs that are NV3x or newer (the README is not accurate).
1.0-71xx supports exactly what is documented in its README.


All times are GMT -5. The time now is 08:07 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.