nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Can't use nvidia drivers on Ubuntu Edgy 6.10 ? (http://www.nvnews.net/vbulletin/showthread.php?t=81894)

voxel 12-07-06 04:08 PM

Can't use nvidia drivers on Ubuntu Edgy 6.10 ?
 
I have an Alienware laptop with a GeForce FX Go5600 video card, which is apparently supported on the latest drivers...
When I follow the guide on:
http://ubuntuguide.org/wiki/Ubuntu_E....28NVID IA.29

After restarting GNOME, I simply get a black screen... and have to revert back to the nv driver.
I noticed these commands on a few other posts, and figured the information might be useful:

Code:

lspci -n | grep 030
001:00.0 0300: 10de:031a (rev a1)

lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation NV31M [GeForce FX Go5600] (rev a1)

If anyone has any ideas/suggestions/insights it would be greatly appreciated!!! I've been trying to make time to get ubuntu going on my laptop for a long time, and I really want to get 3D support working! Thanks in advance!

netllama 12-07-06 04:10 PM

Re: Can't use nvidia drivers on Ubuntu Edgy 6.10 ?
 
Please generate and attach an nvidia-bug-report.log while this problem is present.

You should also verify that you're using the latest BIOS.

Thanks,
Lonni

NotASquirrel 12-19-06 03:59 PM

Re: Can't use nvidia drivers on Ubuntu Edgy 6.10 ?
 
I am also trying to get the nvidia drivers running. I thought I should mention because my setup is nearly identical to yours:

Ubuntu Edgy 6.10
Alienware Area-51m laptop
Geforce 5700Go

My symptoms are a corrupted-looking screen, not a black one. A few questions:

If you type your login and password, do you hear the system log you in?

If you plug an external monitor into the VGA port and then shut down / restart gnome, do you then get a fully functional desktop on the external monitor, but no way of switching that to your laptop screen?

If you try to start gnome with the nvidia drivers and then look at the file /var/log/xorg.log, looking for a bunch of consecutive lines containing "NVIDIA", do you see a list like this?:
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0): No valid modes for "800x600"; removing.
(WW) NVIDIA(0): No valid modes for "640x480"; removing.

Does it help if you add this line to xorg.conf, in the Screen section? (Mine is just underneath the resolution declarations, like shown)
Code:

Section "Screen"
    Identifier    "Default Screen"
    Device        "NVIDIA Corporation NV36 [GeForce FX Go5700]"
. . . [more stuff] . . .
    SubSection    "Display"
        Depth      24
        Modes      "1680x1050" ... etc ...
    EndSubSection
    Option        "UseEDID" "FALSE"
EndSection

Disabling EDIDs doesn't help me out at all. It does the same thing. I'm still trying to figure out the problem and it doesn't seem like many other people have it. I'm starting to think it's some weird interaction between AlienWare laptops and Ubuntu Edgy. If you have exactly the same symptoms, we should watch each others' posts or move to a new thread or something.

NotASquirrel 12-19-06 11:26 PM

Re: Can't use nvidia drivers on Ubuntu Edgy 6.10 ?
 
Just in case anyone finds this thread (like I did) while searching for a problem not solved by disabling EDIDs in xorg.log, I opened a new thread for my issue:

--> Laptop screen unusable, corrupted, but X and VGA port work

Did this because it seems likely my problem might be unrelated to EDIDs so far.

Thanks!


All times are GMT -5. The time now is 06:02 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.