nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Have to reinstall drivers each logon for FC6. (http://www.nvnews.net/vbulletin/showthread.php?t=81986)

bumfluff 12-08-06 01:45 PM

Have to reinstall drivers each logon for FC6.
 
Hi,

I'm a newbie to Linux and FC6 so go easy please! :D

I've successfully installed the nvidia 1.0-9631 drivers and they're running perfectly which is clearly seen in GNOME and KDE.

However, each time I reboot, the drivers are lost and the have to be installed again for them to work.

Could someone point me to some log files to look at to try and work out what's going on.

Many thanks in advance


Joel

zaOnline 12-08-06 04:38 PM

Re: Have to reinstall drivers each logon for FC6.
 
I had the same problem with Debian. I figured out that the problem was the nvidia-glx script debian ran every time it booted. When I disabled the driver installation worked well.

Look for nvidia-glx or linux-restricted-drivers under /lib/ directory.. ubuntu have a directory named linux-restricted-driver that contained a nvidia driver, you need to delete it and install the drivers from nvidia if it exist on your system.

iki488 12-08-06 05:53 PM

Re: Have to reinstall drivers each logon for FC6.
 
try

Code:

sudo nano /lib/modules/2.6.17-10-generic/modules.alias
(change 2.6.17-10-generic with your kernel version)

and comment these two lines :
Code:

alias char-major-195-* nvidia_legacy
alias pci:v000010DEd*sv*sd*bc03sc00i00* nvidia_legacy


bumfluff 12-09-06 03:58 AM

Re: Have to reinstall drivers each logon for FC6.
 
Thanks for the swift reply. I've tried both the above and no joy. (I can't restricted drivers).

I've noticed a couple more things that may be of use with the diagnosis:

1. Upon bootup I receive the error message nivdia kernel not found..nvidia.ko cannot be found.

2. When I reinstall the nvidia driver, it reports that there is an existing nvidia driver and asks me to replace it. It then builds the kernel module, and gives a warning regarding "The nvidia-installer was unable to determine the correct X library installation path with the pkg-config utility. Please install the X.Org SDK/development package for your distribution."
Followed by "nvidia-installer was unable to determine the correct X library installation path and will install the NVIDIA X libraries to /usr/lib"

Not sure if this is related to my problem as the drivers still install fine.

Thanks for your help from a total noobie. :)

iki488 12-09-06 05:03 AM

Re: Have to reinstall drivers each logon for FC6.
 
Quote:

Originally Posted by bumfluff
Thanks for the swift reply. I've tried both the above and no joy. (I can't restricted drivers).

I've noticed a couple more things that may be of use with the diagnosis:

1. Upon bootup I receive the error message nivdia kernel not found..nvidia.ko cannot be found.

2. When I reinstall the nvidia driver, it reports that there is an existing nvidia driver and asks me to replace it. It then builds the kernel module, and gives a warning regarding "The nvidia-installer was unable to determine the correct X library installation path with the pkg-config utility. Please install the X.Org SDK/development package for your distribution."
Followed by "nvidia-installer was unable to determine the correct X library installation path and will install the NVIDIA X libraries to /usr/lib"

Not sure if this is related to my problem as the drivers still install fine.

Thanks for your help from a total noobie. :)

did you install these packages before nvidia-glx ?
Code:

build-essential
linux-source
linux-headers-`uname -r`  (uname -r is your kernel version number)
xserver-xorg-dev

also, be sur to have uninstalled old nvidia driver.

bumfluff 12-09-06 08:48 AM

Re: Have to reinstall drivers each logon for FC6.
 
Quote:

Originally Posted by iki488
did you install these packages before nvidia-glx ?
Code:

build-essential
linux-source
linux-headers-`uname -r`  (uname -r is your kernel version number)
xserver-xorg-dev

also, be sur to have uninstalled old nvidia driver.


I can't find build-essential, linux-source or linux-headers. Are these for FC6 or just Debian?

Have installed xserver-xorg-dev and same problem.

Also, the nvidia installer says it's uninstalling the old NVIDIA driver but is there anywhere I can check?

Again, thanks for your help.

bumfluff 12-10-06 07:54 AM

Re: Have to reinstall drivers each logon for FC6.
 
FYI: All done on this. Uninstalled all drivers properly and reinstalled and it works.

Thanks for your help.

alaric 12-10-06 11:24 AM

Re: Have to reinstall drivers each logon for FC6.
 
I have to advise against using the nvidia installer on debian.
You should use the debian packages in order not to confuse the package manager/whole system. I am currently writing a "howto" on this, and wrote a script that automates building debian packages from nvidia's .pkg#.run files.

If anyone would like to test it, please.
http://www.xs4all.nl/~carlo17/howto/nvidia.html

(That page contains a link to the script).

Regards,
Alaric


All times are GMT -5. The time now is 10:11 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.