nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   AGP Disabled (http://www.nvnews.net/vbulletin/showthread.php?t=8205)

zarba 03-03-03 03:02 PM

AGP Disabled
 
Hi,

Please, help me to enable AGP on my linux.

My hardware :
Asus P4B533 Chipset i845
Leadtek Geforce 4 ti 4200 250 LE
Used kernel is 2.4.20
Xfree is 4.3

What's wrong :
cat /proc/driver/nvidia/agp/status
Status: Disabled

AGP is well detected on boot time.
Using dmesg, we can see :
agpgart: AGP aperture is 256M @ 0xe0000000
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Detected Intel i845 chipset
agpgart: AGP aperture is 256M @ 0xe0000000

Information about my graphic cards is well
detected too :
cat /proc/driver/nvidia/agp/card
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000000

cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: Intel i845
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000000

cat /proc/driver/nvidia/cards/0
Model: GeForce4 Ti 4200
IRQ: 11
Video BIOS: 04.25.00.30.00
Card Type: AGP

In Bios :
Pnp is set to "no"
AGP is set to 4X ( i have tried 1X but
it gives me the same result ).

I've tried :
insmod agpgart agp_try_unsupported=1
but agp is still disabled.

Any ideas ?

Thanks

SlaYMode 03-03-03 03:32 PM

try this
 
tryed the NVagp module? it does support your motherboard.
To force the use of NVagp insert this line in the device section of XF86Config file:
Option "NvAgp" "1"
the default is "3" (uses AGPGART, if it fails uses NvAgp).
I warn you not to use the AGPGART module with the NvAgp.
best wishes (life isn't so much beautiful without AGP :)

zarba 03-03-03 03:51 PM

I tried this but AGP is still disabled.

Delleon 03-04-03 07:09 AM

What version of gcc are you using?

I have a Geforce4 TI with an NForce2 motherboard and for some weird reason, AGP was listed as being disabled when using the 4191 drivers too. I had reverted back to the 3123 drivers temporarily and it worked (only at AGP 2x), however after upgrading to gcc 3.2.2, I was able to get AGP working properly at 8x. I'm not entirely sure it was the upgrade to gcc 3.2.2 that fixed the problem, however I can't think of anything else I changed that would've had that effect.

/proc/driver/nvidia/agp/status
Status: Enabled
Driver: NVIDIA
AGP Rate: 8x
Fast Writes: Enabled
SBA: Enabled

zarba 03-04-03 10:43 AM

I use gcc 3.2.2

Where did u see that AGP
was disabled with drivers 4191 ?

Delleon 03-04-03 02:23 PM

In /proc/drivers/nvidia/agp/status. 3D performance was noticeably improved once this was corrected, so I'm assuming that AGP either wasn't working, or was running at a much lower rate.

Another odd thing in the 4191 drivers was that in /proc/drivers/nvidia/cards/0, my video BIOS showed up as ??.??.??.??.??
It shows up fine now though using 4191.

Did you compile MTRR into your kernel? (I'm just trying to remember all the little things that I did that APPEARED to fix the problem.)

zarba 03-04-03 02:46 PM

I found where was my problem....

It was so stupid....

I got one
Option "NvAGP" "1"
in the device section

and another one in the screen section:
Option "NvAGP" "0"

I didnot see the second one.
grrrr !!

I repeat, it was so stupid..

Sorry to have waste your time...


All times are GMT -5. The time now is 09:40 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.