nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   forcedeth problems on nforce 680i (http://www.nvnews.net/vbulletin/showthread.php?t=82151)

rob4141 12-11-06 01:06 AM

forcedeth problems on nforce 680i
 
2 Attachment(s)
Is anyone else having problems getting the ethernet card on a 680 platform to work? I'm running fedora core 6 on an asus p5n32-E sli motherboard. The forcedeth module loads but I can't get an ipaddress via dhcp and if I setup a static address it still doesn't work. If I rmmod the module the system locks up, though I believe it's being auto reloaded (and locks up at that point) because I get message about it not detecting a link on initialization.

uname -a
Code:

Linux minas-morgul 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST 2006 i686 i686 i386 GNU/Linux
I've attached the dmesg and lspci output.

rob4141 12-12-06 10:05 AM

Re: forcedeth problems on nforce 680i
 
I've done some more research and found that booting with the kernel parameter irqpoll will enable the card to get an ipadress however the system becomes extremely unstable and will crash a few minutes after booting.

rob4141 12-12-06 10:48 PM

Re: forcedeth problems on nforce 680i
 
For future reference the asus board seems to have the same bug the evga one does as described in this link (you have to search 680 with the i to find it :))
http://www.nvnews.net/vbulletin/showthread.php?t=79917

adding
Code:

options forcedeth msi=0 msix=0
to /etc/modprobe.conf on FC6 works for me.


All times are GMT -5. The time now is 12:22 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.