nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia-settings + suspend2 problems (http://www.nvnews.net/vbulletin/showthread.php?t=82346)

walex0325 12-13-06 05:28 PM

nvidia-settings + suspend2 problems
I have a GeForce 7400 with 512 MB, the nvidia 9631 driver and linux on a laptorp. I am using TwinView when I have my latop docked and connected to a second monitor. My metamode configuration is as follows:
Option "metamodes" "DFP-0: 1920x1200 +0+0,CRT-0: 1600x1200 +1920+0;DFP-0: 1920x1200 +0+0,CRT-0: NULL"

When I startx with the second monitor attached, xrandr -q shows two available sizes, 3520x1200 and 1920x1200. I can switch back and forth between these modes to enable/disable the second screen. Then when I suspend the machine and later resume it without the second monitor, I can use xrandr -s to "disable" the second monitor and switch to 1920x1200. However, after I do this and then resume the machine with the second monitor attached, xrandr is no longer able to switch back to 3520x1200.

I can use the nvidia-settings utility to Detect Displays and enable the second monitor. Unfortunately, anytime I use nvidia-settings to apply a new display configuration I can no longer suspend. Shortly after initiating the hibernate cycle, it says "Finding Allowances for Drivers", the screen goes black and never comes back. Normally, it gets to this part, blanks the screen for a few seconds and then continues suspending.

Has anyone else experienced the same problem with suspend2 and nvidia-settings applying a new display configuration? I'm trying to find out if this is a bug in the NVidia driver or if I am missing something in my config. Also, does anyone know of an updated XRandR that fixes the suspend docked/resume+suspend undocked/resume docked problem?


lloeki 12-19-06 02:16 PM

Re: nvidia-settings + suspend2 problems
1 Attachment(s)
yes, I do experience exactly the same freezing issue at the 'finding allowances from drivers', with a 7400 Go on a dell XPS. glad I'm not alone, I was thinking my system was having a hardware defect...

I have one difference though. for me, this occurs as soon as X is started. I could start X then stop it (e.g /etc/init.d/xdm stop under gentoo) and hibernate and resume just fine, but if X is started, then, freeze. both suspend2 and swsusp tried and give same results.

I do not use twinview. I do use two screens though, but that happens even if I only configure the internal panel.

this does not occur on the asus w7j of my girlfriend, which also has a gf7400go.

I even haphazardly reinstalled gentoo from scratch (went from x86 to x86_64), and that did not fix anything.

up till now, I have no solution, except to just stick with suspend to ram, which works for me.

I'd gladly have a fix for that hibernate issue.

EDIT: attached nvbr.log

apekool404 12-20-06 06:01 PM

Re: nvidia-settings + suspend2 problems
Ditto problem. Ditto hardware (Dell XPS M1210), GeForce Go 7400.

With drivers before 1.0.9631 I could hibernate (swsusp and suspend2)... usually. If I ever used suspend to RAM inbetween, subsequent hibernates resulted in a hang. With 1.0.9631, any attempt to hibernate finds me holding the power button down for a prolonged period :-/

STR seems to work but always screws up my text consoles (as in: blank screen, no text, ever). Nowadays I mostly run in level 5, but still, it bothers me.

Will try beta driver 1.0.9742 shortly. One can always hope :-P

-- Steven

lloeki 12-21-06 03:19 AM

Re: nvidia-settings + suspend2 problems
suspend to disk worked back in 8774, then problem has been present for me since I upgraded to 9626, then I downgraded to 8774, just in case, and it was still freezing... now I just go on upgrading, hoping it'll be fixed. that's prolly the last issue I have with this (great) laptop.

regarding s2r, I had the same issue (search on gentoo forums). then, it suddently disappeared. I have been tinkering various things, and it seems using 2.6.18 kernel and vesafb(tng) allows for things to work.

walex0325 12-21-06 11:47 AM

Re: nvidia-settings + suspend2 problems
I am able to successfully suspend to disk if I do not use the nvidia-settings utility to "Detect Displays" when the second monitor is added or removed; however, it did require some mods ot the /etc/hibernate/*.conf files.

First, check to make sure you have this in suspend2.conf:
ProcSetting extra_pages_allowance 0
and the following should be in your hibernate/common.conf file:
SwitchToTextMode yes
UseDummyXServer no

With the 7xxx nvidia series I needed to set UseDummyXServer to yes, but, for whatever reason, this needs to be No for the 9x series.

From what I've read (and remember) if your screen blanks immediately after it says "Doing atomic copy" then you have run out of extra pages. Setting this to 0 supposedly allows suspend2 to dynamically determine the number of pages, but there may be problems with this. Try setting it to (4k * video memory) + 20% if it still doesn't work. Once you are able to successfully suspend/resume, you can see how many pages were used and how many were allocated in either /proc/suspend2/debug_info or /sys/power/suspend2/debug_info depending on your version of suspend2.

I'm about to try Dynamic twinview with the latest nvidia driver. I'll post my results.

lloeki 01-05-07 05:25 PM

Re: nvidia-settings + suspend2 problems
just for the sake of it, I tried suspend2 again, with suggested settings, and still encounter the same issue.

lloeki 01-12-07 03:56 AM

Re: nvidia-settings + suspend2 problems
tried 9746, still crashing at 'finding allowances from drivers'.

meskalamdug 01-23-07 04:18 PM

Re: nvidia-settings + suspend2 problems
Tried with 2.6.20-rc5(with suspend2 patch)
nvidia 9746
latest hibernate script
System hang at resume
i tried the "hacks" of suspend2.conf
but nothing change
On syslog i found

Jan 23 22:56:15 Slack kernel: NVRM: Xid (0001:00): 6, PE0000 0954 5ff8d373 00000000 f000e2c3 00000000


walex0325 02-05-07 01:32 PM

Re: nvidia-settings + suspend2 problems
I rebuilt my laptop this weekend and was seeing this exact same thing at first: The text ui would come up, say Finding Allowances For Drivers, blank the screen and never resume. I had not seen this behavior before. I looked at my old modprobe.conf and found this:

options nvidia NVreg_NvAGP=3

I added this to my new modprobe.conf (depending on your distro you may need to add it to /etc/modprobe.d/nvidia) and was able to get past that screen.

Hope this helps! Suspend2 is still a little unreliable. The scren always blanks when it says "Doing atomic copy". Usually the screen flickers again after this and shuts down the PC, but every once in a while it never returns from this state. However, it's about 80% reliable now.

All times are GMT -5. The time now is 01:45 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.