nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   unable to output 720x576 on tv-out with 9631 (http://www.nvnews.net/vbulletin/showthread.php?t=82563)

Anssi 12-17-06 11:13 AM

unable to output 720x576 on tv-out with 9631
 
1 Attachment(s)
I'm unable to output PAL 720x576 with the 9631 driver.

I get:

(II) NVIDIA(0): Requested modes:
(II) NVIDIA(0): "720x576"
(WW) NVIDIA(0): No valid modes for "720x576"; removing.

Even while the driver claims to support 720x576:

(II) NVIDIA(0): TV modes supported by this encoder:
(II) NVIDIA(0): 1920x1080; Standards: HD1080i
(II) NVIDIA(0): 1280x720; Standards: HD720p
(II) NVIDIA(0): 1024x768; Standards: NTSC-M, NTSC-J, PAL-M, PAL-BDGHI,
(II) NVIDIA(0): PAL-N, PAL-NC
(II) NVIDIA(0): 800x600; Standards: NTSC-M, NTSC-J, PAL-M, PAL-BDGHI, PAL-N,
(II) NVIDIA(0): PAL-NC
(II) NVIDIA(0): 720x576; Standards: HD576i, HD576p
(II) NVIDIA(0): 720x480; Standards: NTSC-M, NTSC-J, PAL-M, HD480i, HD480p,
(II) NVIDIA(0): HD1080i
(II) NVIDIA(0): 640x480; Standards: NTSC-M, NTSC-J, PAL-M, PAL-BDGHI, PAL-N,
(II) NVIDIA(0): PAL-NC, HD480i, HD480p, HD1080i, HD576i
(II) NVIDIA(0): 640x400; Standards: NTSC-M, NTSC-J, PAL-M, PAL-BDGHI, PAL-N,
(II) NVIDIA(0): PAL-NC
(II) NVIDIA(0): 512x384; Standards: NTSC-M, NTSC-J, PAL-M, PAL-BDGHI, PAL-N,
(II) NVIDIA(0): PAL-NC
(II) NVIDIA(0): 400x300; Standards: NTSC-M, NTSC-J, PAL-M, PAL-BDGHI, PAL-N,
(II) NVIDIA(0): PAL-NC
(II) NVIDIA(0): 320x240; Standards: NTSC-M, NTSC-J, PAL-M, PAL-BDGHI, PAL-N,
(II) NVIDIA(0): PAL-NC
(II) NVIDIA(0): 320x200; Standards: NTSC-M, NTSC-J, PAL-M, PAL-BDGHI, PAL-N,
(II) NVIDIA(0): PAL-NC
(II) NVIDIA(0): 0x0; Standards: HD720p, HD1080i, HD576p

I will attach nvidia-bug-report.log.

netllama 12-17-06 11:54 AM

Re: unable to output 720x576 on tv-out with 9631
 
Please start X with the following command:
startx -- -logverbose 6

and then generate a new bug report.

Thanks,
Lonni

Anssi 12-17-06 12:47 PM

Re: unable to output 720x576 on tv-out with 9631
 
Quote:

Originally Posted by netllama
Please start X with the following command:
startx -- -logverbose 6

and then generate a new bug report.

-logverbose 6 is already used. As you can see, the detailed mode/timing info is there.

If you're looking for the mode validation info, that doesn't seem to be getting logged when ConnectedMonitor is TV. If I use CRT instead, Mode validation info does get logged (but that info isn't relevant in this case).

netllama 12-17-06 01:35 PM

Re: unable to output 720x576 on tv-out with 9631
 
Hrmm, did this work with a previous driver? What kind of TV are you using?

Anssi 12-17-06 02:10 PM

Re: unable to output 720x576 on tv-out with 9631
 
Quote:

Originally Posted by netllama
Hrmm, did this work with a previous driver?

Yes, but I don't remember anymore which one. It seems to not work with 8774 either, so it was probably some more older one.
If I remember correctly, I needed to use a custom modeline like
ModeLine "720x576" 14.1 720 760 800 900 576 584 600 625 -hsync -vsync
The modeline timings afaik weren't actually used, but without that line the driver didn't accept the "720x576" mode.
The recent drivers seem to ignore custom ModeLines alltogether when TV-out is in question.
Quote:

Originally Posted by netllama
What kind of TV are you using?

Standard PAL television with S-VIDEO input.

netllama 12-17-06 02:20 PM

Re: unable to output 720x576 on tv-out with 9631
 
If its PAL, then that's the problem, as the nvidia driver doesn't currently support HD modes for PAL.

Anssi 12-17-06 02:50 PM

Re: unable to output 720x576 on tv-out with 9631
 
Quote:

Originally Posted by netllama
If its PAL, then that's the problem, as the nvidia driver doesn't currently support HD modes for PAL.

The tv set also supports NTSC, but afaik 720x576 should be a PAL-only mode (NTSC max res is 720x480).
So did the driver support them before, then, as I had this working once?
It also seems a bit strange to call 720x576 a HD mode, as it is the standard PAL resolution.

I will see if I could try some older drivers tomorrow. I'll have to downgrade my kernel (2.6.18), though.

Thunderbird 12-18-06 06:00 AM

Re: unable to output 720x576 on tv-out with 9631
 
Try to select HD576i as that should similar to standard PAL.

Anssi 12-18-06 09:34 AM

Re: unable to output 720x576 on tv-out with 9631
 
Quote:

Originally Posted by Thunderbird
Try to select HD576i as that should similar to standard PAL.

That is the mode I have been trying here all along (as the lists shows only HD576i and HD576p supported with 720x576).

ukrcald 01-30-07 11:25 AM

Re: unable to output 720x576 on tv-out with 9631
 
How's this going?
I've had the same problem since debian upgraded to xorg7.1.
I have thVGA CRT connector running to a SCART socket and a small circuit to convert the VGA sync to composite sync, the upshot is I get RGB to my TV (better than s-video)
.. anyway i get the same errors... :
(--) NVIDIA(1): Philips 200W (DFP-0): Internal Dual Link TMDS
(II) NVIDIA(1): Assigned Display Device: CRT-0
(WW) NVIDIA(1): No valid modes for "702x576@25i"; removing.
(WW) NVIDIA(1):
(WW) NVIDIA(1): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(1): "nvidia-auto-select".
(WW) NVIDIA(1):
...
there's no modes as it's a TV! ?

here's my xorg.conf:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Mar 29 14:43:26 PST 2006

################################################## #####
################################################## ####
################################################## ####

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Philips"
ModelName "200w"
HorizSync 30.0 - 93.0
VertRefresh 56.0 - 85.0
Option "DPMS"

EndSection

Section "Monitor"
Identifier "TV"
HorizSync 15-17
VertRefresh 49.0-61.0
ModeLine "702x576@25i" 13.5 702 722 785 864 576 581 586 625 interlace -hsync -vsync

EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6150"
BusID "PCI:00:05:00"
Screen 0
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6150"
BusID "PCI:00:05:00"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "UseDisplayDevice" "DFP-0"
Option "NoLogo" "True"
SubSection "Display"
Depth 24
Modes "1680x1050"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "TV"
DefaultDepth 24
Option "UseDisplayDevice" "CRT-0" # "TV-0"
Option "NoLogo" "True"
SubSection "Display"
Depth 24
Modes "702x576@25i"
EndSubSection
EndSection
.

Hope you got somewhere, otherwise i'll post a separate thread...

Anssi 01-30-07 11:54 AM

Re: unable to output 720x576 on tv-out with 9631
 
Quote:

Originally Posted by ukrcald
How's this going?
I've had the same problem since debian upgraded to xorg7.1.
I have thVGA CRT connector running to a SCART socket and a small circuit to convert the VGA sync to composite sync, the upshot is I get RGB to my TV (better than s-video)
.. anyway i get the same errors... :

Your problem is likely not related to mine. My problem is the apparent regression that the nvidia driver seems to now ignore the TV mode HD576i available on the Philips TV encoder chip of my GF4ti4200. Unfortunately I haven't been able to do any more testing due to the card in question being now in a production box.


All times are GMT -5. The time now is 12:50 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.