nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X.org doesn't start: segmentation fault trying to initialize GLX extension (http://www.nvnews.net/vbulletin/showthread.php?t=82702)

artem 12-19-06 04:02 PM

X.org doesn't start: segmentation fault trying to initialize GLX extension
 
Hello, I've recently upgraded to vanilla kernel 2.6.16.36 (I had 2.6.16.27 before) and X.org no longer starts with GLX enabled - I get segmentation fault. I tried increasing X.org verbosity level by running X -logverbous 9 but I just get the same result:

...
(II) Initializing extension GLX
Segmentation fault.

When I comment out "glx" module in X.org configuration file X.org starts.

Hardware: Sempron 3000/939, nForce4/nVidia 6100 IGP (or maybe 6150) motherboard. Upgrading to the most recent driver available (96.31) doesn't help.

netllama 12-19-06 04:04 PM

Re: X.org doesn't start: segmentation fault trying to initialize GLX extension
 
See:
http://www.nvnews.net/vbulletin/showthread.php?t=46678

artem 02-01-07 12:57 PM

Re: X.org doesn't start: segmentation fault trying to initialize GLX extension
 
1 Attachment(s)
I'm sorry for a long delay.

Updating for 2.6.16.38 and latest nVidia drivers didn't help. OpenGL/GLX still doesn't load.

Here are two reports: one with GLX enabled and X.org segfaulting and another one with GLX disabled and X.org starting normally.

netllama 02-01-07 01:07 PM

Re: X.org doesn't start: segmentation fault trying to initialize GLX extension
 
I see this warning:
WARNING: nvidia-installer was forced to guess the X library path '/usr/lib' and
X module path '/usr/lib/xorg/modules'; these paths were not queryable
from the system. If X fails to find the NVIDIA X driver module,
please install the `pkg-config` utility and the X.Org SDK/development
package for your distribution and reinstall the driver.

I'd suggest reading here:
http://www.nvnews.net/vbulletin/showthread.php?t=72490

artem 02-07-07 08:40 AM

Re: X.org doesn't start: segmentation fault trying to initialize GLX extension
 
1 Attachment(s)
I have installed Xorg SDK and pkgconfig as you suggested - still no luck.

netllama 02-07-07 10:19 AM

Re: X.org doesn't start: segmentation fault trying to initialize GLX extension
 
In the installer log I see:
-> Installing classic TLS OpenGL libraries.

I'm wondering if perhaps your system needs the 'new' TLS libraries. Can you try reinstalling with the --force-tls=new option?

artem 02-20-07 09:50 AM

Re: X.org doesn't start: segmentation fault trying to initialize GLX extension
 
Installing new tls libraries did the trick. Thank you. I hope the next version of nVidia linux drivers will automatically check what version of libraries to install.

chunkey 02-20-07 09:57 AM

Re: X.org doesn't start: segmentation fault trying to initialize GLX extension
 
Quote:

Originally Posted by artem
Installing new tls libraries did the trick. Thank you. I hope the next version of nVidia linux drivers will automatically check what version of libraries to install.

The installer does this already! And it does it quite well...

artem 02-20-07 10:08 AM

Re: X.org doesn't start: segmentation fault trying to initialize GLX extension
 
Quote:

Originally Posted by chunkey
The installer does this already! And it does it quite well...

In my case it didn't.


All times are GMT -5. The time now is 04:29 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.