nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Laptop screen unusable, corrupted, but X and VGA port work (http://www.nvnews.net/vbulletin/showthread.php?t=82722)

NotASquirrel 12-19-06 10:07 PM

Laptop screen unusable, corrupted, but X and VGA port work
 
Hi, I'm moving my questions about this to a new thread for TS because I'm starting to think it isn't related to the other problems involving EDIDs. (even though the symptoms are similar.)

Symptoms are, when GDM starts up, it rejects all resolutions and ends up showing just corrupted graphics on the laptop screen. The graphics are almost exactly the same every time, like a memory region holding an 800x600 image being displayed raw at 640x480.

Plugging a monitor into the laptop VGA port and restarting GDM results in a perfectly functional desktop being displayed on the external monitor at the correct native resolution, with fast and functional openGL and everything, but the laptop's screen stays blank. The nvidia drivers' gui utility cannot seem to make the laptop screen work when I tweak it from the second monitor. It sees a disabled screen at 640x480 but seems to get hung up whenever it tries to do anything with it. It will spit out a rewritten xorg.conf, but this also does not work.

/var/log/xorg.0.log shows these lines coming from the NVIDIA drivers that seem to be related to the problem. It is rejecting all resolutions. (Maybe they are not defined correctly? But I did not change them...)

Note - this xorg.0.log happened with EDIDs enabled. I turned them back on after disabling them did not help.
Code:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): NVIDIA GPU GeForce FX Go5700 at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 04.36.20.33.14
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce FX Go5700 at
(--) NVIDIA(0):    PCI:1:0:0:
(--) NVIDIA(0):    Nvidia Default Flat Panel (DFP-0)
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): 300.0 MHz maximum pixel
(--) NVIDIA(0):    clock
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1680x1050_75_0"; removing.
(WW) NVIDIA(0): No valid modes for "1280x854"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0): No valid modes for "800x600"; removing.

(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):    "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(--) NVIDIA(0): DPI set to (50, 60); computed from "UseEdidDpi" X config
(--) NVIDIA(0):    option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
        [0] 0  0      0xc0000000 - 0xcfffffff (0x10000000) MX[b]
        [1] 0  0      0xdc000000 - 0xdcffffff (0x1000000) MX[b]
        [2] -1  0      0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
        [3] -1  0      0x000f0000 - 0x000fffff (0x10000) MX[b]
        [4] -1  0      0x000c0000 - 0x000effff (0x30000) MX[b]
        [5] -1  0      0x00000000 - 0x0009ffff (0xa0000) MX[b]
        [6] -1  0      0xdeff0000 - 0xdeffffff (0x10000) MX[b]
        [7] -1  0      0xdefefc00 - 0xdefefcff (0x100) MX[b]
        [8] -1  0      0xdefee000 - 0xdefeefff (0x1000) MX[b]
        [9] -1  0      0xdefed000 - 0xdefedfff (0x1000) MX[b]
        [10] -1 0      0xdefec000 - 0xdefecfff (0x1000) MX[b]
        [11] -1 0      0xdefeb000 - 0xdefebfff (0x1000) MX[b]
        [12] -1 0      0xdefea000 - 0xdefeafff (0x1000) MX[b]
        [13] -1 0      0xdefe9000 - 0xdefe9fff (0x1000) MX[b]
        [14] -1 0      0xe0000000 - 0xdfffffff (0x0) MX[b]O
        [15] -1 0      0xddee0000 - 0xddefffff (0x20000) MX[b](B)
        [16] -1 0      0xc0000000 - 0xcfffffff (0x10000000) MX[b](B)
        [17] -1 0      0xdc000000 - 0xdcffffff (0x1000000) MX[b](B)
        [18] -1 0      0xdf000000 - 0xdfffffff (0x1000000) MX[b](B)
        [19] 0  0      0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
        [20] 0  0      0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
        [21] 0  0      0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
        [22] -1 0      0x0000ffff - 0x0000ffff (0x1) IX[b]
        [23] -1 0      0x00000000 - 0x000000ff (0x100) IX[b]
        [24] -1 0      0x0000e800 - 0x0000e8ff (0x100) IX[b]
        [25] -1 0      0x0000ec00 - 0x0000ec7f (0x80) IX[b]
        [26] -1 0      0x0000e400 - 0x0000e4ff (0x100) IX[b]
        [27] -1 0      0x0000ee80 - 0x0000eeff (0x80) IX[b]
        [28] -1 0      0x0000e000 - 0x0000e0ff (0x100) IX[b]
        [29] -1 0      0x0000ffa0 - 0x0000ffaf (0x10) IX[b]
        [30] -1 0      0x00000c00 - 0x00000c1f (0x20) IX[b]
        [31] 0  0      0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
        [32] 0  0      0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): Built-in logo is bigger than the screen.
(II) NVIDIA(0): Setting mode "640x480"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled

System:
Alienware Area-51m laptop
Ubuntu 6.10 (Edgy Eft)
nvidia Geforce 5700 Go
native laptop screen res. is 1680x1050

Linux Kernel (uname -r):
2.6.17-10-generic

Xorg:
1:7.1.1ubuntu6.2 (installed version reported by Synaptic)

Xorg -version
Code:

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.15.7 i686
Current Operating System: Linux bkbuntutop 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686
Build Date: 07 July 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present


xorg.conf
Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Nov  1 19:47:17 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

        # path to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load          "i2c"
    Load          "bitmap"
    Load          "ddc"
    Load          "extmod"
    Load          "freetype"
    Load          "glx"
    Load          "int10"
    Load          "type1"
    Load          "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "us"
    Option        "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ExplorerPS/2"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "false"
EndSection

    ...  (snipped out the typical three Wacom devices for length)

Section "InputDevice"
  Driver        "synaptics"
  Identifier    "TouchPad"
  Option        "Device"        "/dev/input/mouse0"
  Option        "Protocol"      "audo-dev"
  Option      "LeftEdge"      "1700"
  Option      "RightEdge"    "5400"
  Option      "TopEdge"      "1700"
  Option      "BottomEdge"    "4200"
  Option      "FingerLow"    "25"
  Option      "FingerHigh"    "30"
  Option      "MaxTapTime"    "75"
  Option      "MaxTapMove"    "2"
  Option      "TapButton1"    "0"
  Option      "TapButton2"    "2"
  Option      "TapButton3"    "2"
  Option      "VertScrollDelta" "100"
  Option      "MinSpeed"      "0.09"
  Option      "MaxSpeed"      "0.18"
  Option      "AccelFactor"  "0.0015"
  Option      "SHMConfig"    "on"
  Option      "UpDownScrolling"  "on"
  Option      "UpDownRepeat"  "off"
  Option      "ScrollButtonRepeat"  "300"
  Option      "HorizTwoFingerScroll"  "on"
EndSection


Section "Monitor"
    Identifier    "Generic Monitor"
    HorizSync      28.0 - 84.0
    VertRefresh    43.0 - 60.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "NVIDIA Corporation NV36 [GeForce FX Go5700]"
    Driver        "nvidia"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "NVIDIA Corporation NV36 [GeForce FX Go5700]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection    "Display"
        Depth      1
        Modes      "1680x1050_60_0" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      4
        Modes      "1680x1050_60_0" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      8
        Modes      "1680x1050_60_0" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      15
        Modes      "1680x1050_60_0" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      16
        Modes      "1680x1050_60_0" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      24
        Modes      "1680x1050_60_0" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
#    Option        "ModeValidation" "NoEdidModes"
#    Option        "UseEdidFreqs" "FALSE"
#    Option        "UseEDID" "FALSE"
#    Option        "ModeValidation"  "DFP-0: NoDFPNativeResolutionCheck, AllowNon60HzDFPModes, NoMaxPClkCheck, NoEdidMaxPclkCheck, NoHorizSyncCheck, NoVertRefreshCheck, NoWidthAlignmentCheck, NoVirtualSizeCheck, NoEdidModes, NoMaxSizeCheck, NoVesaModes"
EndSection

Section "Extensions"
    Option        "Composite" "Disable"
EndSection


Tried (and failed) so far:

The 'nv' module is disabled :
DISABLED_MODULES="nv"
in /etc/default/linux-restricted-modules-common

Neither of the four commented lines at the end of the Screen section (xorg.conf) helped anything.

Disabling EDIDs did not solve the problem. I checked in xorg.0.log to be sure - it did report the EDIDs were disabled and not being used, and the problem did not change.

Tried different mode declarations for 1680x1050, with no change:
Modes "1680x1050"
Modes "1680x1050_60_0"
Modes "1680x1050_75_0"

I will put in a second post with the larger log files in full and the nvidia-bug-report output.

In total I have probably spent about a week and a half searching around and trying things in xorg.conf... Always going back to a clean one when things didn't work of course.

The other threads I've looked at that were similar to my problem (but I'm thinking one might not be related) are:
--> Monitor doesnt like Drivers
--> Can't use nvidia drivers on Ubuntu Edgy 6.10 ?

NotASquirrel 12-19-06 10:20 PM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
1 Attachment(s)
The full Xorg.0.log and nvidia-bug-report.log are attached in a zip - NotASquirrel_logfiles.zip.

Thanks for reading. I'll be really grateful if anyone is able to help me fix this!

netllama 12-19-06 10:23 PM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
If this problem persists with 1.0-9631 and 1.0-9742, please start X with the following command:
startx -- -loverbose 6

and then generate a new bug report.

Thanks,
Lonni

NotASquirrel 12-19-06 11:02 PM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
Doing that now with 9631.

Anything special I need to do to make sure the old drivers get purged out? (I'm going to just run the .sh script now and see if it works)

Thanks!

NotASquirrel 12-19-06 11:47 PM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
2 Attachment(s)
No luck again.

I updated the drivers using 'nvidia-installer --update'. Started gnome using 'startx -- -logverbose 6' instead of the usual '/etc/init.d/gdm start'. I ran this command as the usual user who logs in normally, not root. Same symptoms except now there is a bit more info to go along with it.

I attached new bug reports in two new zip files, for two new trials:

Trial 2: NotASquirrel_logfiles_2.zip
EDIDs enabled.
In xorg.conf I had declared the maximum vertical refresh as 60Hz, but after starting X with verbose logging I noticed the drivers were trying 61.1 Hz, not 60 Hz, so those modes were getting invalidated incorrectly.

Ran nvidia-bug-report.sh and zipped the output into NotASquirrel_logfiles_2.zip.

Trial 3: NotASquirrel_logfiles_3.zip

Changed the following in xorg.conf:
-- Disabled EDIDs with Option "UseEDID" "FALSE"
-- Changed max vertical refresh to 62 Hz to let those 61.1Hz requests through.

Same results. Same corrupted screen. Ran nvidia-bug-report.sh and zipped output into NotASquirrel_logfiles_3.zip.


I may take another crack at it once I've found the download location for 9742 but so far no luck with 9631.

Thanks again for the quick reply and the help!

netllama 12-20-06 10:38 AM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
Without disabling the EDID, please add the following option to the Device section of xorg.conf:
Option "ModeValidation" "NoVertRefreshCheck"

Thanks,
Lonni

NotASquirrel 12-20-06 12:41 PM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
That worked! Thank you!

I do DCC and was hoping to get to try Maya out in linux as I'd heard good things about its performance. I was worried I'd have to scrap linux yet again and go back to windows.


What I wonder now is why that option didn't work before... I'm not exactly clear on the effects of putting different options in different sections of xorg.conf. I had that option present before, but it was in the Screen section not the Device section.

Thank you! I will go back to the Ubuntu forums thread I started and post the fix now.

voxel 12-31-06 01:19 AM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
I just mustered up the courage to take another shot at getting the new nvidia drivers working on my Alienware Area51m laptop (GeForce FX Go5600) and after instering the Option "ModeValidation" "NoVertRefreshCheck" line into my xorg.conf file, it worked flawlessly!!
I'm currently using the 1.0-9746 drivers, and they seem to be working great
Thanks!!

NotASquirrel 01-02-07 04:09 PM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
Great Voxel!

Nice of you to verify this fix worked on another AlienWare laptop.

By the way I have unverified suspicions that my display might be grabbing 50Hz as its refresh. Not so big a problem on an LCD for me, but you might want to check if you care.

I'm not sure of an easy way to check, and haven't had time to dig yet - which is why it's unverified. I just remember seeing it somewhere right after getting the drivers working, but I was so elated at the time I don't remember where it was.

-- Brian

Pingus 01-08-07 07:07 PM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
Hi Guys,

Thanks so much for your postings on this thread. The same option "ModeValidation" "NoVertRefreshCheck" worked for me on another Alienware Area 51-m laptop!

I was running the Nvidia driver 8776 and all was well when I decided to upgrade to the then-current 9* driver. The compilation failed, complaining that it didn't know where to store some libraries. Uninstall also complained and didn't remove everything it was supposed to. I then entered a world of pain having to remove things by hand.

I next switched to the Debian unstable driver but couldn't get X to start up. After weeks of fiddling, your thread gave me the answer. Thanks again!

We should share our xorg.conf file to see what other Alienware Area 51-m users are up to in their configuration.

Cheers

gr83 01-09-07 11:51 AM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
nice, Option "ModeValidation" "NoVertRefreshCheck" fixed my issue on a similar Alienware laptop (Clevo D9K) (nana2)

NotASquirrel 01-10-07 01:40 AM

Re: Laptop screen unusable, corrupted, but X and VGA port work
 
Mine has been working ever since, though it recognizes 50Hz (minor problem only on LCD but will fix eventually...)

50Hz is the only refresh available in the Gnome res/refresh chooser. This could be my fault for something I put in xorg.conf too, so no worries yet. :D


All times are GMT -5. The time now is 01:29 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.