nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GeForce 420 Go on Kubuntu6.10:Desktop fixed on 800*600 rectangle area,not full screen (http://www.nvnews.net/vbulletin/showthread.php?t=83549)

hufigo 01-03-07 12:35 PM

GeForce 420 Go on Kubuntu6.10:Desktop fixed on 800*600 rectangle area,not full screen
 
3 Attachment(s)
My System:
Toshiba 6100 pro/GeForce4 420 Go/Kubuntu 6.10 Edgy

Hi,everyone.
I installed the 9631(NVIDIA-Linux-x86-1.0-9631-pkg1.run) on my laptop yesterday.
And modified some options in options below:

/etc/modpro.d/
Quote:

options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=1
/etc/X11/xorg.conf
Quote:

Option "UseDisplayDevice" "DFP"
Option "ExactModeTimingsDVI"
Option "UseEdidDpi" "FALSE"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoVesaModes"
After reboot, X and render works but the Desktop is just a 800*600 rectangle in the center of screen, it is not full screen, some black backgound aound(like snapshot.jpg in attachment)!

then i checked /var/log/xorg.0.log
I found some lines like:

Quote:

(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 800 x 600
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in defaul

I cannot get any resolution above 800*600 in nVidia Configure.
And i set 1024*768 in my xorg.conf,but it did not work.

i need EDID.bin file to fix this?
thx in advance.

netllama 01-03-07 12:37 PM

Re: Desktop fixed on 800*600 rectangle area,not full screen
 
See:
http://www.nvnews.net/vbulletin/showthread.php?t=46678

hufigo 01-03-07 01:24 PM

Re: GeForce 420 Go on Kubuntu6.10:Desktop fixed on 800*600 rectangle area,not full sc
 
thx for you reminder,netllama.I've added the bug-report.

My xorg.conf
Quote:

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV17 [GeForce4 420 Go]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV17 [GeForce4 420 Go]"
Monitor "Generic Monitor"
DefaultDepth 16
Option "UseDisplayDevice" "DFP"
Option "ExactModeTimingsDVI"
Option "UseEdidDpi" "FALSE"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoVesaModes"
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection


netllama 01-03-07 01:56 PM

Re: GeForce 420 Go on Kubuntu6.10:Desktop fixed on 800*600 rectangle area,not full screen
 
In your bug report I see:
(WW) NVIDIA(0): Unrecognized ModeValidation token "NoEdidDFPMaxSizeCheck";
(WW) NVIDIA(0): ignoring.

However, you didn't generate a verbose X log, per the instructions in the post I referenced earlier.

thepisu 04-08-07 09:39 AM

Re: GeForce 420 Go on Kubuntu6.10:Desktop fixed on 800*600 rectangle area,not full sc
 
I resolved adding this line in Screen and Device section:

Option "ModeValidation" "NoEdidMaxPClkCheck,NoDFPNativeResolutionCheck "

mondoswank 04-08-07 02:00 PM

Re: GeForce 420 Go on Kubuntu6.10:Desktop fixed on 800*600 rectangle area,not full screen
 
I am having some issues as well, although a bit different. My screen will boot similarly but into 1280 x 1024 surrounded by black, and I can change the resolution to 1920 x 1200 and it applies, but I can't save the xorg.conf out, getting the following error:

ERROR: Unable to determine valid vertical refresh ranges for display device
'Sharp' (GPU: GeForce4 4200 Go)!
ERROR: Failed to add display device 'Sharp' to screen 0!
ERROR: Failed to add X screen 0 to X config.
ERROR: Failed to add X screens to X config.
ERROR: Failed to generate an X config file!


I have the /etc/modprobe.d/options entry-

options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=1

and /etc/X11/xorg.conf incudes-

ection "Monitor"
Identifier "Generic Monitor"
VendorName "Dell"
ModelName "Dell 1920x1200 Laptop Display Panel (16/10)"
HorizSync 30.0 - 107.0
VertRefresh 50.0 - 185.0
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "640x480@72" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
ModeLine "640x480@75" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
ModeLine "640x480@85" 36.0 640 696 752 832 480 481 484 509 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
ModeLine "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
ModeLine "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "832x624@75" 57.3 832 864 928 1152 624 625 628 667 -hsync -vsync
ModeLine "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
ModeLine "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
ModeLine "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync +vsync interlace
ModeLine "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
ModeLine "1152x768@54" 65.0 1152 1178 1314 1472 768 771 777 806 +hsync +vsync
ModeLine "1280x854" 80.0 1280 1309 1460 1636 854 857 864 896 +hsync +vsync
ModeLine "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
ModeLine "1280x960@85" 148.5 1280 1344 1504 1728 960 961 964 1011 +hsync +vsync
ModeLine "1280x1024@85" 157.5 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
ModeLine "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x960@75" 129.9 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
ModeLine "1400x1050@60" 122.6 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
ModeLine "1400x1050@75" 155.8 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
ModeLine "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
ModeLine "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
ModeLine "1600x1200@75" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
ModeLine "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
ModeLine "1600x1200@85" 229.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
ModeLine "1792x1344@75" 261.0 1792 1888 2104 2456 1344 1345 1348 1417 -hsync +vsync
ModeLine "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
ModeLine "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
Modeline "1920x1200@60" 162.0 1920 2020 2052 2184 1200 1202 1208 1235 +Hsync +Vsync
ModeLine "2048x1536@60" 266.9 2048 2200 2424 2800 1536 1537 1540 1589 -hsync +vsync
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
EndSection

Section "Device"
Identifier "Nvidia 4200 Go"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce4 (generic)"
BusID "PCI:1:0:0"
Screen 0
Option "ExactModeTimingsDVI"
Option "UseEdidDpi" "FALSE"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoVesaModes"
Option "ModeValidation" "NoEdidMaxPClkCheck,NoDFPNativeResolutionCheck "


EndSection

Section "Device"
Identifier "device1"
Driver "nv"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce4 (generic)"
BusID "PCI:1:0:0"
Screen 1
Option "ExactModeTimingsDVI"
Option "UseEdidDpi" "FALSE"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoVesaModes"
Option "ModeValidation" "NoEdidMaxPClkCheck,NoDFPNativeResolutionCheck "

EndSection

Section "Screen"
Identifier "Default Screen"
Device "Nvidia 4200 Go"
Monitor "Generic Monitor"
DefaultDepth 24
Option "UseDisplayDevice" "DFP"
Option "ExactModeTimingsDVI"
Option "UseEdidDpi" "FALSE"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoVesaModes"
Option "ModeValidation" "NoEdidMaxPClkCheck,NoDFPNativeResolutionCheck "
SubSection "Display"
Depth 24
Modes "1920x1200@60" "2048x1536@60" "1856x1392@60" "1792x1344@60" "1792x1344@75" "1600x1200@85" "1600x1200@70" "1600x1200@75" "1600x1200@60" "1600x1200@65" "1400x1050@75" "1400x1050@60" "1280x960@75" "1280x1024@60" "1280x1024@85" "1280x960@85" "1280x960@60" "1280x1024@75" "1280x854" "1152x768@54" "1152x864@75" "1024x768@43" "1024x768@60" "1024x768@70" "1024x768@75" "1024x768@85" "832x624@75" "800x600@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "Screen"

#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
Option "UseDisplayDevice" "DFP"
Option "ExactModeTimingsDVI"
Option "UseEdidDpi" "FALSE"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoVesaModes"
Option "ModeValidation" "NoEdidMaxPClkCheck,NoDFPNativeResolutionCheck "
SubSection "Display"
Depth 24
Modes "640x480@60"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"

EndSection
__________________________________________________ _________
__________________________________________________ _________


using the dell monitor settings generated by kubuntu's control manager has been the only way thus far to get up to true 1920 x 1200 at true color. The control center, however, still reports a generic 4 series being driven by nv

I'm using driver 9631.

Thanks in advance!




Thanks in advance, bug reports have been sent.

netllama 04-09-07 07:12 PM

Re: GeForce 420 Go on Kubuntu6.10:Desktop fixed on 800*600 rectangle area,not full screen
 
Please start X with the following command:
startx -- -logverbose 6

and then generate and attach an nvidia-bug-report.log.

Thanks,
Lonni


All times are GMT -5. The time now is 10:28 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.