nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   9746 alt-F[123456] doesn't work (http://www.nvnews.net/vbulletin/showthread.php?t=83592)

ctilburg 01-04-07 08:39 AM

9746 alt-F[123456] doesn't work
 
virtual consoles seem to be broken... should read control-alt-{F[12345]}

sambo57u 01-04-07 08:45 AM

Re: 9746 alt-F[123456] doesn't work
 
I presume you mean ctrl+alt+F[1..] for virtual console. This is
actually working for me but when I do dtrl+alt_f1 I just get a
black screen and no login prompt. When I do ctrl+alt+f7 I do go
back to the previous gui. Using FC6+updates+9746.

ctilburg 01-04-07 08:50 AM

Re: 9746 alt-F[123456] doesn't work
 
yep, that is what I'm talking about... I'm on gentoo

sambo57u 01-04-07 09:29 AM

Re: 9746 alt-F[123456] doesn't work
 
I actually keep getting "Entering Power Save" message after hitting
ctrl+alt+f1.

netllama 01-04-07 11:34 AM

Re: 9746 alt-F[123456] doesn't work
 
see http://www.nvnews.net/vbulletin/showthread.php?t=72490

sambo57u 01-04-07 07:31 PM

Re: 9746 alt-F[123456] doesn't work
 
I could not find any solution there. I am not running Sellinux
and have done all of the recommended steps. This is an
x86_64 system.

netllama 01-04-07 08:56 PM

Re: 9746 alt-F[123456] doesn't work
 
Sorry, I meant here: http://www.nvnews.net/vbulletin/showthread.php?t=46678

sambo57u 01-09-07 01:30 PM

Re: 9746 alt-F[123456] doesn't work
 
I think I found a solution to ctrl+alt+Fn problems:

If you are using KDM, edit your kdmrc file (usually in /etc/X11/xdm)
and insert the line:

TerminateServer=true

In all the blocks that contain -Core in their heading.

If you are using GDM try editing gdm.conf and put in the line:

AlwaysRestartServer=true

Hope this helps!
Sammy

Kethal 01-09-07 09:53 PM

Re: 9746 alt-F[123456] doesn't work
 
I also had this problem. It seems that something of Nvidia's messed up my config file. Adding these lines to the keyboard section fixed the problem.

Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"

Without them it interprets the keystrokes as something other than ctr+alt+fn

Good luck,
Justin

codermotor 01-20-07 02:15 AM

Re: 9746 alt-F[123456] doesn't work
 
I've had the same problem with Fedora Core 6 and 9746 with a GeForce Go 6600 on my Asus Z71V laptop. 9631 works fine.

With 9746, starting from console and running "startx" brings up a working X. Switching to a console (<Alt><Ctrl><Fn>) causes a brief flash - as if the console came up for a few milliseconds - and then a black screen. I can switch back to console F7 and X is back.

The same thing happens when leaving X: flash, then black screen. As with the console switch, the CLI is still running. I can run "startx" again and X runs fine. No errors mentioned in either the X log, or in system log.

I guess I'll go back to 9631 till this is fixed.

derbuffer 01-20-07 08:14 AM

Re: 9746 alt-F[123456] doesn't work
 
Hi, I think this is a known problem with the nvidia/framebuffer and vga= kernelparameter. Have a look at:

http://www.nvnews.net/vbulletin/showthread.php?t=83900

http://www.nvnews.net/vbulletin/showthread.php?t=83335

http://www.nvnews.net/vbulletin/showthread.php?t=83858

Always the solution is to edit the vga= parameter into vga=normal (or deactive fb?).

Greetings

dorin.lazar 02-01-07 11:07 PM

Re: 9746 alt-F[123456] doesn't work
 
1 Attachment(s)
Hello, I have the same problem here.
When I try to switch to a console I am getting no signal on my monitor. Going back to X works without problems. The system does not hang, nor crash.
The distribution is FC6 with the latest updates, I use the kmod-nvidia packed by rpm.livna.org.


All times are GMT -5. The time now is 06:41 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.