nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   black screen when I startx (http://www.nvnews.net/vbulletin/showthread.php?t=83805)

chen23547 01-07-07 08:56 AM

black screen when I startx
 
1 Attachment(s)
My machine is Acer TravelMate 634xv, the graphic card is Geforece2 go. I have installed FreeBSD 6.2-RC2 in my laptop, then have nvidia driver installed from ports. I startx after configuring all the things, but the system showed a black screen. I found the system doesn't hang when the black screen showes, I can type 'exit' and back to console.

Below is my log file.

SirDice 01-08-07 07:10 PM

Re: black screen when I startx
 
It looks like a CRT is detected but it might not be the right one. Is there an external monitor attached? What's the HorizSync and VertRefresh set to in the Monitor section? Try removing those and let it use EDID. You problem sounds related to the HorizSync en VertRefresh frequencies.

You may also need to play a little with the ConnectedMonitor and/or UseDisplayDevice setting.

Yan can also try to setup the xorg nv driver first so you know the setup works, then move on to the nvidia driver.

Post your xorg.conf here too so we can take a look at it.

chen23547 01-20-07 07:06 AM

Re: black screen when I startx
 
Quote:

Originally Posted by SirDice
It looks like a CRT is detected but it might not be the right one. Is there an external monitor attached? What's the HorizSync and VertRefresh set to in the Monitor section? Try removing those and let it use EDID. You problem sounds related to the HorizSync en VertRefresh frequencies.

You may also need to play a little with the ConnectedMonitor and/or UseDisplayDevice setting.

Yan can also try to setup the xorg nv driver first so you know the setup works, then move on to the nvidia driver.

Post your xorg.conf here too so we can take a look at it.

Thanks for your reply.

Yes, I have an external VGA port and the monitor attached to it is displayed correctly. I have checked my xorg.conf file, the HorizSync and VertRefresh is ok. When blackscreen showes, I can make X displayed in the 'internal' LCD by press screen-switch button but no mouse cursor could be seen.


All times are GMT -5. The time now is 11:13 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.