nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVdriver module not loaded (http://www.nvnews.net/vbulletin/showthread.php?t=8399)

Digit0 03-07-03 08:15 PM

NVdriver module not loaded
 
Why??? Because its not there in the first place!!!
K a bit of specs first:

asus a7v333 xp1700+ GeForce 4 4200 (also asus)

Mandrake 9 (with whatever Kernel it brings by default) and the latest Nvidia drivers (4191)

nv_check gives this dump:

the NVdriver kernel module does not seem to be loaded. The 3D
drivers will not work without it...please compile it for your
kernel, set it up to insert the module on boot, then run
this script again.

So I started trouble shooting 2 see what on earth was going on. I has been 2 months now and I think I finally cracked it but have no clue how to fix it. I have tried installing from RPM, tarball and from source. With the same dump from nv_check I tried with the older drivers (the 3 something) and found in the tarball had the NVdriver and the modules. so I look @ the 4191 tarball and its not there. Uhmmm well maybe I'm supposed to build from source:


[root@localhost root]# modprobe NVdriver
modprobe: Can't locate module NVdriver
[root@localhost root]# cd Desktop/src
[root@localhost src]# rpm --rebuild N
NVIDIA_GLX-1.0-4191.src.rpm NVIDIA_kernel-1.0-4191.src.rpm
[root@localhost src]# rpm --rebuild NVIDIA_kernel-1.0-4191.src.rpm
Installing NVIDIA_kernel-1.0-4191.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.15983
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd /usr/src/RPM/BUILD
+ rm -rf NVIDIA_kernel-1.0-4191
+ /bin/gzip -dc /usr/src/RPM/SOURCES/NVIDIA_kernel-1.0-4191.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd NVIDIA_kernel-1.0-4191
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.15983
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd NVIDIA_kernel-1.0-4191
+ set +e
++ rpm -q --queryformat '%{VERSION}' rpm
+ RPMVERSION=4.0.4
++ awk -F . '{print $1;}'
++ echo 4.0.4
+ RPMMAJOR=4
++ echo 4.0.4
++ awk -F . '{print $2;}'
+ RPMMINOR=0
++ echo 4.0.4
++ awk -F . '{print $3;}'
+ RPMPATCH=4
+ '[' 4 -le 3 -a 0 -le 0 -a 4 -lt 4 ']'
+ make nvidia.o
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -1`\" > nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=4191 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -I. -I/lib/modules/2.4.19-16mdk/build/include -Wno-cast-qual nv.c
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=4191 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -I. -I/lib/modules/2.4.19-16mdk/build/include -Wno-cast-qual os-agp.c
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=4191 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -I. -I/lib/modules/2.4.19-16mdk/build/include -Wno-cast-qual os-interface.c
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=4191 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -I. -I/lib/modules/2.4.19-16mdk/build/include -Wno-cast-qual os-registry.c
ld -r -o nv-linux.o nv.o os-agp.o os-interface.o os-registry.o
ld -r -o nvidia.o nv-linux.o nv-kernel.o
size nvidia.o
text data bss dec hex filename
1248673 92760 32940 1374373 14f8a5 nvidia.o
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.79142
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd NVIDIA_kernel-1.0-4191
+ rm -f /tmp/files.lst
+ '[' -z '' ']'
++ uname -r
+ export TARGET_KERNEL=2.4.19-16mdk
+ TARGET_KERNEL=2.4.19-16mdk
+ '[' -d /lib/modules/2.4.19-16mdk/kernel ']'
+ INSTALLPATH=/lib/modules/2.4.19-16mdk/kernel/drivers/video
+ mkdir -p /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.19-16mdk/kernel/drivers/video
+ install -m 0444 nvidia.o /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.19-16mdk/kernel/drivers/video
+ echo '%attr(444 root root) ' /lib/modules/2.4.19-16mdk/kernel/drivers/video/nvidia.o
+ unset RPM_BUILD_ROOT
+ /usr/lib/rpm/brp-mandrake
no RPM_BUILD_ROOT variable; exiting.
Processing files: NVIDIA_kernel-1.0-4191
Finding Provides: (using /usr/lib/rpm/find-provides)...
Finding Requires: (using /usr/lib/rpm/find-requires)...
Using BuildRoot: /var/tmp/NVIDIA_kernel-1.0 to search libs
PreReq: /bin/sh /bin/sh /bin/sh rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Requires(interp): /bin/sh /bin/sh /bin/sh
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Requires(pre): /bin/sh
Requires(post): /bin/sh
Requires(preun): /bin/sh
Requires: kernel >= 2.2.0 rpm >= 3.0.4
Wrote: /usr/src/RPM/RPMS/i586/NVIDIA_kernel-1.0-4191.i586.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.20694
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd NVIDIA_kernel-1.0-4191
+ '[' -n /var/tmp/NVIDIA_kernel-1.0 -a /var/tmp/NVIDIA_kernel-1.0 '!=' / ']'
+ rm -rf /var/tmp/NVIDIA_kernel-1.0
+ exit 0
Executing(--clean): /bin/sh -e /var/tmp/rpm-tmp.20694
+ umask 022
+ cd /usr/src/RPM/BUILD
+ rm -rf NVIDIA_kernel-1.0-4191
+ exit 0

Aha!!!!! No reference whatsoever of make NVdriver.

Any ideas on how to make the bloody driver and modules so I can finally waste my time playing UT2k3????

Many thanks.

Hexdump 03-09-03 12:28 AM

I'm really disappointed with you. First you didn't read the README file, and second the answer is right there in the output you included in your message:
Quote:

+ install -m 0444 nvidia.o /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.19-16mdk/kernel/drivers/video
Third-party tools are great but they are no substitute for reading the documentation.

bwkaz 03-09-03 07:41 PM

In other words, nv_check does not understand driver 4191.

In 4191, the kernel module's name was changed to nvidia.o.


All times are GMT -5. The time now is 09:51 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.