nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SuSe 8.1 NVIDIA - INSTRUCTIONS (GF2 Bug fixed) (http://www.nvnews.net/vbulletin/showthread.php?t=8409)

MrBug 03-08-03 02:47 AM

SuSe 8.1 NVIDIA - INSTRUCTIONS (GF2 Bug fixed)
 
This is how you can install all nvidia drivers for all cards on Suse 8.1, and this is also the way to fix the gf2 bug.

1) Load suse Linux 8.1 in failsafe mode
2) Log in as "root"
3) Type in:
"rpm -e NVIDIA_GLX"
"rpm -e NVIDIA_kernel"
(This should deinstall old linux drivers)
4) Then install your new drivers:
"rpm -ivh NVIDIA_kernel-1.0-4191.suse81.i586.rpm"
"rpm -ivh NVIDIA_GLX-1.0-4191.suse81.i586.rpm"
(Number 4191 changes per version of the driver)
5) Restart
6) Start Linux again in failsafe mode
7) Log in as "root"
8) Type in "startx"
9) Go into Yast2, configure a little bit around with your display settings
10) reboot, start normal
11) Enjoy the wonderful TuxRacer grafics :D :D :D

Please add this on the top of this forum mods, because I think there are a lot of people with a geforce2. :)

E079561 03-09-03 12:46 PM

I can tell you from personal experience that this does not guarantee success. It maybe worked sometimes when using the original SuSE 8.1 kernel release; it doesn't work when after applying the newer 2.4.19-167 kernel released by SuSE to fix a whole bunch of bugs in the original kernel release.

See many other posts on this board to confirm it if you don't agree.

The problem with applying the newer kernel has to do with the disabling of AGP support. Insmod agpgart fails; and the the NVIDIA AGP will hand during X startup. To date, I have not seen a someone who has successfully resolved this problem using the newer kernel release; at least they have not posted a procedure to fix on this board.

I have given up trying to resolve this after weeks of fighting with it. I am using the XF86_GLX and MESA GLX for 3d acceleration with much better success than using NVIDIA's drivers.

wv6u 03-10-03 06:31 PM

This worked for me
 
I have SuSE 8.1 and I did an online update before I did this.

I had already done the rpm -i on the NVIDIA_kernel 4191 and it did not work.
I did the rpm -e on the NVIDIA_kernel and it told me that I could not do this as there was more then one package.
The trick then is to do an rpm -q NVIDIA_kernel
This will show you what else is there.
Mine had an old 0.8 level rpm. I removed it with the rpm -e and the newer 4149 started to work. I could not remove them both.

Now I have the eth0 nivida port working well. The 3D graphics working and if I su to root and do a modprobe nvaudio the sound works. Now I just have to figure out where to put the
"modprobe nvaudio" command so that it gets executed at the right time on boot.

E079561 03-11-03 12:01 AM

You can put 'modprobe nvaudio' in /etc/init.d/boot.local and it will load all the sound modules for alsa sound.

Doing an online update via YOU will not upgrade the original 2.4.19-4GB kernel that shipped with 8.1. You have to download that from the SuSE ftp site (or mirror site) and install via YAST or Kpackage or Gnorpm or via cmd line.

Like I said in my first post, the NVIDIA driver worked OK with the original 2.4.19-4 kernel. But that kernel release had a slew of other kernel bugs causing frequent freezes and crashes. If you haven't upgraded your kernel, you ought to consider it. There is even a 2.4.20 kernel out that you can download from ftp://ftp.suse.com/people/mantel/next if you want to.


All times are GMT -5. The time now is 11:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.