nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   While starting Xawtv, X crashes (http://www.nvnews.net/vbulletin/showthread.php?t=84303)

marchetto 01-15-07 06:44 AM

While starting Xawtv, X crashes
 
If I start latest CVS version of Xawtv, X crashes and asks me for a new login.

http://www.mail-archive.com/debian-x.../msg54562.html

I'm with a GEFORCE4 MX 440SE with latest legacy nvidia driver 9631

netllama 01-15-07 12:37 PM

Re: While starting Xawtv, X crashes
 
The mailing list post that you referenced appears to be discussing an unrelated problem with X server crashes when running any OpenGL application. In that thread, the NVIDIA driver is not correctly installed, as the GLX module is not the module that ships with the NVIDIA driver:
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(==) AIGLX enabled
(II) Loading extension GLX

If you're experiencing the same problem, then you need to fix your NVIDIA driver installation, and if the problem persists generate and attach an nvidia-bug-report.log.

Thanks,
Lonni

marchetto 01-16-07 04:29 AM

Re: While starting Xawtv, X crashes
 
1 Attachment(s)
That link was about the X crash with xawtv... but I don't know if it's the same problem...
It's quite strange.
I even tried compiling again the xawtv code, but it crash the same.

Kde tv works so I don't think it's a TV tuner card troubleshooting (I don't want to use kdetv it's really slow and huge)

I don't know how to log the error, because even if I start from Konsole I cannot see the error... here's my nvidia-bug-report.log

netllama 01-16-07 11:29 AM

Re: While starting Xawtv, X crashes
 
You've not corrected your broken NVIDIA driver installation. You need to reinstall the NVIDIA driver.

marchetto 01-16-07 11:47 AM

Re: While starting Xawtv, X crashes
 
Oooookei....

I found the way, here's a piece of my /etc/X11/xorg.conf:

Code:

Section "Module"
    Load          "freetype"
    Load          "dbe"
    Load          "type1"
    Load          "v4l"
#    Load          "glx"
    Load          "extmod"
EndSection


netllama 01-16-07 11:59 AM

Re: While starting Xawtv, X crashes
 
That isn't fixing the problem, its just commenting out the GLX module, which isn't correctly installed. You need to (re)install the NVIDIA driver to fix this problem.

marchetto 01-16-07 04:46 PM

Re: While starting Xawtv, X crashes
 
Ok you're right, now I've reinstalled nvidia driver, but the problem was here:

Code:

l
totale 902
drwxr-xr-x  2 root root    280 16 gen 23:34 ./
drwxr-xr-x 10 root root    984 16 gen 23:18 ../
-rwxr-xr-x  1 root root  18248  9 gen 18:27 libdbe.so*
-rwxr-xr-x  1 root root  30712  9 gen 18:27 libdri.so*
-rwxr-xr-x  1 root root 126672  9 gen 18:27 libextmod.so*
lrwxrwxrwx  1 root root    18 16 gen 23:34 libglx.so -> libglx.so.1.0.9631*
-rwxr-xr-x  1 root root 675436 16 gen 23:34 libglx.so.1.0.9631*
-rwxr-xr-x  1 root root  26476  9 gen 18:27 librecord.so*
-rwxr-xr-x  1 root root  32928  9 gen 18:27 libxtrap.so*

You (driver nvidia) make a little bit confusion between your libglx.so and the xorg-x11-server one....

Anyway the solution I found, I deleted the old libglx, I reinstalled the driver and now is like you can see over.

THANKS :D


All times are GMT -5. The time now is 06:14 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.