nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   MultiGPU Option with two 7950 GX2's (http://www.nvnews.net/vbulletin/showthread.php?t=84495)

JaguarIV 01-17-07 03:47 PM

MultiGPU Option with two 7950 GX2's
 
Hi all,

I have a new Dell XPS 700 with 2 GeForce 7950 GX2 cards in it. I was planning to run with the following configuration:
24" flat panel connected to the primary video card running in MultiGPU mode
19" flat panel connected to the secondary video card using one GPU
19" flat panel connected to the secondary video card using the other GPU

The problem I am having is that the Nvidia driver complains that it is not able to use MultiGPU and that I should use SLI instead (which is not what I want). If I remove the second video card, then the first works fine in MultiGPU mode.

So the question. Is what I am wanting to do technically possible? Do I need to do something to trick the X server into treating the two cards as distinct entities and ignore any possible SLI capabilities?

If this setup is technically possible, then I will post log outputs and such to help in debugging.

Thanks in advance.

Jason

netllama 01-17-07 03:58 PM

Re: MultiGPU Option with two 7950 GX2's
 
The MultiGPU X option has the same limitations as the SLI option, namely a single display device. If you wish to use more than 1 display device, then you'll need to configure X for separate X screens and/or Twinview and/or Xinerama.

Thanks,
Lonni

JaguarIV 01-17-07 04:05 PM

Re: MultiGPU Option with two 7950 GX2's
 
The primary video card, for which I specify the MultiGPU option, has only a single display connected. The two other displays are connected to the secondary card which has the MultiGPU option disabled. In fact, if I remove the entries for the two secondary displays from the xorg.conf file, leaving only the display on the primary card in MultiGPU mode, it still doesn't work. Only if I physically remove the secondary card from the machine does this setup work.

netllama 01-17-07 06:06 PM

Re: MultiGPU Option with two 7950 GX2's
 
You cannot currently run MultiGPU/SLI mixed with non-MultiGPU/SLI. If that information doesn't allow you to resolve this problem, then please generate and attach an nvidia-bug-report.log.

Thanks,
Lonni

JaguarIV 01-17-07 07:25 PM

Re: MultiGPU Option with two 7950 GX2's
 
That is exactly the information I was looking for. Thanks.

Is this capability something that will eventually become available? Or are there technical reasons that prevent running a mixed-mode video card setup?

netllama 01-17-07 08:32 PM

Re: MultiGPU Option with two 7950 GX2's
 
It will be possible at some point in the future.

JaguarIV 01-18-07 12:31 PM

Re: MultiGPU Option with two 7950 GX2's
 
Ok. So let me clarify one last thing. The MultiGPU option cannot be used at ALL if you have more than one video card? In other words, you can't have two, dual-GPU cards with each one running in MultiGPU mode. Correct?

Thanks again for the help.

netllama 01-18-07 12:35 PM

Re: MultiGPU Option with two 7950 GX2's
 
That is correct.


All times are GMT -5. The time now is 04:08 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.