nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Sending output to a TV (http://www.nvnews.net/vbulletin/showthread.php?t=84575)

JCA 01-18-07 03:29 PM

Sending output to a TV
 
I have a GeForce FX 5200 on my Slackware 11.0 Linux box, running a 2.6.19.1 kernel under a Pentium IV processor. I am using the recently released 9746 Nvidia drivers on this board.

I have connected this FX 5200 card to my NTCS TV set by means of an S-Video cable. With this, and the xorg.conf file that I am appending to the end of these lines, I can use my TV as a monitor all right.

The thing is, when I play video material (with mplayer or any other application) on full screen, the material does not play like an ordinary TV broadcast, which really takes up the whole of the screen.

Rather, it is played in a section that encompasses most of the actual TV screen, but one can see black borders - four of them. Less easy to ignore is the fact that sometimes I get bright blue edge on the left, and occasionally on the top as well.

Is there anything I can change in my xorg.conf file to eliminate the effects above?

Thanks.

--------------------------------------------------------------------------

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Fri Dec 15 10:12:14 PST 2006

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/misc/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "True"
Option "TwinViewOrientation" "Clone"
Option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
SubSection "Display"
Depth 24
Modes "800x600" "720x480" "640x480"
EndSubSection
EndSection

PenGun 01-18-07 05:51 PM

Re: Sending output to a TV
 
You need to read the TVOut section of the docs.

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "UseEDID" "FALSE"
Option "TVStandard" "HD1080i"
Option "ConnectedMonitor" "TV"
Option "TvOutFormat" "Component"
Option "metamodes" "CRT: 1920x1080 +0+0"
SubSection "Display"
Depth 24
Modes "1920x1080i60"
EndSubSection

This is my relevent section, you'll need to change a few things.


All times are GMT -5. The time now is 04:03 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.