nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Xen Support for NVidia 9746 (http://www.nvnews.net/vbulletin/showthread.php?t=85037)

baco 01-25-07 07:07 PM

Xen Support for NVidia 9746
 
1 Attachment(s)
Hi,

I have included a contrib patch for adding Xen support
to NVidia driver for Linux release 9746.

With this patch you can run Xorg under a Linux with
CONFIG_XEN enable and the NVidia driver module.

I hope you will officially support Xen in the futur
but until you decide It can be great for Linux users
community to add this patch in a contrib directory
inside your distribution package.

Best Regards,
Guy

--

Infomaniak Network SA
Guy Baconniere <baco ~at~ infomaniak.ch>
Unix System Administrator
Certified Linux Engineer (RHCE, LPIC-2)
Avenue de la Praille 26
1227 Carouge (Geneva)
Switzerland (CH)

baco 01-26-07 08:40 AM

Re: Xen Support for NVidia 9746
 
Instructions for compilation

wget http://us.download.nvidia.com/XFree8...-9746-pkg1.run
sh NVIDIA-Linux-x86-1.0-9746-pkg1.run -x
cd NVIDIA-Linux-x86-1.0-9746-pkg1
/usr/src/nv zcat ../../../../NVIDIA_xen-9746.patch.gz | patch -p4
make SYSSRC=/usr/src/linux module
install -D -o root -g root -m 0644 nvidia.ko /lib/modules/$(uname -r)/video/nvidia.ko
depmod -a
modprobe nvidia

Enjoy

superzerg 01-27-07 05:38 PM

Re: Xen Support for NVidia 9746
 
3 Attachment(s)
I have tried to make this driver works for 2 days on an AMD 64 x2 (AM2) with linux-2.6.16.33-xen (SMP x86_64) and finally succed :D but there is something wrong :( : the resolution is blocked at 800x600 when I use this driver but just restoring nv driver in xorg.conf I can go to 1200x786. I tried to use the nvidia-xconfig command or dprkg -phigh xserveur-xorg but nothing make a difference.
I attach some log file.

(Thanks for this patch)

Ravenik 02-17-07 08:16 PM

Re: Xen Support for NVidia 9746
 
I have succeded with this patch. No problems with screen resolution.
However i had to modify usr/src/nv/os-interface.c line 1288 modified to:
#if 0
Otherwise there was compilation error with consecutive lines.
Suse 10.2 64-bit.

Regards,
Mark

masv 02-26-07 07:36 AM

Re: Xen Support for NVidia 9746
 
I can't get this to work, perhaps it's just some silly mistake on my part, anyhow: Everything runs smoothly untill the "modprobe nvidia" where I get this
Code:

FATAL: Error inserting nvidia (/lib/modules/2.6.16.26-xendom0/kernel/drivers/video/nvidia.ko): Unknown symbol in module, or unknown parameter (see dmesg)
and dmesg | tail returns:
Code:

evbug.c: Event. Dev: isa0060/serio0/input0, Type: 0, Code: 0, Value: 0
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 4, Code: 4, Value: 38
...


meyerdtd 02-26-07 03:53 PM

Re: Xen Support for NVidia 9746
 
Similarly, I have no problems until "modprobe nvidia", at which point:

Code:

FATAL: Error inserting nvidia (/lib/modules/2.6.18-xen/video/nvidia.ko): Unknown symbol in module, or unknown parameter (see dmesg)
And dmesg gives me the following:

Code:

nvidia: module license 'NVIDIA' taints kernel.
nvidia: unknown symbol raw_local_irq_restore
nvidia: unknown symbol __raw_local_save_flags
nvidia: unknown symbol raw_local_irq_disable
nvidia: unknown symbol init_level4_pgt
nvidia: unknown symbol raw_local_irq_enable

Does anyone have any pointers as to what I might be doing incorrectly?

netllama 02-26-07 03:58 PM

Re: Xen Support for NVidia 9746
 
Xen is currently not supported with the nvidia driver.

meyerdtd 02-26-07 04:18 PM

Re: Xen Support for NVidia 9746
 
Quote:

Originally Posted by netllama
Xen is currently not supported with the nvidia driver.

Understood, unfortunately I don't have another option - Hopefully someone here has some experience using the above patch to get the nvidia driver working with Xen.

(PS - Nvidia, please support Xen)

enigmaedge 05-17-07 02:12 PM

Re: Xen Support for NVidia 9746
 
Thanks for the patch and instructions! Everything seems to have compiled fine and I am able to modprobe the driver.

Now I'm stuck in actually getting use out of it. After I modprobed the driver, I made the changes to my xorg.conf file (disabled dri, enabled glx, and added Driver "nvidia") and proceeded to execute startx I get the error:
Quote:

(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available
How have you succeeded in running X?

Thanks in advance!

MajinBlayze 07-12-07 12:28 PM

Re: Xen Support for NVidia 9746
 
two questions:
1) does this go into the domU or dom0?
2) will this work (any time in the future) with HVM's?


All times are GMT -5. The time now is 03:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.