nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Feisty Fawn and kernel 2.6.20-6 (http://www.nvnews.net/vbulletin/showthread.php?t=85409)

plun 01-31-07 04:25 PM

Feisty Fawn and kernel 2.6.20-6
 
Running Ubuntu Feisty Fawn and nVidia driver 9746.

Today Feisty was updated from -5 > -6 kernel. Probably using the RC6 kernel

After this its impossible to build a new kernel module
during setup.

It gives this error:
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'para virt_ops'

A major upstream challenge perhaps ?

TPG 01-31-07 04:50 PM

Re: Feisty Fawn and kernel 2.6.20-6
 
Please use seach feature of this forum.

This is what you are looking for:

http://www.nvnews.net/vbulletin/show...L-incompatible

plun 01-31-07 05:06 PM

Re: Feisty Fawn and kernel 2.6.20-6
 
Well, thanks...

My knowledge about kernels is nearly zero so maybe someone
from nVidia could maybe tell us about new beta drivers for new kernels .

Its no problem for me beacuse I took a step back to the -5 kernel.

Nevertheless this is irritating beacuse of kernel symbols and lack of compability.

zander 01-31-07 05:54 PM

Re: Feisty Fawn and kernel 2.6.20-6
 
The NVIDIA Linux kernel module doesn't reference the GPL symbols in question explicitely, they're picked up implicitely. It looks like paravirt_ops is picked up via udelay().

plun 01-31-07 06:06 PM

Re: Feisty Fawn and kernel 2.6.20-6
 
Quote:

Originally Posted by zander
The NVIDIA Linux kernel module doesn't reference the GPL symbols in question explicitely, they're picked up implicitely. It looks like paravirt_ops is picked up via udelay().

Yup... I am just a "user" not a developer, this is heavily discussed
within Feistys forum. I started a "fire"...

I just want a driver to work, others can discuss upstream challenges as licenses, GPL and coordination between major players such as nVidia.

Thanks anyway :)

zander 01-31-07 06:21 PM

Re: Feisty Fawn and kernel 2.6.20-6
 
The CONFIG_PARAVIRT configuration option is experimental and as such not supported; I recommend that you fall back to a stable kernel.

plun 01-31-07 07:08 PM

Re: Feisty Fawn and kernel 2.6.20-6
 
Quote:

Originally Posted by zander
The CONFIG_PARAVIRT configuration option is experimental and as such not supported; I recommend that you fall back to a stable kernel.

Well, Ubuntu devs solved it with a new patched kernel update release.

Installed ver 9746 again with only minor protests from setup. :)

Great ! (maybe easier to run with open source :cool: )

I am glad that I have an nVidia card.


All times are GMT -5. The time now is 10:20 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.