nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   No sync in console mode upon vt-switch (http://www.nvnews.net/vbulletin/showthread.php?t=85616)

FNX 02-03-07 03:09 AM

No sync in console mode upon vt-switch
 
1 Attachment(s)
A couple of days ago I replaced my Geforce 5200 based AGP card with a 6200 based one in my FC6 system. I made no other alterations, but now when I boot, although X does start & run fine with the nvidia driver, if I vt-switch (<Ctrl+Alt+Fn>) back to a console mode my monitor (Iiyama Vision Master Pro 454) reports no sync.

I *can* log in and do stuff, I just can't see it. I can also switch back to X on vt7 OK. I'll attach the bug report log as requested; it shows I use a vga= and a video= in my kernel boot, but I've tried without these, and also with a 'vga=normal' which was suggested in this forum 2-3 years ago, but to no avail.

Oh yes, and although I'm set up for running Beryl, I don't run it by default, so it's not that.

Any ideas what to try next?

netllama 02-03-07 09:54 AM

Re: No sync in console mode upon vt-switch
 
Are you stating that this problem persists even if you boot without all of these options?
vga=0x0F01 video=vesa:ywrap quiet

FNX 02-03-07 01:12 PM

Re: No sync in console mode upon vt-switch
 
That's right, I've tried with both those options (which is what I started with), with just the vga one, with just the video one, with neither, and with 'vga=normal'. None of these combinations fixes the issue.

And again, all I changed was the card itself (5200 to 6200), no other changes; it was OK with the old card (but that was starting to play up, hence the newer one).

netllama 02-04-07 10:22 AM

Re: No sync in console mode upon vt-switch
 
I'm not able to reproduce this problem with a GeForce 6200 in FC6, which suggests that this problem is specific to your environment. Have you verified that you're using the latest motherboard BIOS?

majormeatbone 02-04-07 12:09 PM

Re: No sync in console mode upon vt-switch
 
1 Attachment(s)
I have a similar problem. I had a GeForce 2MX, evetything worked fine, upgraded to a GeForce 6200 X works fine, console does not.
From lspci:
01:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1)

When i switch from vt7 to vt1, all i get are some green, red and yellow boxes on random places on the screen.
I to can login and do stuff, but cant se them. vt7 works fine when switching back. (Same thing for the tv-out)

Running nvidia 1.0.9631-1 On Arch linux 0.8.

It has to be the nvidia driver that causes this, because the "nv" driver does not.

jak 02-04-07 01:07 PM

Re: No sync in console mode upon vt-switch
 
I also have a very similar problem.

I have nForce 430, GeForce 6150 (not sure if that is redundant?); my monitor is a 23 inch Apple cinema display.

I had an older monitor that I replaced yesterday with the ACD; I installed the latest nvidia linux amd64 bit driver successfully and my old monitor worked fine. In the process I set the runlevel to 3;

Thinking it was the safest thing to do, I booted up with the ACD at runlevel 3 but I got the "blank" screen of death right from the start. No setup/bios console stuff just "blank";

I searched the internet for hours trying to find similar experiences and there were a few but there were no solutions. What I didn't realize is that my setup would not work in "text/console" mode (runlevel 3).

Based upon a hunch from reading some posts, I again booted into runlevel 3 with the ACD.

I gave sufficient time for the boot to come to the login prompt.

Then I carefully logged into to the root account (remember I have a "blank" screen).

Hoping that I successfully logged in, I issued the command to change the runlevel to 5 and start X which for me is:

#telinit 5 // carefully typing this so that I made no mistakes cuz I couldn't see anything

and bam: X started just fine!

When in X, I was able to edit xorg.conf and set things up correctly for the ACD. I also set the runlevel to 5 for boot and rebooted successfully launching the x-server. But the screen is completely blank until the Xserver is started by init.

I cannot visit the console mode / bios setup stuff at all which is a major issue.

Is there a fix for this? I am using the absolutely latest bios.

jak 02-04-07 02:01 PM

Re: No sync in console mode upon vt-switch
 
Details and Correction relevant to my post above:

Motherboard: m2npv-vm: GeForce 6150, nForce 430MCP
Correction: I'm using bios 0603 which is not quite the latest -- at this point its difficult to upgrade since I have a blank screen.

My driver is:
Version: 1.0-9746
Operating System: Linux x64 (AMD64/EM64T)
Release Date: December 21, 2006


All times are GMT -5. The time now is 08:07 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.