nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Unable to perform runtime configuration check for library libGL.so.1 (http://www.nvnews.net/vbulletin/showthread.php?t=86185)

Kayo Dot 02-12-07 02:11 PM

Unable to perform runtime configuration check for library libGL.so.1
 
I'm running Ubuntu Edgy 64 on my Laptop. I'm trying to fix a problem with the lag I've been experiencing with Beryl, and problems experienced when using XGL.

I have tried installing the graphics card drivers for my nVIDIA GeForce Go 7600 (256mb memory) both with Envy, and also using the drivers from the nVIDIA website. However, both methods return the following error:

'unable to perform runtime configuration check for library libGL.so.1.0-9746'.

Thus, there is no /usr/lib64/nvidia/libGL.so.1 file, as one would expect.

Does anyone have any advice? I have followed all guides I have found but to no avail.

netllama 02-12-07 02:18 PM

Re: Unable to perform runtime configuration check for library libGL.so.1
 
Please attach the installer log that includes this failure.

Thanks,
Lonni

Kayo Dot 02-12-07 02:52 PM

Re: Unable to perform runtime configuration check for library libGL.so.1
 
1 Attachment(s)
It's right towards the bottom. It seems to me that it's trying to find the lib32 folder, when in fact I'm using the x64 version, so it should be aiming at the lib64 folder.

This is definitely the x64 driver I have downloaded, so I don't know what to do :/.

netllama 02-12-07 03:00 PM

Re: Unable to perform runtime configuration check for library libGL.so.1
 
According to the log you've attached, the driver is successfully installed. Are you experiencing a problem?

Kayo Dot 02-12-07 03:07 PM

Re: Unable to perform runtime configuration check for library libGL.so.1
 
I am unable to run Beryl with XGL. An apparent fix for this is to use the command LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1.beryl-manager.

Due to the error during installation regarding the file libGL.so.1, I am unable to run this command, thus I can not use XGL acceleration.

netllama 02-12-07 03:15 PM

Re: Unable to perform runtime configuration check for library libGL.so.1
 
The warning in your installer log doesn't seem to be related to the beryl problem you've reported. What you are describing sounds like a beryl bug, not an nvidia driver bug. Also, beryl doesn't require XGL.


All times are GMT -5. The time now is 12:58 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.