nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   9746 BUG: No user defined clip planes (http://www.nvnews.net/vbulletin/showthread.php?t=86535)

Teknoenie 02-16-07 07:27 PM

9746 BUG: No user defined clip planes
 
After switching from 9631 to 9746, I have noticed that user defined clipping planes in openGL (not the view frustum clip planes) do not work any more. I have tested this on machines with 6800 Ultras, Quadro FX 3450s, and 8800GTXs. It is always the same result, and it always goes away when we revert the drivers to 9631 (except the 8800 obviously doesn't work with 9631). Turning off the clipping planes in my code gives me the exact same artifacts, so I am 99.99% sure this is the problem.

All of the machines we tested this on were running Suse 9 or 10, with 32-bit Xeons and 64-bit Opterons.

netllama 02-16-07 08:47 PM

Re: 9746 BUG: No user defined clip planes
 
Please provide a test app which reproduces this problem along with an nvidia-bug-report.log.

Thanks,
Lonni

Teknoenie 02-20-07 03:49 PM

Re: 9746 BUG: No user defined clip planes
 
1 Attachment(s)
The clipping planes still work with the fixed function vertex pipeline, but when I use my own vertex shader they no longer work. The clipping planes used to work (with older drivers) when I used my own vertex shader, as long as I wrote to gl_ClipVertex in GLSL.

I have attatched some code which reproduces the error. It is a simple volume rendering program that renders a procedurally generated dataset with a single sphere in the center. The volume rendering is done by applying a 3D texture to view aligned slices. The slices are as tall and wide as the longest diagonal of the volume, and then user defined clipping planes are used to clip the slices down to the size of the volume. The texture wrap mode is set to repeat so that you can see if the slices are being clipped correctly. If the slices are clipped correctly, you should see a single sphere in the center. If the slices are not clipped, you should see several partial spheres surrounding the center one (from the texture wrapping).

With the 9631 and earlier drivers, the attatched code works correctly, with the 9746 drivers it does not.

netllama 02-20-07 04:15 PM

Re: 9746 BUG: No user defined clip planes
 
Thanks. I've replicated the problem with 1.0-9746, however this should be fixed in the next driver release.

Thanks,
Lonni

Teknoenie 03-13-07 01:55 PM

Re: 9746 BUG: No user defined clip planes
 
This has not been fixed in the 9755 driver release.

netllama 03-13-07 02:03 PM

Re: 9746 BUG: No user defined clip planes
 
I'm not able to reproduce this in 1.0-9755. As you've not provided a bug report, I can't compare your environment to mine.

Teknoenie 03-13-07 02:17 PM

Re: 9746 BUG: No user defined clip planes
 
Sorry, the bug was on my end this time. This problem appears to be fixed for the 9755 drivers.


All times are GMT -5. The time now is 07:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.