nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   7600GT won't do 1440x900 with AL1916W? (http://www.nvnews.net/vbulletin/showthread.php?t=86579)

fluffyelmo 02-17-07 05:39 PM

7600GT won't do 1440x900 with AL1916W?
 
2 Attachment(s)
I just got an Acer AL1916W 19" wide-screen monitor with a native resolution of 1440x900 though it is reported as 1400x1050. In a dual-head configuration it runs at 1400x1050, as the sole monitor it runs at 1280x1024. These are the only resolutions I have been able to get after hours of attempts and many different xorg.conf files. The resolutions are confirmed by both the Nvidia settings utility and the monitor OSD.

I'm running 32bit Ubuntu Edgy with driver version 9746 and I have a BFG 7600GT with 128MB of RAM. My current xorg.conf and Xorg.0.log file are attached, though I've tried many others. The driver seems to be rejecting 1440x900 as a valid mode with either explicit modelines or just a mode of 1440x900 specified. The line in the log is:
Code:

(WW) NVIDIA(0): No valid modes for "1440x900_60.00"; removing.
Any help greatly appreciated as this is getting very frustrating...

reet 02-17-07 06:33 PM

Re: 7600GT won't do 1440x900 with AL1916W?
 
Remove Option "UseEDID" "FALSE" and try again. Xorg will then list the EDID information in Xorg.0.log so you can look at what modes are available. Also, when Xorg is running, using the xrandr command with no options will give a list of available resolutions.

runlinux 03-05-07 08:59 AM

Re: 7600GT won't do 1440x900 with AL1916W?
 
i had the same issue (same monitor) and it was fixed with these two lines:

you dont need modelines at all to get this working. remove those and under the screen section, just put in "1400x900" under the 24 bit section and you should be ok.

add them under the device section of the xorg.conf

Option "ExactModeTimingsDVI"
Option "ModeValidation" "NoDFPNativeResolutionCheck"

fluffyelmo 03-05-07 09:19 AM

Re: 7600GT won't do 1440x900 with AL1916W?
 
Perfect, that worked. Thanks!

I discovered that it worked with VGA but not DVI so I pretty much left good enough alone. I'm very happy to have DVI working though...thanks again.

guwrt 04-10-07 10:25 AM

Re: 7600GT won't do 1440x900 with AL1916W?
 
Hello,

What is this option for?

Option "ModeValidation" "NoDFPNativeResolutionCheck"

Thanks

Guwrt

fluffyelmo 04-10-07 10:32 AM

Re: 7600GT won't do 1440x900 with AL1916W?
 
It stops the driver from asking the monitor what it's native resolution is. In my case, without this option, the monitor reports incorrect information and the driver then changes it's settings to accommodate what the monitor reports.

EDIT: Added 'without this option' to clarify...

guwrt 04-10-07 10:49 AM

Re: 7600GT won't do 1440x900 with AL1916W?
 
Thanks for reply.

Is it better to include this option in my Xorg.conf file? Because I dont see this option in my Xorg.

Check my new post (couple of minutes ago)

http://www.nvnews.net/vbulletin/show...53#post1221953

Thanks for your support

Guwrt

fluffyelmo 04-10-07 10:54 AM

Re: 7600GT won't do 1440x900 with AL1916W?
 
I don't see how it would hurt to try it. I have the two lines in my 'Device' section of xorg.conf. You may also want to try using the VGA connector to see if the problem goes away. If it does then it's probably one of the options that query the monitor you have to disable.

guwrt 04-10-07 11:13 AM

Re: 7600GT won't do 1440x900 with AL1916W?
 
Ok. On my model, I dont have the DVI port. There is only a VGA port.

Do I have to include this line Option "ExactModeTimingsDVI" in my case?

I will try the other option to see the effect on the rez.

Thanks again for your help

Guwrt

netllama 04-10-07 12:26 PM

Re: 7600GT won't do 1440x900 with AL1916W?
 
All supported NVIDIA specific driver options are documented in the driver README.

If someone needs further assistance with a mode validation issue, please start X with the following command:
startx -- -logverbose 6

and then generate and attach an nvidia-bug-report.log.

thanks,
Lonni

guwrt 04-10-07 10:03 PM

Re: 7600GT won't do 1440x900 with AL1916W?
 
ok for generating a report but I am not quite familiar with this.

How do I have to start X and how I get this bug report?

Thank for support

Guwrt

zander 04-10-07 10:27 PM

Re: 7600GT won't do 1440x900 with AL1916W?
 
Please see: http://www.nvnews.net/vbulletin/showthread.php?t=46678.


All times are GMT -5. The time now is 10:07 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.