nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Modular X + nVidia = crashes (http://www.nvnews.net/vbulletin/showthread.php?t=86755)

orben 02-20-07 12:04 PM

Modular X + nVidia = crashes
 
Hi,


Last week I switched to modular Xorg (I had 7.1 already though) on Gentoo. I uninstalled my complete X, edited my make.conf to
VIDEO_CARDS="nv nvidia vesa" and INPUT_DEVICES="mouse keyboard" and reinstalled xorg.

Everything works fine with the nv and vesa driver, but not with the nvidia driver. X is starting, but whenever I switch to a console (ctrl+alt+f#) my comp freezes completely. I also have this problem when I logoff (yet again a switch to a console) and when I try glxinfo in a terminal.

I tried version 8776 and 9746, makes no difference.

Some errors I get during the boot of X:
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) Loading extension MIT-SCREEN-SAVER
(EE) Error loading keymap /var/tmp/server-0.xkm


Help needed pls, getting tired of these hard shutdowns :(

Thank you

netllama 02-20-07 12:36 PM

Re: Modular X + nVidia = crashes
 
http://www.nvnews.net/vbulletin/showthread.php?t=58498

orben 02-20-07 12:46 PM

Re: Modular X + nVidia = crashes
 
None of the proposed solutions are appriopriate to my situation since I got a newer video driver and kernel.
Besides: everything worked perfectly with the complete 7.1 install. Could it be that the re-install skipped some required package?

Oh my cpu and vidcard are:

AMD athlon64 X2 3800+
Asus geforce 7600gt

orben 02-20-07 02:37 PM

Re: Modular X + nVidia = crashes
 
After some further testing:

vga=normal and acpi=off on the command line don't help. Disabling GLX doesnt either.

I also tried the driver from the nvidia website (instead of portage). It gave ma logo once, but didnt help the switch to console issue. Still only my wallpaper was visible but the desktop environment was gone -> freeze.

netllama 02-20-07 03:15 PM

Re: Modular X + nVidia = crashes
 
You've not followed all of the instructions in the sticky post I referenced. If you want further assistance, please post a bug report.

Thanks,
Lonni

orben 02-20-07 11:46 PM

Re: Modular X + nVidia = crashes
 
After hours of trying, it is fixed.

I tried to compile a 2.16.20 kernel, only thing in the config I changed was "Support for video mode selection". Now I cant specify vga= on the bootline but I didnt use that anyways :)

Then I unmerged the portage nvidia driver and installed the one from the site. Dont ask me what of the 3 changes fixed it, but I don't care to be honest: glad this misery is over :)


All times are GMT -5. The time now is 11:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.