nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   3D accel only works over VGA, not DVI (7800GS) (http://www.nvnews.net/vbulletin/showthread.php?t=86774)

usr/thomas 02-20-07 06:58 PM

3D accel only works over VGA, not DVI (7800GS)
 
Hi, new user here, first post. Kind of new-ish to Linux, too.

I'm using PCLinuxOS2007TR1/TR2 and had a real bugger of a time getting 3D accel working. I pored over all the various instruction threads on their forums regarding installing/setting up the proprietary nvidia drivers (from the pkg in their repository). I could get the drivers installed, as evidenced by the additional options then available in the nvidia-config applet.

Problem is, when I rebooted, half-way thru the boot the screen would go blank and display a "no input signal - going to sleep" message. (I'd get this same result when hitting the "Test" button before actually rebooting, too.)

Then came my Eureka moment. I was thinking about the line nVidia says needs to be added to the screen section of the xorg.conf file (Option "AddARGBGLXVisuals" "True") when it struck me - ARGB means analog RBG (VGA cable).

Sure enough, when I switched out the DVI cable for a VGA, everything worked fine - I got the nVidia splash screen (finally! yea!), the OpenGL screen savers ran at the right speed and I even got to play around with Beryl for a bit. But ... now I have a new dilemma.

I'm running this on a dual-boot with w2k. I use my PC primarily for gaming and watching DVDs and specifically upgraded to a monitor with DVI (Xerox 19" widescreen, 1 DVI, 2 VGA inputs) to take full advantage of my 7800GS.

I thought, no prolem, I'll just hook the DVI cable back up (I discovered during the install that I had to completely remove the DVI cable to get the install to work, but could reconnect the DVI afterwards along with the VGA) and tell the monitor to use the DVI input when I boot into Windows. But this doesn't work - with both cables hooked up, the monitor refuses to accept the DVI and only accepts the VGA signal. (I'm thinking these multiple inputs on the monitor are for running multiple PCs to it, not multiple cables off the same vid card on 1 PC to it.)

Now, the PCLinuxOS is running off an external USB HD and iirc I even tried disconnecting that so the PC would boot directly to Windows but got the same result.

So, for now, it's back to the DVI cable and the 2D generic nv driver for pclos (which works fine btw and I think was what was throwing me off during the "why won't it work" as I tear my hair out phase lol) while I investigate this a little further.

Nowhere in any of these various instructions did I see any mention/warning that 3D only works over a VGA connection and I'm wondering if this is just how it works or is there maybe something in *my* setup that allows it to only work this way? Does anyone have 3D working over DVI and, if so, can offer me some pointers?

Here's a run-down of my system:

AMD Athlon XP 2800+
Soltek SL-75FRN2-RL nForce2 Ultra 400 mobo
768MB DDR RAM running @ 333mHz
PNY 7800GS AGP with DVI/VGA/S-video out
120MB WD HDD @7200rpm
Plextor single-layer DVD burner
On-board audio
On-board 100MB ethernet
Netgear WAG511 wireless abg adaptor
w2kpro SP4

PCLinuxOS in running on a Simpletech 40GB external USB HDD
grub in on the external HD

Now, I do have a little Shuttle SFF box running winXP that has an EVGA e-GeForce 6200 ACP hooked to an analog-only LCD that I *could* run the pclos on but this w2k box is my main rig so it's a bit more convenient to have it hooked to this one.

Any advice/suggestions would be greatly appreciated. Thanks.

netllama 02-20-07 07:04 PM

Re: 3D accel only works over VGA, not DVI (7800GS)
 
Per the driver README, the AddARGBGLXVisuals option adds a 32-bit ARGB visual for each supported OpenGL configuration. It has nothing to do with the type of display device that is in use.

While this problem is present, please post the output from glxinfo and generate & attach an nvidia-bug-report.log.

Thanks,
Lonni

usr/thomas 02-21-07 05:51 PM

Re: 3D accel only works over VGA, not DVI (7800GS)
 
2 Attachment(s)
thanks for the quick reply. okies, being new-ish to Linux, I've had some trouble finding some of this stuff, but have done what I could, hope it's enough. btw, finally found glxinfo but it's an executable - when I dbl-click on it nothing seems to happen; if it's producing some output somewhere, I can't find it.

I've attached 3 sections of logs and 2 bug reports:

some things I've noticed in particular

the .old bug is before I told it to load the proprietary drive, the other one is after. when I hit the "test" button after loading the prop driver (still b4 rebooting, tho), I don't get the black screen / "no input" message, I get the error mesage shown in the report:

an error occurred
(EE) failed to load /usr/lib/xorg/modules/extensions/nvidia/libglx.so
(EE) failed to load module /usr/lib/xorg/modules/extensions/nvidia/libglx.so
try to change some parameters

now, I've looked to where this is pointing and the libglx.so *is* there

another thing I noticed is that the kdm.log says "(EE) AIGLX: DRI module not loaded" while the other 2 logs show that AIGLX *is* loaded

and the other 2 logs are showing this:

Feb 21 13:51:46 localhost kernel: 0000:00:02.0 OHCI: BIOS handoff failed (BIOS bug ?) 00000784
Feb 21 13:51:46 localhost kernel: Console: switching to colour frame buffer device 93x31
Feb 21 13:51:46 localhost kernel: RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
Feb 21 13:51:46 localhost kernel: NFORCE2: BIOS didn't set cable bits correctly. Enabling workaround.

hope this helps but let me know if more info is needed, thanks much

usr/thomas 02-21-07 05:57 PM

Re: 3D accel only works over VGA, not DVI (7800GS)
 
1 Attachment(s)
oops, seem to have lost some of the attachments, here they are

actually, it's telling me that some of these files I'm trying to attach are "invalid" but here's 1 more

netllama 02-21-07 09:16 PM

Re: 3D accel only works over VGA, not DVI (7800GS)
 
glxinfo is a command line tool, you need to run it from a terminal window.

According to your bug report, you're using the 'nv' X driver, and not the 'nvidia' X driver.

usr/thomas 02-22-07 02:02 AM

Re: 3D accel only works over VGA, not DVI (7800GS)
 
1 Attachment(s)
thanks for being so patient.

thanks for the tip on glxinfo, below is the output as it appeared in the terminal screen.

also attached is a new bug report, which does show "nvidia" as the driver in the .conf

the first report prob didn't as I ran it after installing the driver but before rebooting, because the problem I am having was that during the reboot the screen would go black with the "no input signal" message though the boot process would continue (judging from the HDD activity light); sometimes I could cntl+alt+backspace to stop X and it would give me a command line but most times it wouldn't and I'd just have to hit the reset button.

it occurred to me that maybe I could run the bug report from the command line in safe mode, then get back to my old config to get to the generic nv GUI in order to post it. (I had to reinstall pclos several times to get a working system again before I figured out how to restore my my xorg.conf without a total reinstall.)

one thing I did try again this afternoon was to install the nvidia driver from your website (tho pclos says not to). I have tried this before and afterwards, during the verbose boot it would show that HAL failed. now Hal shows ok but this is what I did

installed nvidia 9746 from your webite, didn't work, but HAL ok
reinstalled the dkm-nvidia_97xx pkg from the pclos repository, this wouldn't give me the option to install the proprietary driver for some reason, so...
I uninstalled the dkm pkg and then reinstalled it, now I again got the option to use the proprietary driver, chose yes
rebooted

one thing has changed after all this - instead of the screen going black and giving the "no input signal" message, it drops me to a command line login, where i was able to generate the new bug report.

I'm quite willing to wipe the system and do a fresh install if I've bunged things up too much for the bug report to be useful

glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_EXT_texture_from_pixmap
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5)
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_texture_non_power_of_two, GL_ARB_texture_rectangle,
GL_ARB_transpose_matrix, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_logic_op,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
GL_EXT_framebuffer_object, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
GL_EXT_secondary_color, GL_EXT_separate_specular_color,
GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,
GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias, GL_EXT_texture_object,
GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
GL_ATIX_texture_env_combine3, GL_IBM_texture_mirrored_repeat,
GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
GL_NV_blend_square, GL_NV_point_sprite, GL_NV_texgen_reflection,
GL_NV_texture_rectangle, GL_SGIS_generate_mipmap,
GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x62 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 Ncon

netllama 02-22-07 10:18 AM

Re: 3D accel only works over VGA, not DVI (7800GS)
 
The fact that your glxinfo output has these lines:
direct rendering: No
server glx vendor string: SGI

indicates that you're not using the glx module that ships with the nvidia driver. Therefore, the NVIDIA driver isn't correctly or fully installed.

At this point, you can either seek help from whomever built the NVIDIA driver packages that you're using, or install the official NVIDIA driver package:
http://www.nvidia.com/object/unix.html


All times are GMT -5. The time now is 01:15 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.