nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia-1.0-9746 kernel module doesn't be built in kernel-2.6.20-git15. (http://www.nvnews.net/vbulletin/showthread.php?t=86802)

sangu 02-21-07 08:28 AM

nvidia-1.0-9746 kernel module doesn't be built in kernel-2.6.20-git15.
 
OS : Fedora Development (rawhide 20070221)
Kernel Version : kernel-2.6.20-git15(kernel-2.6.20-1.2936.fc7)

Code:

/NVIDIA-Linux-x86-1.0-9746-pkg0/usr/src/nv$ make SYSSRC=/usr/src/kernels/2.6.20-1.2936.fc7-i686 module
sh ./conftest.sh "cc" "cc" /usr/src/kernels/2.6.20-1.2936.fc7-i686 /usr/src/kernels/2.6.20-1.2936.fc7-i686 cc_sanity_check full_output
sh ./conftest.sh "cc" "cc" /usr/src/kernels/2.6.20-1.2936.fc7-i686 /usr/src/kernels/2.6.20-1.2936.fc7-i686 select_makefile full_output
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1

Please See : http://bugzilla.livna.org/show_bug.cgi?id=1419

netllama 02-21-07 11:05 AM

Re: nvidia-1.0-9746 kernel module doesn't be built in kernel-2.6.20-git15.
 
What is the output from the following command:
rpm -qa | grep kernel

Thanks,
Lonni

19721201 09-12-07 12:33 AM

Re: nvidia-1.0-9746 kernel module doesn't be built in kernel-2.6.20-git15.
 
I am having the same problem on a Xen 3.1.0/Gentoo 2.6.20-r3 AthlonXP system. I'm following baco's method of applying Xen patches to the Nvidia driver but to no avail. I don't have rpm installed, so I can't get the output of that command but here's what I'm getting from uname -a:

Code:

Linux localhost 2.6.20-xen-r3 #1 Wed Sep 12 00:53:45 EDT 2007 i686 AMD Athlon(tm) XP 2600+ AuthenticAMD GNU/Linux
And at present my linux-headers are 2.6.22-r2. Am I missing some obvious environment variable or do I need to downgrade my kernel to an older Xen release? Any thoughts? Thanks in advance!


All times are GMT -5. The time now is 07:03 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.