nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   v4l module + nvidia 9xxx drivers = Xorg crashing (http://www.nvnews.net/vbulletin/showthread.php?t=87002)

punky 02-24-07 08:12 AM

v4l module + nvidia 9xxx drivers = Xorg crashing
 
2 Attachment(s)
Hello,

When I try to enable the v4l module in my xorg.conf, Xorg and KDE start fine, but crash when I try to launch something related to Xv (xvinfo, xdtv, ...).
Here is an extract from the console output when the crash occurs :
Quote:

[...]
(II) NVIDIA(0): v4l: memPhysBase=0xd0000000

Backtrace:
0: /usr/bin/X11/X(xf86SigHandler+0x6d) [0x4802ed]
1: /lib/libc.so.6 [0x2b55f51d0110]
2: /usr/bin/X11/X(Dispatch+0x120) [0x4480b0]
3: /usr/bin/X11/X(main+0x44d) [0x430f6d]
4: /lib/libc.so.6(__libc_start_main+0xda) [0x2b55f51bd4ca]
5: /usr/bin/X11/X(FontFileCompleteXLFD+0x9a) [0x43026a]

Fatal server error:
Caught signal 11. Server aborting
Here is my config :
Software :
Linux heyyourself 2.6.18-4-amd64 #1 SMP Wed Feb 21 14:29:38 UTC 2007 x86_64 GNU/Linux,
Up-to-date Debian Sid amd64,
Xorg 7.1.0-12 with Nvidia beta drivers 9746 from the experimental Debian repository.

Hardware :
GeForce 7300 LE PCI-express,
MSI K8N neo4.

You can see in my xorg.cong file some options enabled to make Beryl work fine. I also tried to make v4l work without all these options, but it still crashes.



Could you help me please ?
Do you have any idea ?

punky 02-25-07 06:39 AM

Re: v4l module + nvidia 9xxx drivers = Xorg crashing
 
1 Attachment(s)
Oups, I forget the bug report ...

Cheers.

energyman76b 02-25-07 10:46 AM

Re: v4l module + nvidia 9xxx drivers = Xorg crashing
 
try updating the v4l driver to the latest version (0.1.1).

punky 02-25-07 02:33 PM

Re: v4l module + nvidia 9xxx drivers = Xorg crashing
 
Hello,

I already have this version of v4l :
Quote:

(II) LoadModule: "v4l"
(II) Loading /usr/lib/xorg/modules/drivers/v4l_drv.so
(II) Module v4l: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 0.1.1
ABI class: X.Org Video Driver, version 1.0

energyman76b 02-25-07 05:56 PM

Re: v4l module + nvidia 9xxx drivers = Xorg crashing
 
Hi,

well I had v4l related crashes and an updated to the latest xorg version (server), solved it.

See also:
http://bugs.gentoo.org/show_bug.cgi?id=157573

punky 02-26-07 04:57 AM

Re: v4l module + nvidia 9xxx drivers = Xorg crashing
 
Hello,

Well, I'm glad to see I'm not the only one, but unfortunatelly xserver-xorg 7.2 isn't yet in debian repo ...

Thanks for your help.


All times are GMT -5. The time now is 06:23 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.