nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   x86_64-1.0-9746 freezes OpenSuse 10.2 (http://www.nvnews.net/vbulletin/showthread.php?t=87104)

Nukem36 02-26-07 11:37 AM

x86_64-1.0-9746 freezes OpenSuse 10.2

I do have a massive problem with drivers of the NVIDIA-Linux-x86_64-1.0-9xxx series. None of them works at all!

What happens is, that installation etc. works properly as usual. When starting

sax2 -r -m 0=nvidia

the computer freezes reproduceable all the time. Cause I'm not able to access the computer even via ssh after that, I'm not able to post here any logfiles or output of the error-log utility, cause nothing exists!

I tried several 9xxx- versions, all with the same result.

I found out, that something's wrong when the module nvidia.ko is build. When I try the following:

modprobe nvidia

I get the message:

FATAL: Error inserting nvidia (/lib/modules/ Invalid module format

I think that's the problem! Something does not work correctly when building the module.

Additional facts:

I do have another disk with OpenSuse (586) 10.1 installed, where everything works perfect.
I tried the rpm's too, same negative result.

Linux l2.6.18.2-34-default #1 SMP Mon Nov 27 11:46:27 UTC 2006 x86_64 x86_64 x86_64 GNU/Linux

GeForce 6200 (0x0221)

Could anybody help me out of here?



dougmc 02-26-07 09:28 PM

Re: x86_64-1.0-9746 freezes OpenSuse 10.2
I've got a similar problem, but using Fedora Core 5. I've tried several versions of the NVIDIA driver, but it doesn't matter. If I use a 2.6.17 kernel, things work -- but as soon as I go to a 2.6.18 kernel, things break.

I can reproduce it at will -- boot a 2.6.18 kernel, reinstall the driver, then let X start -- it crashes. boot a 2.6.17 kernel, reinstall the driver, let X start -- it works.

As soon as X starts, the computer locks up. Loading the module doesn't do it -- it's X starting that does it.

I also have a GeForce 6200 card --

(--) PCI:*(1:0:0) nVidia Corporation GeForce 6200 rev 161, Mem @ 0xf2000000/24, 0xe0000000/28, 0xf3000000/24
(II) NVIDIA(0): NVIDIA GPU GeForce 6200 at PCI:1:0:0 (GPU-0)

and my motherboard is an Nforce 3 model, running an Athlon X2 3800 chip, running x86-64. I guess I should do try again to track it down, and file a proper problem report, since it looks like it's not just me.

One thing that doesn't make much sense with your post --

FATAL: Error inserting nvidia (/lib/modules/ Invalid module format

if the module can't be loaded, I wouldn't expect that to crash the system -- it should just keep X from starting. (on my system, the module starts up fine.)

netllama 02-26-07 09:43 PM

Re: x86_64-1.0-9746 freezes OpenSuse 10.2

dougmc 02-26-07 10:02 PM

Re: x86_64-1.0-9746 freezes OpenSuse 10.2
2 Attachment(s)
netlama -- Yeah, I've been through that many times (But maybe Nukem36 hasn't, and I have hijacked his thread, after all. On the plus side, our setups and problems are very similar, so any resolution I get might help him. He could always try a 2.6.17 kernel -- that might be a good workaround.)

I'm doing a formal bug report now. Included are two nvidia-bug-report.log files --

One, with a 2.6.17 kernel, shows everything working correctly. X is up and running and all is stable and well.

One, with a 2.6.19 kernel (looks like I got an update from the 2.6.18 one) has nvidia.ko loaded, but X has not yet been started, because the entire system locks up as soon as X is started. But other than the kernel, and the NVIDIA driver being reinstalled each time, both are from the same system, both taken minutes apart with the system freshly booted. (The 2.6.19 version had the system booted into single user mode, if that matters -- it was the easiest way to stop X from starting, but it'll crash in normal user mode just fine, and indeed, right after getting the nvidia-bug-report.log file, I put it into normal mode, services start, then where it would start X and ... crash. Screen stays blank, system can't even be pinged.)

Note that the 2.6.19 version has the kernel booted up with `pci=nommconf idle=poll' and the 2.6.17 version does not. (But 2.6.18 crashed without these options, and I'll assume that 2.6.19 will as well.)

I am using the most recently released bios for my motherboard.

Nukem36 02-27-07 11:02 AM

Re: x86_64-1.0-9746 freezes OpenSuse 10.2

thanks for all the hints. I already read the posts you mentioned, but they didn't really help me out here. I agree with you dougmc, we seem to have the same problem. I do have problems using a 2.6.17 kernel , cause ther's only a (the default kernel coming with the distribution) available in the moment.

I played a little with building the nvidia.ko from sources. Just by doing a

make module
make install

I got a nvidia.ko loading normaly with modprobe! The module didn't really work with sax2, but the system didn't crash anymore. So for me this is a hint that something's going wrong when building the module via nvidia-script!? As far as I now it's a must that modules load normaly with modprobe before using them. I'm quite shure that something is buggy here.

Unfortunatly I wasn't able to generate any nvidia-bug-report.log file, cause the system crashes realy hard. But I'll do some other tries to receive one!?

If I had found a description howto build the complete modules manually I would do so, trying to get more detailed information where the problemis really located!?

Maybe dougmc's reports help the nvidia programmers to help us both!

Thanks a lot for further help


Nukem36 02-28-07 02:12 AM

Re: x86_64-1.0-9746 freezes OpenSuse 10.2

Again me. Up to here I didn't find a way to generate a report logfile. I tried the following:

Boot init 3 (no X11 start)

installed the driver with "sax2 -r -m 0=nvidia"

system crashes

restart pc with init 3

try to make the report file with script, but file is empty!?

uninstall driver and "sax2 -r -m 0=nv"

to be able to post here.

Is there another chance to generate the necc. report file?

Thanks for your help!



Nukem36 03-02-07 05:51 AM

Re: x86_64-1.0-9746 freezes OpenSuse 10.2
High there!

my problem still exists. Anybody out there who may give me some help or hints?




All times are GMT -5. The time now is 05:03 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.