nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Sync to Vertical Blank aborts in TwinView setup (http://www.nvnews.net/vbulletin/showthread.php?t=87108)

downey 02-26-07 12:11 PM

Sync to Vertical Blank aborts in TwinView setup
 
1 Attachment(s)
I have setup TwinView using two Samsung 205BW monitors with my 8800GTX and everything works fine as long as I don't enable vertical synch.

Here are my tests with glxgears:

No __GL_SYNC_TO_BLANK:
114939 frames in 5.0 seconds = 22987.681 FPS
119124 frames in 5.0 seconds = 23824.795 FPS

__GL_SYNC_TO_BLANK=1:
Aborted

I have found that if I turn off TwinView and only have one monitor working then everything works correctly, and glxgears reports ~60FPS. So the problem is something to do with TwinView. I have also tried setting __GL_SYNC_DISPLAY_DEVICE=DFP-0 but that didn't seem to make a difference. I have also tried it with and without the composite extension enabled.

Has anyone run into this problem? Or been able to use __GL_SYNC_TO_VBLANK under TwinView? Any help would be appreciated.

Thanks.

Attached my bug-report.log

AaronP 02-26-07 12:37 PM

Re: Sync to Vertical Blank aborts in TwinView setup
 
Hi downey,
This problem should be resolved in the next release.

downey 02-26-07 01:11 PM

Re: Sync to Vertical Blank aborts in TwinView setup
 
Great, thanks.


All times are GMT -5. The time now is 05:38 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.