nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X freezes when trying to use GeForce FX 5500 (http://www.nvnews.net/vbulletin/showthread.php?t=87238)

doctor detroit 02-28-07 08:30 AM

X freezes when trying to use GeForce FX 5500
1 Attachment(s)
I'm a new Linux user - about a week into my first Linux system. I've spent four of those seven days just trying to get my graphics card to work, so you'll have to forgive me if I'm not as knowledgeable as some...

Whenever I finish installing whichever driver I'm attempting to use at whichever given moment (which always seems to work correctly at the time), I restart my computer and enable the PCI as the default video device in BIOS, and the computer will restart and Ubuntu will freeze during boot up. I don't know enough about what goes on at what particular time during booting, but when the logo is on the screen and the little bar beneath it is filling up, it -always- locks when it jumps into the third section. If that tells you anything.

I followed the NVidia/Linux install guide to the letter and had the same result as all the other (unofficial) instructions I've received. I've completely ruined and had to re-install Ubuntu 3 separate times now - I'd rather not have to do it a fourth.

I'm using:
HP a1030n (official HP page is here.)
Intel P4 530 3GHz
82915G onboard graphics controller
NVidia GeForce FX 5500

Ubuntu Edgy
2.6.17-11-generic kernel
All the required software to run the installer.

I've attached the installer.log file, but the bug report is too large to include. (152.9KB text file).

This strikes me as odd.. Here's the what my xorg.conf looked like after the installer did its thing:

Section "Device"
Identifier "Intel Corporation 82915G/GV/910GL Express Chipset Family Graphics Controller"
Driver "nvidia"

I'll be happy to provide any other info you may need.


whig 02-28-07 01:53 PM

Re: X freezes when trying to use GeForce FX 5500
The nvidia bug report you include shows the results with Intel graphics - not nvidia so it's hard to put a finger on the problem. You shouldn't need to reinstall an OS because of graphics problems - just boot to single user mode and remove the automatic starting of xdm/gdm/kdm - whatever your sesssion manager (ie gui logon) is, and reboot again (or "telinit 3" may work). From the console "startx" starts the gui.

Having distribution (eg Ubuntu) packages of nvidia and running the nvidia installer manually can cause conflicts and breakage - there should be only one driver in other words. Remove the previous driver before installing the next.

For new users it is probably better to stick to distribution packages and not perform a manual install.

In any case please remove this from xorg.conf,

        Load    "dri"

doctor detroit 02-28-07 03:30 PM

Re: X freezes when trying to use GeForce FX 5500
I guess I generated that bug-report when I executed the command, then. Sorry. I didn't think it would contain anything relevant as I've never been able to get the OS up with the card enabled - not in restore mode, not a command line, nothing - it freezes almost as soon as it starts loading.

I did find the load "dri" in xorg.conf in the modules section. there's also a load "glx" line, too. does that need to stay or go?

The part about this whole thing that throws me is how I'm supposed to configure and enable a device that's disabled in BIOS(nvidia), while using the device that interferes with it and will ultimately end up as the disabled device (intel).

I may be a Linux newbie, but I've had a computer of one sort or another since '86.. I'm no stranger to a command prompt, I'm just a stranger to the linux shell. As I said, I've been racking my brain on this for four (going on five) days now, and I've tried quite a few methods of makng this thing work.

The very first thing I tried after my initial Ubuntu install was Alberto Milone's Envy script. After that attempt failed, and since I didn't yet know what xorg.conf was (or how to find it), I did a re-install.

I dug around some more and found a couple how-to's for the open-source drivers, and I even had the card working for a while, but I had no 3D capabilities and for a time was stuck in 640x480 mode. I kept playing and tweaking, downloading everything I could get my hands on, corrupted a handful of files, and locked myself out of the GUI. Luckily, I have SLAX on a USB stick, and I was able to restore enough backups to get the thing running on my Intel graphics controller.

Since then, I've read a few more articles and made a post on the Ubuntu forums, where someone (erroneously) told me that since I was running the generic kernel, I'd have to switch over to the 386 kernel. No problem - Synaptic makes that real easy. The only problem being that this machine has dual-processors, and the 386 kernel doesn't support that. That led to install #3.

Something I've noticed, especially on Ubuntu and Debian forums: There are literally hundreds and hundreds of posts from people having various quirky problems making their particular NVidia card work properly (or just the way they want it to) on their particular OS. And for every one of those problems, there's 5 or 6 people with various answers - and all of them are different. No two people are having the same issue, and each issue has half a dozen possible fixes that may or may not even address the issue at hand. I'm enjoying learning my new OS (especially having migrated from XP), but I don't yet know enough about what I'm doing to go through every single post and read every single reply and try and piece together a solution that may or may not work for me. So I figured I'd come straight to the source.

This is still a fresh OS. The only tinkering I've done (aside from updates) is run the NVIDIA-Linux-x86-1.0-9746-pkg1.run installer.The program said it couldn't locate a kernel, so it compiled one, xconfig did its thing and said it was successful (but produced an xorg.conf with the nvidia drver being used under my Intel chipset...), but when I try and run the machine under that configuration it freezes. Same spot every time.

How can I disable the load "dri" line and run with that xorg.conf when it ponts to the intel chipset (which is going to end up disabled in BIOS)? Some of the how-to's I've read say that agpgart and intel_agp need to be blacklisted in /etc/hotplugs/blacklist for NVIDIA to work. Others say that the section "device" need to look like this:

Section "Device"
Identifier "NVIDIA GEFORCE FX 5500"
Driver "nvidia"
BusID "PCI:x:x:x"
VideoRam 256000
Option "NvAGP" "x"
Others tell me that this:

Section "Device"
Identifier "Intel Corporation 82915G/GV/910GL Express Chipset Family Graphics Controller"
Driver "nvidia"
is perfectly fine and can't understand why it doesn't work.

I guess I've taken in too much information in too short a timespan and now I'm just confused as to where to go next.

If there's any other info I can provide about my setup or whatever, I'd be happy to.

Thanks, Whig.

whig 02-28-07 05:40 PM

Re: X freezes when trying to use GeForce FX 5500
Straying off the beaten track, for newcomers to anything, is not recommended. In time one can do it - no doubt about that - too soon is diving in the deep end.

Yes, there can be many, many ways to achieve the same thing. I suggest you try the Ubuntu way, ie Ubuntu nvidia packages. The nvidia installer has this option you should run first,

      Uninstall the currently installed NVIDIA driver.

Install the .debs (which should handle necessary kernel modules) and edit xorg.conf,
- remove the loading of dri module
- keep the glx module
(I'm not sure how Intel graphics handles the above)
- the "Screen" section references a "Device" section by a name you give, it can be "Intel Corporation 82915G/GV/910GL Express Chipset Family Graphics Controller" or "mycard" - up to you - the names you give have to be the same in both places
- your main "Device" section needs to have a 'Driver "nvidia"' (multiple device sections are possible but you will only use 1 at a time)
- reboot to enable the nvidia card in bios
- "startx"

Retief-CDT 03-01-07 11:00 AM

Re: X freezes when trying to use GeForce FX 5500
Since you mention a onboard video chip I thought I would post what I know from installing to SUSE Linux. In order for a add on video card to work when there is more than one video whether disabled or not in BIOS. SUSE requires you to tell which card that Xorg is using. This is done by first finding the number of the card by at command prompt sax2 -p
This will list which video cards are available. Now after installing the Nvidia drivers you tell Xorg by entering
sax2 -r -m -c1 0=nvidia note:0 is a number and c1 is the cards number.
I don't know if this helps.

All times are GMT -5. The time now is 08:35 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.