nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   97.46 fc6 x86_64 DPMS, XVideo, etc. issues (http://www.nvnews.net/vbulletin/showthread.php?t=87365)

r.c. 03-01-07 09:43 PM

97.46 fc6 x86_64 DPMS, XVideo, etc. issues
1 Attachment(s)
Hi, I've been doing some work on a new Fedora Core 6 system, and am having some issues with the nvidia / Xorg combination.

The first issue is fairly straightforward. Using a stock FC6 x86_64 system, updated to current yum update, I can't use DPMS. This is filed under https://bugzilla.redhat.com/bugzilla....cgi?id=229302

In the xorg.conf, I have dpms turned on in the Monitor sections:
Option "DPMS"
I also tried Option "dpms" in case case sensitivity changed, but neither made a difference, and both
used to work on earlier Fedora Core 5 and previous installs.

In the Xorg.0.log file, I see that the option is read and acted on by the driver by lines such as:
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled

There is also a couple lines like the above for the other head of the display, NVIDIA(1)

If I run xset q, the dpms section says:
DPMS (Energy Star):
Server does not have the DPMS Extension

# xset +dpms
server does not have extension for +dpms option

and so on for any of the other dpms commands.


Since I apparantly was not content to simply have one thing not work, I went ahead and forged on with some other things I was interested in. When I next looked, I was also missing the XVideo extension (and apparently some other modules I don't yet care about). If I run X with no xorg.conf file and let it autodetect everything, it sets itself up pretty well with the open source nv driver, and supports XVideo and dpms properly.

Since I didn't notice the lack of XVideo initially, and have updated kernels and modified the nvidia driver package since then, I am not sure whether or not the XVideo extension was working or not with the stock fc6 system and unmodified nvidia installer I used above. Given that please treat the rest of this as potentially a different issue than the more straightforward dpms issue above, and even if we get bogged down on this part, maybe we can get the dpms thing worked out.

Now, for details on recent changes that could be relevant:

I updated to the latest real time patched kernel from http://people.redhat.com/mingo/realtime-preempt/ ( more specifically, http://people.redhat.com/mingo/realt...rt8.x86_64.rpm )

I then discovered he'd compiled with gcc4.0 instead of the default 4.1.1 of fc6, and I therefore couldn't compile the nvidia driver glue code. So, I went ahead and got the src packages, set them up, and rebuilt the kernel and kernel-devel rpms, and installed them. I did make a few changes to the config - one thing I wonder about now is the fact that I cleared the "Create deprecated SYSFS files". It occurs to me that the nvidia driver might use those? I saw something about that when I searched the forum, but it was looking like in that case it was causing crashes on X init, which I got through just fine.

In any event, after rebooting into the newly compiled kernel, the nvidia-installer got through the gcc check, but then had issues with some changed symbols thanks to the rt patches I suppose. I replaced "SA_INTERRUPT | SA_SHIRQ" with "IRQF_DISABLED | IRQF_SHARED" in the relevant places in nv.c as suggested in http://www.nvnews.net/vbulletin/show...t=77597&page=2 and was then able to build successfully and complete nvidia-installer's run. I did not have to do any of the other patches referred to in that thread (I am not running Xen), and X starts up with no crashes.

I can use xterm, random X programs, etc., but I don't have XVideo (or dpms) capability. If I run nvidia-settings, I get two lines of "Xlib: extension "XVideo" missing on display ":0.0"." printed to the console before the program continues. Presumably because of that, I have a bunch of missing settings (like XVideoTextureSyncToVBlank, etc.)

So... any ideas? I'm attaching the results of nvidia-bug-report.sh. Before we get too deep into the preempt/rt potential issues, hopefully we can at least get the stock kernel DPMS issue resolved.

Thanks for any help.

netllama 03-01-07 09:50 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
Do all of these problems persist with a stock FC6 kernel ?

Please post the output from 'glxinfo', 'xdpyinfo', 'xvinfo' and 'xset q'.


r.c. 03-01-07 10:19 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
As posted above, the dpms issue is with a stock fc6 kernel (as well as the new kernel). I'll reinstall a stock kernel and recheck the XVideo issue.

r.c. 03-01-07 10:36 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
1 Attachment(s)
Ok, just reinstalled the stock 2.6.19-1.2911.fc6 kernel and reinstalled the unmodified nvidia driver (with it removing the old driver). All the problems I mentioned remain. DPMS doesn't show as a loaded server extension (though it shows as a line in the X log), and the XVideo extension is not loaded either.

Here is the output from the files you requested. I zipped them up since they were a bit big.

Thanks for the quick response, by the way.

netllama 03-01-07 10:43 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
Thanks. I'd like to see the same output when you're using the 'nv' X driver.

r.c. 03-02-07 04:32 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
1 Attachment(s)
As requested, here are the results of:
[root@dev3 nvlog]# glxinfo > glxinfo.log 2>&1
[root@dev3 nvlog]# xdpyinfo > xdpyinfo.log 2>&1
[root@dev3 nvlog]# xvinfo > xvinfo.log 2>&1
[root@dev3 nvlog]# xset q > xset.log 2>&1

These are with the nv driver. Note I did not uninstall the nvidia driver, so the default xorg config file tried loading up glx and had issues due to the bad combo of nv vs. nvidia, but ignore that please. My issue isn't with GLX, and you can tell from the attachments at the xorg bug listing I filed that GLX works ok once the nvidia driver is uninstalled. The important part to note from these logs are that DPMS and XVideo both are loading and working properly.

netllama 03-02-07 04:43 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
Something appears to be misconfigured/broken on your system, as you're the first person to report this problem, and I'm not seeing it on any of the FC6 systems that I have here.

How are you starting X on this system?

r.c. 03-02-07 05:07 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
I'm using this for kiosk type work, so no window manager. I just start X with the following line in the inittab (same line I used in previous FC5 builds that all work normally):

x:5:once:su --login --command xinit codec >/dev/null 2>&1

However, to go ahead and anticipate the next question, I went ahead and changed the line back to the original stock fc6 line:
x:5:once:/etc/X11/prefdm -nodaemon

And then telinit 3 and 5'd the system, logged in through gdm, and checked the situation again. Still no XVideo and still no DPMS.

Is there a package during the FC6 install I might have missed that is needed for the nvidia module to support dpms and xvideo which is not needed by nv to to do the same?

netllama 03-02-07 05:24 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
I believe that xv support is in the driver itself. DPMS is part of the core X server bits.

I'm not sure how you've reconfigured this system, but at this point, I'd suggest either backing out the changes one at a time until you determine what caused this, or starting with a fresh install, and testing after each change. Either way, it seems unlikely that this is an nvidia driver bug, and even if it is, I'd need you to provide me with details on how to replicate it.


r.c. 03-02-07 05:57 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
as of the last post, it was a completely stock system. What I had changed (inittab, kernel) had been rolled back. The xorg.conf was set up to support dual head, but was using the same xorg.conf I've used in the fc5 systems (can't exactly roll back that file, since the "stock" one isn't a multihead config).

I'll start over on a fresh hard drive and note what packages I select for install.

As I'm doing this, if you don't mind, reassure me... you have in fact seen a dual head (not twinview) nvidia driver based system running a completely up to date FC6 *64 bit* install running? For bonus points, was it a Core2 based system on an Asus P5B Deluxe board with a dual-dvi 7300GT card?

Note, it *looks* like it runs fine, in terms of just starting up typical X programs, but you have actually seen DPMS and XVideo running on an install like that?

I'm going to try it from scratch anyway, but I'd appreciate the knowledge that this is in fact a config someone has seen fully working before. I went a week thinking everything was working before I noticed the DPMS and XVideo issue.

This machine by the way ran fine on another FC5 install (seperate hard drive, all the FC6 stuff has been from a clean install) so I don't think there's any hardware issues.

netllama 03-02-07 06:09 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues
Yes, I've setup a few FC6-x86_64 systems that run 'yum update' every day, and none of them have had these problems (and no one else has reported them either).

AaronP 03-02-07 06:38 PM

Re: 97.46 fc6 x86_64 DPMS, XVideo, etc. issues

Load "extmod"
to the "Module" section of your xorg.conf.

All times are GMT -5. The time now is 07:38 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.